@littlehui said in emulationstation can not lauche: lima driver only support opengl es. Is this the problem? No, actually is the other way around - Emulationstation needs OpenGL ES for your system to work, but it relies on SDL2 to offer that. If your SDL2 library is not compiled with OpenGL ES support, then it won't work. The RetroPie-Setup script takes care of compiling or installing such SDL2 version (for Raspberry PI at least), I'm not sure your system provided SDL2 library has GL ES support and - also important - accelerated GLES support from the Lima driver.