Please do not post a support request without first reading and following the advice in

Macintosh (Basilisk II) 8-bit Color

  • Global Moderator


    I do appreciate it, but it's probably best that it be compiled and installed as your guide intends or else we'll just be asking for trouble.

  • I tried to run the BasiliskII executable from a location other than the standard location (i.e. /home/pi/ instead of /usr/local/bin/). It appears to need a config file (i.e. /home/pi/.basilisk_ii_prefs), a ROM for the virtual Mac and a hard disk image for the virtual Mac (both can be nicked from the PoP Mac total Pack). And BasiliskII needs to be started from within LXDE. One might try to find a good tutorial to install and start LXDE in RetroPie and do an experiment w/ the BasiliskII executable that I posted. Might save one the time and trouble of compiling it from source...

    Good luck everybody. :-)

  • Global Moderator

    Last night, I was fortunate enough to stumble onto somewhat of a solution to this problem. Using the runcommand-onstart, we can now set the framebuffer to 8-bit color on launch by adding:

    if [ "$2" = "basilisk" ]; then
    fbset -depth 8

    With this enabled, games running in 8-bit color will now be visible. From here, I want to reset the default color depth on exit in the runcommand-onend script. Am I correct in assuming that the default color depth is 16-bit 32-bit?

    if [ "$2" = "basilisk" ]; then
    fbset -depth 32

  • administrators

    @mediamogul it's 32 bit now.

    I could probably add some framebuffer depth setting to runcommand. Ill look into it.

  • Global Moderator


    Oh wow, that would be fantastic. Thanks.

  • administrators

    @mediamogul I haven't looked into it too extensively but there are some colour type Macs for the minivmac emulator though currently the macplus is the only binary it compiles

  • Global Moderator


    Very keen! My childhood best friend had a Macintosh Plus. I think that was the first time I ever played 'Deja Vu'. Has SheepShaver ever been considered for Retropie? If I remember right, it's capable of emulating a PowerPC up to System 9.0.4.

  • Global Moderator

    Just tested 'Prince of Persia 2: The Shadow and the Flame' and it runs like a champ with the framebuffer set to 8-bit color depth. A runcommand setting would indeed be most helpful for games that require a higher color depth, as the screen now turns black when the emulated Mac is set to "Thousands of Colors". It's been a long time coming, but it was well worth the wait to play this great game again. I'm marking this as solved. Thanks again @Meneer-Jansen and @BuZz for your help with this.

  • administrators

    @mediamogul I made a ticket for myself on the issue tracker. Nice find btw. Strangely I did try switching framebuffer depth before and it didn't work. I obviously did something wrong or a firmware change has affected something. Nice one!

  • Got this all working today with a "1gb hard drive". Now i notice on the pi the mouse skips. Which makes using paint impossible. Closing stuff gets to be a pain too. Is it possible to have the mouse working a little better? On windows obviously it is flawless. Im going to install doom for fun just to see how bad it runs.

  • Global Moderator


    The mouse doesn't skip on mine for whatever reason. I've even tried it with a few mouse-based games and it's pretty smooth.

  • @mediamogul strange. I have it with a premade 30mb drive and the 1gb one i made. The skip is so big that the blue squares on the background are slightly smaller than the space between each mouse jump. I watched a youtube video where the guy had the same issue.

  • @mediamogul also this is on os 7.5.5 with several performa roms and a quadra 650 rom. On a pi 3 i might try a fresh install as i used the files from a premade image.

  • Global Moderator


    Mine is MacOS 8.1 with a Performa ROM. My basiliskii.cfg contents may help:

    extfs /
    seriala /dev/ttyS0
    serialb /dev/ttyS1
    udptunnel false
    udpport 6066
    bootdrive 0
    bootdriver -62
    ramsize 67108864
    frameskip 2
    modelid 14
    cpu 4
    fpu true
    nocdrom false
    nosound false
    noclipconversion false
    nogui false
    jit true
    jitfpu false
    jitdebug false
    jitcachesize 8192
    jitlazyflush true
    jitinline true
    keyboardtype 5
    keycodes false
    mousewheelmode 1
    mousewheellines 3
    dsp /dev/dsp
    mixer /dev/mixer
    ignoresegv true
    idlewait true

  • @mediamogul well i found out the issue. for some reason it does not like my apple iie mouse. hopefully i can figure the issue out. i even play all my doom mods with this single button mouse. i ended up making my cfg like yours except that i have my ram up to 138412032. thanks for the help.

  • I just tested and it actually skips in everything. Just never noticed before. This suxx...

  • Global Moderator

    @edmaul69 said in Macintosh (Basilisk II) 8-bit Color:

    i even play all my doom mods with this single button mouse.

    Hah! Too kool.

    I just tested and it actually skips in everything. Just never noticed before. This suxx...

    Maybe it's just getting gummed up. It is one of the old ball-type mice right? Is it easy to take apart to clean?

  • @mediamogul i am having trouble trying to install os 8 on basilisk ii on windows. I have an os 8.0 iso as my cd rom drive, 7.5.5 recognizes the files. But using the 7.5.5 image or a fresh image i cant get it to work. Are you able to tell me which rom you are using? Ie: quadra 900 (might have a much longer name) and cpu type. And are you choosing to boot from cd when it is launched? I get a black screen if i dont and i get the checkerboard screen if i do but windows immedietly has an error and crashes.

    Edit: with a blank hard drive and the os 8.iso as my cdrom drive choosing to boot from cd rom if i use the quadra 650 rom i get told about the startup disk wont work on this mac. But it brings up the b&w screen but then immedietly crashes if i try the quadra 900 rom. Im not sure how to get the basilisk on the pi to force boot the cd to see if i can install it on there. You said you used a performa rom. Curious about that.

  • Global Moderator


    I setup my installation last May, so my memory on the details is more than a little hazy. However, looking over my backup files, I appear to have actually used a Quadra 900 Rom and a MacOS 8.1 install ISO.

  • @mediamogul ok. I will try to find the 8.1 install instead of the 8.0.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.