Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

  • Hi everyone,

    I am totally desperate. I have tried to connect my PS3 controller for months, but it's being impossible. I have to say I am not a Linux specialist.

    I have installed PS3 controllers from Retropie Setup (Retropie-setup -> Manage Packeges -> Manage drivers packages -> ps3controller). Then I installed the clone support for Shanwan. I plugged my Shanwan controller, it vibrated then I disconnected it and pushed PS3 button, but it didn't pair.

    This is my dmesg result for the whole operation:

    Can anybody help me?

    [ 1679.032260] usb 1-1.4: new full-speed USB device number 19 using dwc_otg
    [ 1679.139294] usb 1-1.4: New USB device found, idVendor=054c, idProduct=0268
    [ 1679.139316] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
    [ 1679.139329] usb 1-1.4: Product: PS(R) Gaepad [ 1679.139341] usb 1-1.4: Manufacturer: ShanWan [ 1689.142055] sony 0003:054C:0268.001A: usb_submit_urb(ctrl) failed: -1 [ 1689.142081] sony 0003:054C:0268.001A: timeout initializing reports [ 1689.142579] input: ShanWan PS(R) Gaepad as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.4/1-1.4:1.0/0003:054C:0268.001A/input/input24
    [ 1689.143614] sony 0003:054C:0268.001A: input,hiddev0,hidraw1: USB HID v1.10 Joystick [ShanWan PS(R) Gaepad] on usb-3f980000.usb-1.4/input0 [ 1689.501976] usb 1-1.4: reset full-speed USB device number 19 using dwc_otg [ 1690.310034] input: ShanWan PS(R) Gaepad as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.4/1-1.4:1.0/0003:054C:0268.001B/input/input25
    [ 1690.311104] sony 0003:054C:0268.001B: input,hiddev0,hidraw1: USB HID v1.10 Joystick [ShanWan PS(R) Gaepad] on usb-3f980000.usb-1.4/input0 [ 1690.311295] sony 0003:054C:0268.001B: can't set operational mode: step 1 [ 1690.321100] usb 1-1.4: USB disconnect, device number 19 [ 1690.372592] sony: probe of 0003:054C:0268.001B failed with error -32 [ 1690.651989] usb 1-1.4: new full-speed USB device number 20 using dwc_otg [ 1690.758088] usb 1-1.4: New USB device found, idVendor=054c, idProduct=0268 [ 1690.758108] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=0 [ 1690.758121] usb 1-1.4: Product: PS(R) Gaepad
    [ 1690.758133] usb 1-1.4: Manufacturer: ShanWan
    [ 1700.761790] sony 0003:054C:0268.001C: usb_submit_urb(ctrl) failed: -1
    [ 1700.761816] sony 0003:054C:0268.001C: timeout initializing reports
    [ 1700.762310] input: ShanWan PS(R) Gaepad as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.4/1-1.4:1.0/0003:054C:0268.001C/input/input26 [ 1700.763303] sony 0003:054C:0268.001C: input,hiddev0,hidraw1: USB HID v1.10 Joystick [ShanWan PS(R) Gaepad] on usb-3f980000.usb-1.4/input0
    [ 1701.101704] usb 1-1.4: reset full-speed USB device number 20 using dwc_otg
    [ 1701.933718] input: ShanWan PS(R) Gaepad as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.4/1-1.4:1.0/0003:054C:0268.001D/input/input27 [ 1701.934273] sony 0003:054C:0268.001D: input,hiddev0,hidraw1: USB HID v1.10 Joystick [ShanWan PS(R) Gaepad] on usb-3f980000.usb-1.4/input0
    [ 1701.934434] sony 0003:054C:0268.001D: can't set operational mode: step 1
    [ 1702.032017] sony: probe of 0003:054C:0268.001D failed with error -32
    [ 1702.098566] usb 1-1.4: USB disconnect, device number 20
    [ 1702.331668] usb 1-1.4: new full-speed USB device number 21 using dwc_otg
    [ 1702.436494] usb 1-1.4: New USB device found, idVendor=054c, idProduct=0268
    [ 1702.436503] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
    [ 1702.436510] usb 1-1.4: Product: PS(R) Gaepad [ 1702.436516] usb 1-1.4: Manufacturer: ShanWan [ 1710.531999] input: ShanWan PS(R) Gaepad as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.4/1-1.4:1.0/0003:054C:0268.001E/input/input28
    [ 1710.533055] sony 0003:054C:0268.001E: input,hiddev0,hidraw1: USB HID v1.10 Joystick [ShanWan PS(R) Ga`epad] on usb-3f980000.usb-1.4/input0
    [ 1710.533246] sony 0003:054C:0268.001E: can't set operational mode: step 1
    [ 1710.592137] sony: probe of 0003:054C:0268.001E failed with error -32
    [ 1710.592853] usb 1-1.4: USB disconnect, device number 21

    Thank you in advance.

  • Global Moderator

    @jmperez

    More information about your setup will probably be necessary. The required information can be found at https://retropie.org.uk/forum/topic/3/read-this-first. Also at that same link, take note of the part detailing how to format your posts for log entries.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.