Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

es_systems.cfg file



  • I am using a RP3 with RetroPie 4.2 installed. To limit the access of configuration screens to unskilled users, I edited the /etc/emulationstation/es_systems.cfg file in File Manager and removed the retropie section. How can I restore the Configuration screen back into ES? In the console, I could not navigate to the /etc/emulationstation/ directory. I can't get any farther back than the "pi@retropie: ~ $" directory. Any suggestions appreciated.

    Thanks, davenlina.


  • administrators

    have a read through this so you understand the implications of the edits.

    https://retropie.org.uk/docs/EmulationStation/#editing-es-configs

    also to restore the retropie menu in ES open the setup script and:

    Manage packages >> Manage Core Packages >> RetroPie Menu



  • @davenlina instead of deleting info in es_systems.cfg, put

    <!-- 
    

    On the line above it and

    --> 
    

    On the line below it. That will disable the system that is in between them.



  • @herb_fargus Just a question about restoring the RetroPie Menu. I did this and the retropie config item is not correct. All the other items went from their IDs as they must be in a config file, but this item just says "rpconfig" and there is no help on the right side for it. Do I need to manually edit the es_systems.cfg file? If so, I don't know what to put in the section for rpconfig.


  • administrators

    @flightrisk said in es_systems.cfg file:

    no help on the right side for it

    You mean there is no description? Idk. I haven't removed the retropie menu so I don't remember what's regenerated, but I would assume the intended result would be to have it create the menu as it is on first boot. If something isn't showing up proper then make sure you don't have an errant es_systems.cfg overriding the default.



  • @herb_fargus Yes, it is the strangest thing. I did recreate everything except for the rpconfig menu. It shows only the word "rpconfig" instead of "retropie config" and there is no help, no icon in the icon/video window to the right. It works, but is just not pointing to things. Are you saying to look for other es_systems.cfg or go through the entries in that file?



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.