Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

[Video Screensaver] Retropie-Themed Screensaver



  • Hi All !

    I try to install screensaver but I result a Black Screen.
    I have emulationstation v2.6.2RP and i put a video in "/home/Pi/RetroPie/Screensavers/The Legend of Zelda (SNES) Screensaver for RetroPie.mp4"

    Here my gamelist.xml

    My config in Emulation Station :

    UI Settings

    • Screensaver after : 1m
    • Screensaver behavior : Random Video
    • Gamelist View Style : Detailed

    Video Screensaver Settings :

    • Swap Video after 30s
    • Use OMX Player for Screensaver ON
    • Screensaver Controls ON
    • Show Game info on Screensaver NEVER
    • Strech Video on Screensaver OFF

    Other Settings :

    • Vram Limit 120mb
    • Power Saver Mode DISABLE
    • Use OMX Player (HW Accelerated) ON

    Thank for help guys!

    TitQuentin ;)



  • @titquentin Hmm, try disabling OMX Player.
    I had a similar issue with ProgettoSnaps video clips, probably due to the way they're encoded, and disabling OMX seemed to fix it.



  • @titquentin Did you check case sensitivity on your commands? This is mandatory for right use. In my config I setted video in head of the xml files... but this isn't the keyfault imho :)

    <?xml version="1.0"?>
    <gameList>
    
    <game><path /><video>/home/pi/RetroPie/screensavers/Tetris (NES) Screensaver for RetroPie.mp4</video></game>
    
        <game>
            <path>./retronetplay.rp</path>
            <name>RetroArch Net Play</name>
            <desc>Set up RetroArch Netplay options, choose host or client, port, host IP, delay frames, and your nickname.</desc>
            <image>/home/pi/RetroPie/retropiemenu/icons/retronetplay.png</image>
        </game>
    


  • Hi guys ! Thx for your reply! ^^

    @supercatfooz

    I'm trying to disable OMX player but doesn't fix my problem...

    @cyperghost

    I check my case sensitivy on my commands. Everything is correct.
    I also try to download your video "vidscreen.mp4" but I still have a black screen.

    alt text
    alt text

    Here 3 pictures of ES :
    https://img11.hostingpics.net/pics/53723520170910091740.jpg
    https://img11.hostingpics.net/pics/33370220170910091754.jpg
    https://img11.hostingpics.net/pics/62140920170910091810.jpg



  • Thank you guys for figuring this out for me!! Now I have a (just one) working screensaver on my EmulationStation!! You guys are awesome!

    Now if I wanted to add more videos to my screensaver, all I have to do is add more lines for the video links right?

    Ex.

    <game>
    <video>/home/pi/RetroPie/screensavers/video_01.mp4</video>
    <video>/home/pi/RetroPie/screensavers/video_02.mp4</video>
    <video>/home/pi/RetroPie/screensavers/video_03.mp4</video>
    </game>
    


  • Also is it possible to disable background music playing while screensaver is playing?? I have mine set to low volume, but even when the screensaver plays, I can still barely hear it. Or not currently possible..



  • @graphicsgod Well ...
    I made suggestion here - I doubt that only one game tag can include several videos.

    Yes it is possible to disable background music - that's not difficult in theorie.
    via pgrep-command look if there is a instance of omxplayer running.
    If yes then STOP background player, if not then CONT player.... it will work fine with mpg123 as mp3 player ;) Then just check the state every 1s ... but this is by no means effective!



  • @titquentin did you ever get this working? im also just getting a black screen



  • @blonqe I also never got this working. For me it seems that the gamelist.xml from the retropie menu doesnt get parsed for videos. What i did is to put the video tags to actual games, for example snes. You can even do this in ES: Select a game, choose to edit this games metadata, and put the full path in the video line.



  • @analoghero

    Thanks for getting back to me, did you have to rename the video files to match the game you were editing?



  • @blonqe No. I named them a bit shorter and all lowercase. sonic.mp4 marioworld.mp4 castlevania.mp4 and so on. I put them in /home/pi/RetroPie/screensavers/. Note that if you do it this way, it will launch the game you attached the video to if you press the a button during the screensaver is displayed.



  • @analoghero said in [Video Screensaver] Retropie-Themed Screensaver:

    @blonqe No. I named them a bit shorter and all lowercase. sonic.mp4 marioworld.mp4 castlevania.mp4 and so on. I put them in /home/pi/RetroPie/screensavers/. Note that if you do it this way, it will launch the game you attached the video to if you press the a button during the screensaver is displayed.

    Thanks @AnalogHero

    I opened my own thread on the situation too and finally came to the same conclusion.

    [https://retropie.org.uk/forum/topic/16228/screensavers-not-working-just-black-screen]

    Working now though so I nearly have my setup as I want it :)

    Cheers



  • @pjft said in [Video Screensaver] Retropie-Themed Screensaver:

    Just to clarify, this is effectively a workaround for people who don't have videos in their metadata, to add a single video for the screensaver purpose. This way a random video out of a collection of one will always be the same.

    Sad but true! The latest version of ES that was able to handle this neat hack is/was ES 2.6.2

    All version > 2.6.2 - the videos have to be linked to real existing ROM files!
    You may use the old binary provided here - use at your own risk and you'll miss some new features like KIOS mode and preselection of game system!



  • Spent hours and learned the hard way that you can't add it to the retropie/gamelist.xml anymore in 2.7.5
    But you can add it to any other system gamelist.xml that has roms
    Really needs a default folder as an option but for now just add the tag to any of your system gamelists

    I don't use videos in ES because of the extreme heat
    But I link 5 videos without names/paths to be discovered by the random video screensaver by simply adding it to the bottom of the nes/gamelist.xml file

    <gameList>
        <game><video>/home/pi/RetroPie/splashscreens/ss1.mp4</video></game>
        <game><video>/home/pi/RetroPie/splashscreens/ss2.mp4</video></game>
        <game><video>/home/pi/RetroPie/splashscreens/ss3.mp4</video></game>
        <game><video>/home/pi/RetroPie/splashscreens/ss4.mp4</video></game>
        <game><video>/home/pi/RetroPie/splashscreens/ss5.mp4</video></game>
        ....
    </gameList>
    

    Works perfect every time and oddly don't overheat the pi while playing.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.