Please do not post a support request without first reading and following the advice in

fatal: Not a git repository (or any of the parent directories): .git

  • Today when I went to update my two Pi3-based RetroPie builds to get the latest Raspberry Pi kernel I noticed an error at the top of the screen:

    fatal: Not a git repository (or any of the parent directories): .git

    Things seemed to update OK, and I'm not sure if this happened previously, but I don't recall noticing it before now. Is this something I need to be concerned with? I'm not even sure how to see what is calling the update. Per my searching online for that error it points to something trying to update when you're in the wrong folder.

    I'm currently at version 4.2.8 (751d970) and I ran the update from the RetroPie-Setup again and got the same message. It's on both Pis, so I don't think it's anything like card corruption.

  • I'll try running the command too... I needed to update the kernel anyways... I'll report my findings.

  • I had the same issue, i deleted the old RetroPie-Setup and re fetched it which fixed the issue.

  • 4.2.9 and I got the same error message updating my Pi3.
    Any clues ?

  • administrators

    You can ignore it - it's just due to some log output and I need to correct the current directory. It's non fatal - just means the git revision isn't in the logfile. (edit: It's now also fixed).

  • @BuZz Thanks!

  • @BuZz thanks!

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.