Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

tried to update joystick selection and it deleted my retropie setup



  • i tried to update joystick selection and it deleted my retropie setup. i cant find what i need to put in the command line to get it back



  • so i followed this guide to manually install everything
    https://github.com/RetroPie/RetroPie-Setup/wiki/Manual-Installation
    and when i type:

    sudo ./retropie_setup.sh
    

    i still get this error:

    ERROR: "/root/RetroPie-Setup" directory not found!
    Looks like you don't have RetroPie-Setup scripts installed in the usual place. Aborting...
    

    my retropie setup is in /home/pi/ and not /root/ . it ran these fine right before it

    cd RetroPie-Setup
    chmod +x retropie_setup.sh
    


  • @edmaul69 as I said on the other thread: looks like you are using the root account!



  • @edmaul69

    when i type:

    sudo ./retropie_setup.sh
    

    i still get this error:

    ERROR: "/root/RetroPie-Setup" directory not found!
    Looks like you don't have RetroPie-Setup scripts installed in the usual place. Aborting...
    

    It's strange! this message is from joystick-selection installation, not retropie_setup!



  • Also, the joystick-selection install.sh script is not intended to be used with sudo. It seems to be the reason of your confusion (you may had installed it with sudo install.sh).

    Anyway, I've just changed the script to make it work fine if the user launch it with sudo.

    My suggestion:

    1. log in to your raspbian as the user pi
    2. go to /home/pi/RetroPie-Setup:
    cd /home/pi/RetroPie-Setup
    
    1. launch retropie_setup script:
    sudo ./retropie_setup.sh
    


  • @meleu well somehow it had killed my retropie setup. when i tried to run the setup script (doing this as pi not root and not using sudo as i am copying and pasting in putty) i kept getting an error about retropie setup not being in root, even though i am running it from the home pi location. so i duplicated it to root and ran it again and i get this error:

    pi@retropie:~/RetroPie-Setup $ /home/pi/RetroPie-Setup/scriptmodules/supplementary/joystick-selection.sh: line 23: unexpected EOF while looking for matching `"'
    > /home/pi/RetroPie-Setup/scriptmodules/supplementary/joystick-selection.sh: line 24: syntax error: unexpected end of file
    > Module /home/pi/RetroPie-Setup/scriptmodules/supplementary/joystick-selection.sh is missing valid rp_module_id
    > Module /home/pi/RetroPie-Setup/scriptmodules/supplementary/joystick-selection.sh is missing valid rp_module_desc
    


  • @meleu so i got it to magically start reading from home pi location. but i had to delete joystick-selection out of the supplementary folder to get retropie setupback. now to try the joystick selection install again



  • so you probably want to correct your github. i kept getting that error on joystick selection under both pi and root. under pi i had to use sudo for it to work. but it is loaded now. now i need to test it out



  • @meleu everything is now all good in the hood. thank you


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.