Please do not post a support request without first reading and following the advice in

  • Hey guys, I finally got Moonlight up and running with all the support in this community. However, I'm running into issues with controller mapping; the controls would either be wrong, or not work at all in game. I tried this with two different Xbox 360 controllers: the Afterglow, and the Microsoft Xbox 360 one.

    I tried using the SDL2 Gamepad Tool to create mappings for these controllers, but whenever I tried to generate the string, I would get the same GUID and mappings for both controllers. The GUID also looked different other GUIDs listed in gamecontrollerdb.txt, so I ran cat /proc/bus/input/devices to determine the GUID that way, but separating each entry with '0000.' I added the mapping generated from SDL2 Game Tool to the end of the GUIDs I made up, and I was able to get the Afterglow controller working. When playing multiplayer on Battleblock Theater, the character on the Afterglow would move just fine, but the Microsoft controller would not move at all.

    Any suggestions on what I'm doing wrong? Any feedback would be greatly appreciated!

  • I'm running into a similar issue as well. Through searching through the moonlight github it seems the move to SDL2 has caused some issues with RetroPie. The developer of Moonlight has stated that they wont bother with fixing the problem as it comes from the way RetroPie handles controllers using SDL2 framework. Something around how the buttons are mapped and what the system sees. I'd love more help trying to track this down as well.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.