Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

START REICAST just crashes at black screen cant get to time/VMU settings



  • RPI3 retropie 4.2
    using the correctly named bios files aka dc_boot &dc_flash, transferred files over via USB not sure if this is the issue. But ive got the dreamcast logo to appear and the start reicast bit has appeared and it doesnt say no BIOS anymore, it just goes black screen and crashes. BIOS files are located in /home/pi/RetroPie/BIOS. Maybe im using the wrong BIOSes. can provide further info any help would be hugely appreciated MDK2 is calling!



  • @tonythetiger you can already check if your bios is correct by looking at the md5 bios table on the wiki and compare it to yours ( https://github.com/retropie/retropie-setup/wiki/Dreamcast ). Also .. MDK2, don't want to sound pessimist but I don't know if it's gonna be playable. DC emu is hit and miss when it comes to 3D games (eg: crazy taxi runs great but powerstone is unplayable)



  • @tonythetiger
    Here is the direction to find out what the md5sum or CRC32 checksums of your BIOSs files are to make sure they're compatible:
    https://github.com/RetroPie/RetroPie-Setup/wiki/FAQ#how-do-i-calculate-the-md5sum-or-crc32-of-a-bios-file

    Here is the list of working BIOS files and their md5sum or CRC32 checksums (to see if yours are on the list):
    https://retropie.org.uk/docs/Dreamcast/#bios

    Also, after you try to run a game that fails, post the contents of /dev/shm/runcommand.log

    Additional information:

    • Make sure you extract (unzip, unrar, un7zip, etc.) your Dreamcast game images (.cdi or .gdi)
    • If you are trying to play both US (.cdi) and Europe (.gdi) games, then you'll want a Region Free BIOS
    • Try downloading the game from a different site


  • @aryetis the CURRENT flash checksum is (U):
    0a93f7940c455905bea6e392dfde92a4= ON LIST.
    I do have another candidate with the following checksum (E):
    23df18aa53c8b30784cd9a84e061d008= ON LIST
    however i am concerned that it is an E region file, and most of the roms are surely gonna be USA (U)
    the boot previously bios checksum is:
    e10c53c2f8b90bab96ead2d368858623 = ON LIST

    I think these are in order:
    Also this seems to think MDK will work, not saying its right but will update as its a nice little resource. I get ya though this stuff is always shaky and it aint exactly a AAA title,
    https://docs.google.com/spreadsheets/d/1AD91IcudqHP7dDmEXLO25Pzb85uUgAy4chU2QxlZBQk/edit#gid=379183179. The issue im having though is i cant even get the START REICAST bit to launch so i can set the time or configure the memory cards.
    After checking they are both on the list ill try and run a more known game. PS when u transfer the ros do u take the whole folder or just the cdi gdi?

    I thinking the problem might be that im transferring them via USB as a pose to SSH or FTP. Please let me know your thought and any further suggestions to trouble shoot.



  • @backstander as seen in my reply to ARYETIS the checksums seem to check out. getting conflicting reports as to whether they should be in /home/pi/RetroPie/BIOS or
    in the data folder, sorry that was vague, thoughts?
    Using my current US region bios im going to try and run shemue.cdi {KALISTO} just now will post error report if i get one but not sure i will cos i cant even get the START REICAST bit to launch atm. Thanks for your reply waiting for more assistance if u may. ill post about the game shortly.



  • @backstander after trying to run sheimu. Same issue as START REICAST screen goes black lookoing as if its about to load but never does.
    output in dev/shm/runcommand.log=
    executing: bash "/home/pi/RetroPie/roms/dreamcast/+Start Reicast.sh"
    ??X creating 3 buffers
    ??X audio output to 'hdmi'
    ??pt/retropie/emulators/reicast/bin/reicast.sh: line 88: 19576 Trace/breakpoint trap "$rootdir/emulators/reicast/bin/reicast" "${paramsQ1}" > dev/null

    sorry about the ??? my screen res aint quite right so i lose the edges. erms also not 100% sure on that Q1 bit in params but thats my output. can u help?



  • @tonythetiger

    PS when u transfer the ros do u take the whole folder or just the cdi gdi

    You just copy the .cdi or .gdi file(s).

    getting conflicting reports as to whether they should be in /home/pi/RetroPie/BIOS or
    in the data folder, sorry that was vague, thoughts?

    /home/pi/RetroPie/BIOS is the correct location for the Dreamcast BIOS files

    sorry about the ??? my screen res aint quite right so i lose the edges. erms also not 100% sure on that Q1 bit in params but thats my output. can u help?

    I'm not see enough information to find the problem. I could be wrong but it looks like your launching "+Start Reicast.sh" and not the actual "shenmue.cdi" game file.

    Do you get to see the part where you enter the time and date?



  • @backstander nah thats what im saying i havent even been able to get to the stage of time and date. the screen just goes black.
    /home/pi/RetroPie/BIOS is the location of the 2 correct checksum bios files, transferred via usb to the rom folder then moved using mv to relocate the files to the correct location.
    ATM ive being using the whole unzipped folder, going to go and try a just cgi or gdi file now, but i think the issue is that the reicast start script isnt launching. Thanks 4 getting back in touch is there anything else u would like me to try or post?



  • @tonythetiger

    is there anything else u would like me to try or post?

    Maybe try re-installing Reicast (the Dreamcast emulator) from the RetroPie-Setup Script -> Manage packages -> Manage optional packages -> reicast -> Update from binary
    https://retropie.org.uk/docs/Updating-RetroPie/



  • @backstander kk gonna try that now i have already updated from source though. ty



  • @backstander after clearing out the roms folder other than the one sheimu game i get the same error message as before:

    ??X creating 3 buffers
    ??X audio output to 'hdmi'
    ??pt/retropie/emulators/reicast/bin/reicast.sh: line 88: 23870 Trace/breakpoint trap
    "$rootdir/emulators/reicast/bin/reicast" "${paramsQ1}" > dev/null,

    updating via binary now



  • still no joy when trying to open +start reicast.



  • @tonythetiger
    Do the games also show up on the list underneath +Start Reicast?

    BTW: MDK2 works for me in reicast with some minor screen artifacts (I usta have that game for the PSX back-in-the-day)!



  • @backstander Yeha they do my man, i have a spare micro sd so trying a fresh install on that. jsyk im following this tutorial to the word



  • @backstander so jelaous man it was a fun fun fun game, WASH YOUR HAND DOCTOR,geez , but in all seriousness thanks for your help so far. hopefully this fresh system will work....



  • kk its fixed as far as i can tell following the above video works perfectly, just be sure to transfer the BIOS over wifi, was the main thing i did different and it eventually worked. give us a shout if anyone gets stuck ive looked at alot of stuff regarding this emulator.



  • @backstander hey buddy ty for all your help finally fixed it turned out youve gotta transfer BIOS'S over wifi, i think was the issue... about MDK2 i got it it works, but could i ask u play 5 mins of it for me, like after the skyfall bit u got a training section i think shoot 2 targets jump on 3 platforms open parachute then use the sniper. SNIPER for me wont work the screen has all graphical issues, seen on youtube ETAPRIME had the same issue was wondering if yours did get past this and if so, woudl u mind emialing me the roms location or the rom?? TYVM, honest wont take more than 7 mins



  • @tonythetiger

    hey buddy ty for all your help finally fixed it turned out youve gotta transfer BIOS'S over wifi

    Great, glad you got it working! That's how I transfer them. I've never actually used the USB flash drive transfer method.

    SNIPER for me wont work the screen has all graphical issues, seen on youtube ETAPRIME had the same issue was wondering if yours did get past this

    I actually have only played it once a couple minutes. Just loaded the game up to see if it would run. I did the skyfall bit but didn't play must past that. I don't even remember seeing the sniper parts.

    I did, however, play Shenmue last night for about 25 minutes. Experience described in this post:
    https://retropie.org.uk/forum/post/96542



  • @tonythetiger
    That "Sniper Mode" bug is a known issue for Reicast. Check out their official compatibility list:
    http://wiki.reicast.com/index.php/Reicast_Compatibility_List?wap2

    I watched a YouTube video of someone on an Android phone using Reicast and they had the same issue (from 2014):

    More information here and here (both are also from 2014):
    https://github.com/reicast/reicast-emulator/issues/76
    http://forums.reicast.com/index.php?topic=122.0



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.