Please do not post a support request without first reading and following the advice in

HELP!!! System just shuts down!

  • I have no idea how to get a log of what's going on, but here's my symptom..

    Power on system
    4 Raspberrys display
    Lots of text about the boot up process (never turned that off yet)
    "Carbon" RetroPie splash screen image displays
    System shuts down (but the power is still on [red light])

    If I unplug the USB drive, and hit ESCAPE on the splash screen, I see text about it trying to connect to the drive, then timing out, then it takes me to something called "Emergency Mode". Looks like I'm logged in as "root", but it says root account is locked. I tried logging in as "Pi" from this point, but it doesn't recognize the account.

    I can't get anywhere! If I have the drive connected and hit ESCAPE like above, I can see all the boot up text, but it never launches ES. It just detects the drive then shuts down. I thought maybe my Mausberry switch was interacting and sending a shutdown signal, so I removed it from the connections. This is all the farther I can get. I don't know what else to try. Is there a way I can SSH into the system from "Emergency Mode" so I can copy/paste some log into ghostbin? Is there maybe a way I can SFTP in and just get a copy of a file? What do I do?

  • @hansolo77 Please share information about all the stuff you have been trying to do to your build. You have been posting a ton of issues with your current set up over the last few days and I am interested in what you have been doing that might be leading to some of these problems.

    I am not saying you are doing anything wrong, I would just like some background as it might help the community trouble shoot your issues.

  • I've got 2 builds going on. The one I built in a Nintendo case is the one I had been playing around with getting the Mausberry circuit shutdown to work with, and have been troubleshooting the video screensaver with. As far as I'm concerned, those issues are resolved, and this build is officially complete (aside from adding more games as I have time).

    The 2nd build I'm doing is a dedicated PlayStation system, inside an old PlayStation. All of the bits are the same as in the Nintendo, only it's a larger hard drive. Same power circuit, same buttons, same led. This is the system I was rebuilding the Comic Book theme for. I took your advice and reduced all the images in the theme to 720p, then uploaded them to a quick little PNG resizer website (since I couldn't figure out how to reduce the file size any). It changed my 1.2mb images to around 300k. The system was stable prior to swapping out the images, aside from the occasional lightning bolt. By replacing the images, I eliminated the black boxes/etc where the theme wouldn't load right after coming out of a screensaver or from a game. So the last thing to fix was the lightning bolt. I did some looking around and found a link on the Raspberry homepage on how to turn off the icon. I edited that file to add that one line. Did some testing, and it worked fine. I decided to leave the screensaver running for a bit when I went to the bathroom. Came back in and the system was off (but the power LED was still on). Pulled the plug and plugged it back in, now all I get is this Power On --> Off with no means of me to interact without removing the hard drive.

  • @hansolo77 did you do avoid warnings 1 or 2? Did you have any overclocking?

    Do you have an image backed up of your SD card? All of your games and gamelists are on your hard drive. I assume you can plug that into your computer to make sure that data is still usable and not corrupt.

    based on what you just provided as background, I am assuming you either corrupted your SD card, or burned up something on the pi board itself. I would either try to reinstall a new image onto your card form a backup, or.....if you are feeling brave i would take your SD card from your nintendo build and put it into the Playstation pi and see if the pi will boot up. Your other card should be in good condition and running so if it boots on the playstation pi, then you know that the pi itself is still functional. I would backup your working SD card first.

  • I have a backup of my PiStation sd card prior to installing the modded Comic Book theme. But It doesn't have the latest modifications I did.

    I was just using avoid warnings 1, and no overclocking.

    I'm exhausted for tonight, so I'm gonna call it a night. But I will try swapping SD cards tomorrow.

  • @hansolo77 A lightning bolt means that you have insufficient power. What is the rating of the power supply you are using? Have you upgraded since your earlier power supply issues?

  • I know what the lightning bolt means. I've been troubleshooting it for weeks. Right now I'm using a 5v 3a supply.

  • @rbaker Correct. I wouldn't fix the lightning bolt by hiding it - that's just asking for trouble. There's a reason for the warning, and it might be that you have corrupted your image as result of a power surge or drop.

    I'd re-install the image, and attempt to solve the power issue properly - both via a better supply, if needed, and powering the external drive via a separate power hub if needed.

  • I just don't know if it's possible to do what I want to do that way then. My intentions were to keep everything internal, with one power cable (the original PSX). There's just no more room to add another power supply and a hub just to drive the hard drive. I'm literally bending the case as it is fitting everything inside. I agree though, having another power source for the drive would probably solve the issue. But it only seems to pop up when the drive is getting hammered. Any other time, it plays fine.

  • @hansolo77 Why not get a USB thumb drive instead? Do you really need a hard drive?

    It's not as much a matter of "when it pops up" but the fact that it does, at any point, as that in itself may cause system failure (not enough power to finish writing, reading whatever, and something be corrupted at that time).

  • @pjft said in HELP!!! System just shuts down!:

    Why not get a USB thumb drive instead? Do you really need a hard drive?

    Because i have 3.5TB of roms and videos. :)

  • @hansolo77 Have you considered running them from a Shared drive instead?

  • I haven't really considered it, because I wanted it to be mobile. I don't like having things like my server running when it doesn't have to be.

  • @hansolo77 I suppose the next question then is obviously if you do need to have your entire video and ROM collection in that set up, but that's a personal choice.

    You may do some research for lower-power-consuming hard drives, but I can't promise anything before you try them.

  • I have had some success... I still can't get a proper boot up log to identify the issue, but I managed to set up a tripod and my camera to take a picture of the screen. Sorry the image is so large, it's a nice camera. :) And the big white spot is the flash. I had to have the flash on because I couldn't get the picture to come out clear enough without it. The text on the screen goes by so fast, I was getting double and triple lines repeating in the picture.
    Anyway, it looks like it runs just fine up until it reaches the switch script from rc.local. Is there any way to edit the filesystem without having to boot up the Pi? Like, is there a Windows program that lets you access the data partition of the SD card? I'd like to try and just #comment out the line calling the script to see if I can get it to recover.

  • More Progress...
    Swapped out the SD card with the one from my NES. It does the same thing, so I thought it might be the Pi. Then I tested the PSX card in the NES and it did the same thing too. So I'm not sure what's going on. I put the NES card back in the NES and it works fine. So that's a relief. The PSX card in the PSX or the NES doesn't work. So I'm going to try and re-image the card to see if I can recover from square one. Bummer.

  • Looks like it was probably the SD card. I didn't have a backup of the "working" system, so I'm starting from the beginning again. But the reimage seems to be working ok. I made a backup of the "broken" card, so maybe I can somehow get in to recover in the future. But then again, starting from the beginning is probably a better way to go and do things right.

  • Reporting Progress Update...
    Got the hard drive working and the skin changes in place. My buttons don't work yet, but the LED does. I just need to get the button scripts installed (POWER and RESET). I will say this.. I think I know what caused the corruption. The PiStation build I'm doing has a microSD card ribbon cable, to make access the the SD card external. When I screwed the top down on my case, I crushed one of the wires in the ribbon between the screws. During all of my re-building today, I kept it simple without using that cable. Everything now works right. I tried hooking up the cable again, and sure enough, I get filesystem read/write errors on my screen. So I've ordered a replacement. Cheap enough, but coming from Taiwan so it might take a couple weeks. The other thing I noticed... since the POWER and RESET buttons aren't working yet, I've had the power going straight into the Pi. I've had ZERO undervoltage warnings flash up on my screen. BUT, once I put the Mausberry circuit into the mix, all of a sudden those lightning bolts started showing up. So I don't know if I have a faulty circuit, of it maybe the circuit isn't capable of supporting the volts/amps. I need to try and get in touch with them and see if they can recommend a solution.

    As an aside, but related question.. Does the "Powerblock" people use work in a similar fashion? Detecting a button push then sending a signal to the Pi to shut down, then cutting out the power? If so, maybe it can handle the power?

Log in to reply

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.