Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Failed saving config to /opt/retropie/configs/psx/retroarch.cfg



  • I tried that, unfortunately it did not work.

    The palliative way of saving the settings was:

    1. Delete all /psx/retroarch.cfg settings, all related to Save Core Overrides and
    the main Retroarch setting.

    2. After deleting, do not use the Save Core Overrides option again.

    Currently I can save the /opt/retropie/configs/psx/retroarch.cfg settings, but without using Save Core Overrides.



  • update post



  • @luizoti Can you please provide the full path of save core override file? I wan to delete it also.



  • @soulfunkdjx /opt/retropie/configs/all/ file name is retroarch-core-options.cfg



  • Sorry for the delay, I thought nobody was going to answer and I just forgot about the post.

    I do not remember the paths, other than the ones I put in the post, because it's been a while since I moved with this Save Core Overrides option, because whenever I use it I can not save any config anymore, I prefer not to move anymore.



  • @jonnykesh said in Failed saving config to /opt/retropie/configs/psx/retroarch.cfg:

    @soulfunkdjx /opt/retropie/configs/all/ file name is retroarch-core-options.cfg

    there are many settings that when using Save Core Override feature are not logged in that file so unfortunately for most people with the issue the OP has expressed this isn't a viable response.



  • Would something like this work?

    sudo chown -R pi:pi /opt/retropie/configs



  • I was having a similar problem with 'Configuration override loaded' and 'Failed saving config to...' messages with the lr-fuse core recently. It wasn't allowing me to make and save changes from within rgui.
    I was about to give up on it when, for reasons I can't recall, I decided to have a look in: /opt/retropie/configs/all/retroarch/config/

    Lo and behold, there were various rmp and cfg files with fuse in their name. I moved these files along with everything in /opt/retropie/configs/<core_name>/ to a temporary location, uninstalled and reinstalled the core - in this case lr-fuse, and everything started working as it should!

    If anyone knows what role the /opt/retropie/configs/all/retroarch/config/ directory has and how it works with the rest of the config system, please feel free to comment! :)



  • I know this topic is old, but I have been struggling with this same issue today, and I think I have found a way to make it work.
    1.) Load the game on the console of your choice
    2.) Bring up the RetroArch menu, starting out in the Quick Menu
    3.) Select "Close Content", this will stop the game from running, bringing you to just the RetroArch menu, saying "No items." Press the back/cancel button on your controller.
    4.) Go to Settings -> Input -> Hotkey Binds
    5.) Make the changes you want, then back out until you hit the main screen that says "Load Core" at the top. On this screen select "Configuration File"
    6.) Select "Save Current Configuration". It should say saved new configuration somewhere on the bottom.
    7.) Back out until you see "Quit Retroarch" on the bottom, select this.
    8.) Load up the game again, try out your hotkeys.

    You will have to do this for all consoles separately, as they each have their own core RetroArch config file.



  • @Kookamunga said in Failed saving config to /opt/retropie/configs/psx/retroarch.cfg:

    1.) Load the game on the console of your choice
    2.) Bring up the RetroArch menu, starting out in the Quick Menu
    3.) Select "Close Content", this will stop the game from running, bringing you to just the RetroArch menu, saying "No items." Press the back/cancel button on your controller.
    4.) Go to Settings -> Input -> Hotkey Binds
    5.) Make the changes you want, then back out until you hit the main screen that says "Load Core" at the top. On this screen select "Configuration File"
    6.) Select "Save Current Configuration". It should say saved new configuration somewhere on the bottom.
    7.) Back out until you see "Quit Retroarch" on the bottom, select this.
    8.) Load up the game again, try out your hotkeys.
    You will have to do this for all consoles separately, as they each have their own core RetroArch config file.

    WOW! This actually worked. I have spent weeks trying to figure out why I couldn't save configs! You are a genius! Only thing now tho that doesnt make sense, why can't we do this in game in Retroarch? I'm using Retropie on a Pi4 4gb, and nothing ever saves in RA when I try to do save current config or save core override. I have seen tons of YouTube where people save current config fine in game so this leaves me baffled.


  • Global Moderator

    @bostonjon34 said in Failed saving config to /opt/retropie/configs/psx/retroarch.cfg:

    I'm using Retropie on a Pi4 4gb, and nothing ever saves in RA when I try to do save current config or save core override. I have seen tons of YouTube where people save current config fine in game so this leaves me baffled.

    This looks like a file permission issue. If you'd like to diagnose this, please open a new topic and provide the info requested in https://retropie.org.uk/forum/topic/3/read-this-first.



  • @bostonjon34
    It seems to behave this way on Android and Windows as well. I think it kind of operates separately once a rom is loaded, locking itself away from the main instance of Retroarch in a way, hence the ability to save per game overrides. This of course is just speculation on my part.



  • @Kookamunga thank you! This works!!! i really appreciate it!



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.