Please do not post a support request without first reading and following the advice in

[SOLVED] Conflict between retrogame and TFT DT overlay ?

  • Hi everyone,

    I'm currently working on a "GBA Zero", using a Pi Zero to fit a Game Boy Advance case. The goal is to have a GBA with ABXY buttons, so it can play nicely any SNES game and even some titles of the PSX (although I now that I'll need to upgrade to PI3, that is for a v2)

    What I've done yet :

    • power supply using Adafruit Powerboost 1000c and 3.7V 2500 mAh LiPO battery
    • display on a 3.2 tft (chinese copy of the waveshare)
    • next to that I'm working on the casing itself (I think I'll do a topic of the project for pictures and worklog, but it is a GBA case with NDS buttons)
    • and finally I was working on buttons but have difficulties to make them work

    After a fews days of struggling I unsoldered evertything and tried again from scratch, focusing on the input.
    And... They work... Until I setup the dtoverlay param in the /boot/config.txt file for the waveshare screen.
    And... they work again if I comment the line and reboot.

    I use retrogame (guide and 3.2 waveshare screen (guide

    It seems that there is some kind of conflict. The screen has 26 pins and I only use pins 4,13,15,19,20,32,24.
    I have 4 buttons at the moment and I use 35,36,37 34 for ground (so I can see how a conflict can happen here) and the pin 7 which is GPIO 04. I've looked into waveshare32b-overlay.dts and I don't find any reference about this GPIO.

    Any help will be greatly appreciated, I really want to go through with this project. Available for any information / photo / config file. (You might have note that English is not my first language, so I'm sorry for any mistakes)

    Pi Model or other hardware: Zero W
    Power Supply used: NorthPada 2.5A
    RetroPie Version: 4.2
    Built From: Pre made SD Image on RetroPie website
    USB Devices connected: None

  • Hum, I edited the retrogame config file and remove all buttons that weren't wired yet, and it seems to work !
    I don't understand why it was working when the dtoverlay was off though... But I can go on to another issue now :)


Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.