Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

There are no Emulators



  • Hi everybody,
    i wanted to build my own handheld, so i went and boorowed a raspberry pie 1 form a friend to test out the software.
    First i downloaded the file then extrated it.
    After that i wrote the image via win32diskimager on a 16GB sd card.
    I started to select the bottons and got to the configuration.
    But here starts my problem. In the describtion it is said that the most inportant emulators are already preinstalled after writting the image. But after i finished the configuration and wanting to select a emulator (downloaded a few roms in advance to test gaming too) I couldnt chose any Emulators. There was not even one that i could chose (only the configuration did show up and could be chosen). I dont know why there are no emulators. I hope somebody can enlighten me.

    PS: i already used 2 different Sd cards, downlaoded it again (3 times) and formated the cards over and over to write the image again, but always the same problem.

    best regards
    Boneclaw


  • Global Moderator

    @boneclaw You won't see any emulators in the ES menus unless you have at least a ROM copied in the emulator's folder.
    So transfer your ROMs to the RetroPie, then restart EmulationStation (or the PI) and see if the emulators come up.



  • This post is deleted!


  • @boneclaw The emulators are there, most of them anyway. The systems do not show up on the carousel menu until you have ROMs in the system folders AND then restart Emulation Station.

    I would suggest you read the official documents and save yourself the frustration and headaches. It's all laid out in the guides provided. https://retropie.org.uk/docs/First-Installation/#transferring-roms



  • I tried to follow the installation guid for roms.
    I always waited until the USB Stick stopped blinking.
    For the test Rom i wanted to use the GBA emulator with Pokemon- Firered as the rom.
    But even thought the data is shown, when i plug the USB stick in my PC (F:retropie/roms/gba/ ) I can't chose the GBA emulator after i restart the Emulator Station or even restart the whole system.
    And for the reference video, I dont know how I can get to the screen shown at the start of the video.

    The Rom has the Datatyp .exe



  • @boneclaw exe is not a recognised ROM file for any emulator. Please read the documents!
    https://github.com/retropie/retropie-setup/wiki/Game-Boy-Advance



  • So I need to find a GBA bios and a suitable Rom to get it working?
    When i click on any of the 4 emulators, i cant download them i just get to a forumlike website.


  • Global Moderator

    @boneclaw said in There are no Emulators:

    When i click on any of the 4 emulators, i cant download them i just get to a forumlike website.

    you already have the emulator. read your own first post.



  • @boneclaw That is not how you install emulators. Again, I suggest you do some reading. Until then I am unable to assist you any further. Good luck.



  • well i watch a few videos, and read some website, and all say i need to put the Rom in the folder for roms on the USB but whenever i download a rom its in the exe format, not GBA like its written in the link that u gave me.


  • Global Moderator

    @boneclaw said in There are no Emulators:

    well i watch a few videos, and read some website, and all say i need to put the Rom in the folder for roms on the USB but whenever i download a rom its in the exe format, not GBA like its written in the link that u gave me.

    Then it's the wrong ROM - the correct ones have the extension the docs mention or have a zip extension - they're an archive for the .gba rom inside.



  • @mitu i finally found a website that should have Roms with right datatyp (.gba is shown) and currently waiting until it has copied the file to the sd card in the raspberry


  • Global Moderator

    a rom that's an .exe is almost certainly a virus or something like that. i'd always wondered who gets caught out by those.



  • Well it worked with a rom that has .gba (2 Games, after changing the configurations a bit).
    As i am quiet new to this (only used a Emulator on the mobilephone) I did not know that .exe isnt used for the emulator. When i used roms before they worked fine, maybe i just hat luck and only found those with .gba not .exe.


  • Global Moderator

    Glad you got it working. As @dankcushions said, any .exe pretending to be a ROM is most likely a virus, so beware.



  • @boneclaw Try another website for your roms (Google "roms" and use the first result). And NEVER open that exe. Most likely some form of malware.

    ---edit---
    Late to the party apparently... ;)



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.