Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Picodrive cross platform settings.



  • Pi Model or other hardware: Pi 3
    Power Supply used: Official 2.5A
    RetroPie Version Used: 4.3
    Built From: Pre made SD Image on RetroPie website
    USB Devices connected: 1x mayflash adapter for sega megadrive controllers.
    Controller used: 2x megadrive controllers
    Emulator: (Name of emulator - if applicable) Picodrive

    Hey guys, I have a odd problem and its driving me nuts so I hope someone can help me out here.

    I have 3 consoles on my megadrive pi.
    The master system, Megadrive and 32X.

    All of which run through Picodrive, I have megadrive set up and working great no problems.
    But my settings for 32X and MS dont seem to be carrying over, They seem to keep reverting back to default or something.
    If I go into the RGUI menu and change them all the same as my megadrive settings it seems to work fine for that game but its not saving and carrying over to the other games.

    I saved the core remap file which seems to save and transfer over the quick menu control settings but the input remap does not seem to be carrying over.
    I have also saved the retroarch.cfg file but again it seems to revert back to default everytime i quit the game and go back in.

    Any help appreciated....



  • Anyone? Still strugling with this one!



  • @titchgamer Can you post your retroarch.cfgs ? Global and core specific.
    Also can you post the runcommand you use to launch each core?



  • @udb23

    How do I get the run command?

    Ile post the CFG's shortly....



  • cfg's as follows:

    <script src="https://pastebin.com/embed_js/U1JXY8AY"></script>



  • @titchgamer emulators.cfg in each core folder.



  • @udb23

    Thanks,

    Master System:

    lr-genesis-plus-gx = "/opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/lr-genesis-plus-gx/genesis_plus_gx_libretro.so --config /opt/retropie/configs/mastersystem/retroarch.cfg %ROM%"
    lr-picodrive = "/opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/lr-picodrive/picodrive_libretro.so --config /opt/retropie/configs/mastersystem/retroarch.cfg %ROM%"
    default = "lr-picodrive"

    Mega drive:

    lr-genesis-plus-gx = "/opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/lr-genesis-plus-gx/genesis_plus_gx_libretro.so --config /opt/retropie/configs/megadrive/retroarch.cfg %ROM%"
    lr-picodrive = "/opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/lr-picodrive/picodrive_libretro.so --config /opt/retropie/configs/megadrive/retroarch.cfg %ROM%"
    default = "lr-picodrive"

    32x

    lr-picodrive = "/opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/lr-picodrive/picodrive_libretro.so --config /opt/retropie/configs/sega32x/retroarch.cfg %ROM%"
    default = "lr-picodrive"



  • @titchgamer runcommands seem ok as each core is pointing to the retroarch.cfg in the respective folder.



  • Just to add it seems my mega drive settings are not saving either now!

    I load the RGUI menu in game, go to input, change the settings and exit. They work fine then all change next time I exit :(
    I have "save config on exit" enabled by the way.



  • @titchgamer Have you checked this ? Setting "auto save on exit" thru RGUI seems to possibly lead to issues.



  • @udb23

    Dont think thats the issue.

    Basicly this is whats happeneing:

    I load a megadrive game go into the RGUI, Then go in the quick menu and change the controls and controller to 6 button. This saves and is fine for all games in that system (never changes).

    I then go into "settings" and "Input" to change the key bindings for the hotkeys, p1 & p2.
    I can change them to what I want no problem and exit the RGUI.

    The game plays as I want no problem unti I exit the game.
    The settings I just made will now be lost totally and I have to reconfigure the next time I go into the game.

    This is the same for the other 2 systems also.



  • Just noticed something else of interest.

    This is ONLY affecting the inputs, If I change other options for instance the on screen display (yellow text) That saves across all.

    But the Inputs keep being rewritten.

    So is this another CFG file over writing them??



  • @titchgamer you mentioned you tried also core remapping. This should create additional cfg files for input in the core folder. Can you check this?



  • Made some progress (Kind of).

    I have realised my mayflash CFG is overwriteing the settings I make in the RGUI.
    I changed a few of the hotkey bindings in the mayflash cfg and they changed in the RGUI menu also.

    So this leaves me with another problem and confusion.

    My p1 bindings are all correct and if I look in the RGUI the bindings are also listed as "AUTO" BUT P2 is wrong.
    They are listed as odd buttons, if I change them to auto they all work correct but that setting again will not save!!



  • @udb23 I cant see any input.cfg in any of the system folders, I do have a picodrive folder with picodrive.rmp in though?



  • @titchgamer have you tried manually editing the retroach.cfg for each core so that bindings fit your needs ? Remember to delete any core remap file.



  • @titchgamer it should be in the core folder; probably has not saved.



  • @udb23 Not yet, Ime thinking of trying that next copying over the settings from the mayflash cfg



  • @udb23

    Well kind of a mixed bag.

    I edited the megadrive CFG and got everything working correctly but killed my sound,
    As for the other 2 no dice.



  • Think ime going to do a clean install and start again with this.....



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.