Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Lr-PCSX-ReARMed - Not saving shader/option setting + other issues



  • I started my machine first time in couple weeks and noticed that the shader settings I had done were missing and not loading during game booting up. Also, it had resetted all of the emulation settings and stated error about not being able to load/save configurations. What I also saw was that the File Manager was showing that there is 16 Gb of SD memory total and it's run out of the memory, even thou the SD card is 64 Gb one. And this is not the first time I've had these issues with the config saving/loading, I had these issues previosly as well.


  • Global Moderator

    @dd-indeed please provide all the information requested in https://retropie.org.uk/forum/topic/3/read-this-first

    also, when that's done please also provide

    /opt/retropie/configs/psx/retroarch.cfg```
    
    also how are you saving settings, or at least trying to? please give the full steps.


  • Pi Model or other hardware: Pi 3 in PS1 case

    Power Supply used: PS1's internal power supply with adjustable voltage regulation, set to 5.1V, no voltage issues.

    RetroPie Version Used: 4.3

    Built From: Stock Retropie image installed into 16 Gb SD card, set up to my personal settings and then recompressed back into .ISO, which was then installed into 64 Gb SD card. So it's this personal custom image with settings and stuff ready to go.

    USB Devices connected: 4-port hub for keyboard/mouse and USB thumbdrive to transfer games + PS1 to USB controller adapter

    Controller used: PS1 Dual Analog + Keyboard

    Error messages received: Not enough storage space to save shader/emulator settings, the message flashes very briefly on the screen on the emulation boot, might need to take a screenshot.

    Log found in /dev/shm/runcommand.log (if relevant): filling this up later

    Guide used: -

    File: filling up later

    Emulator: Lr-PCSX-ReARMed

    Attachment of config files: filling up later

    How to replicate the problem: ?

    What I was thinking is that could it be, that the preinstalled and recompressed image has the 16 Gb SD card information and treats the 64 Gb one as similar sized one ? There was no problems with the image when I used it first, but then I didn't start the device for 2 weeks and when I started it again, this issue started to happen. I'll provide more information later on.

    I tried to save the settings with the Retroarch quick menu, that is accessed with Select + Triangle. It states that the settings save was success, but when I reboot the emulation, it doesn't load them.


  • Global Moderator

    @dd-indeed i think you may have to manually expand the file system: https://retropie.org.uk/forum/topic/5229/solved-how-do-i-resize-the-filesystem/2



  • @dankcushions

    Yea that did the trick, thanks. But now it states error about gamelist.xml parsing, the file is missing. I need to investigate more about it.

    Edit: Got it fixed, just deleted the gamelist.xml from the EmulationStation folder and it recreated new one.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.