Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Cannot update GamepadBlock firmware



  • Hi,

    I've been trying to update my new GamepadBlock firmware from 1.1.0 to 1.2.0, but every time I try to use the GamepadBlock updater, it gives the message 'Error: Cannot communicate with GamepadBlock'.

    I'm using a Windows 10 laptop. I tried on my desktop machine that uses Windows 7, but the updater won't even detect the GamrpadBlock at all.

    Any tips would be much appreciated!


  • Global Moderator

    We will make this work somehow ...

    Does the GamepadBlock show up as a single or two gamepad in Windows?
    Are there other USB devices connected to your PC?
    The updater tries to detect the GamepadBlock automatically, but maybe this is failing in your case. If possible, you could try and disconnect the other USB devices. Also, Windows needs some seconds until a newly connected Usb devices gets enumerated, so waiting for maybe five seconds or so until the update tool can find the GamepadBlock could also play a role.



  • Hi,

    It seems that using a different USB cable has solved the issue. I have successfully updated to 1.2.0.

    Many thanks



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.