Please do not post a support request without first reading and following the advice in

  • Hello friends, this is my fist post. I hope someone in this forum can help me with a problem. Or at least give me some ideas where to look next.

    I've been running retopie flawlessly up until this point for 6 months without issues. I have a pi3 with audio using the headphone jack. All the sounds for every game works perfectly, or at least it did. I was trying to get into the rom settings for a single game rom that wasn't working. I was in a menu that said something like edit this rom only... (or something similar) a white box came up with nothing in it. I think I may have pressed enter a few times, maybe backspaced too. Closed the box and then after not wanting to deal with it deleting the rom file.

    I then went on to launch a game that always worked perfectly and noticed no sounds! I exited that rom and started another. To make a long story short, all of the roms in the entire directory now have no audio. The weird thing is that the menu has sound as you scroll through the list. And all of the sounds work in the other emulators as normal. (This is using lr-mame2003)

    Sorry if I'm not describing everything in the most helpful way! Any ideas how to get sounds back for all the games that lost them in this emulator? Again, all other emulators on retropie still work as before without any issues.

    Thanks guys!!!

    Keep Pumpin

  • Global Moderator

    @keeppumpin You maybe have overridden some of the settings for that particular emulator or libretro core, but you need to be more specific about which game and emulator you used to be able to diagnose this.
    What emulator/folder lost the sound ? Try to be more precise.

  • Thanks mitu, I'll look into this later tonight and post the complete path, every rom in the mame libretro folder lost sound. But all other emulators sound works perfectly. The roms are mostly mame2003 0.78 the best that I remember. While I'm navigating the menu in (I believe the top level of the directory might be mame32, but will confirm later) I have sounds while in that menu- selecting games. Also notice that the audio is set to 0 in the audio menu but when I adjust that setting it always returns to 0. (Mute is off) Thanks for your reply, will post more details later.

  • Global Moderator

    @keeppumpin Ah, so lr-mame2003 is the one that's giving trouble. Try re-installing it from the RetroPie-Setup menu, this might overwrite the custom settings for it with the default ones and could fix the problem.

  • @mitu Ok thanks, that sounds like something I can try, just need to figure out where to go to do that process. I'm still pretty new to this so it's kind of a work in progress. Do you know if this process will erase high scores?

  • Global Moderator

    @keeppumpin said in One of my emulators suddenly lost sound that was previously working:

    Do you know if this process will erase high scores?

    It should not, the hiscores are saved in your ROM folders, with the .hi extension, so they should not be touched by the installer.

  • @mitu Perfect, thanks so much for letting me pick your brain, from what I can tell there aren't a lot of people who've posted about this specific problem online. Hopefully, this discussion might help someone else in the future. I'll go look for a tutorial for re-installing lr-mame2003 and see if that fixes my issues. Will follow up.

  • Global Moderator

    @keeppumpin said in One of my emulators suddenly lost sound that was previously working:

    I'll go look for a tutorial for re-installing lr-mame2003 and see if that fixes my issues. Will follow up.

    There's no tutorial needed, just start RetroPie-setup from Emulationstation (in the RetroPie system), go to the Manage Packages option, chose Manage main packages, then select lr-mame2003 and choose to uninstall, then install again.

  • @mitu One last not so smart question. Do I need to copy over all of my rom files so I can easily re-install them or does it even touch the roms? Second, once I uninstall lr-mame2003 as described above will I have the re-install lr-mame2003 as a choice in that same menu? (My machine has a wifi connection so guessing this all happens automatically) And, again, thank you so much. You've seriously been a huge help. I think this will work but will let you know.

  • Global Moderator

    @keeppumpin The same menu does the installation and uninstallation. Once you uninstalled it, the install option appears. As for the ROMs, they will not be deleted - the installer does not do anything to them.

  • Global Moderator

    EDIT: to install the lr-mame2003 package you'll need to be connected to the internet, make sure your PI is networked and the internet works, otherwise if you're uninstalling the emulator you won't be able to get it back.

  • @mitu I should be good, I'm able to scrape files for images, etc. Will follow up later.

  • @mitu Well, it was a nice try, I uninstalled and re-installed lr-mame2003 but still have no sounds in the games, but continue to have sounds navigating the menus.(?) What gives? lol. Any idea what I should try next?

  • @mitu Just tried a few more things to restore the audio for lr-mame2003 in retropie after the reinstall of lr-mame2003. I did this test (just to confirm the sound works for testing purposes)

    You can test audio with this command:
    speaker-test -c2

    press Ctrl+C to stop the test

    Result: The speaker test played a hissing sound in both speakers.

    I then looked at my config.txt file using: sudo nano /boot/config.txt (by plugging in a USB keyboard to the Raspberry Pi and pressing F4 to exit EmulationStation to the command prompt and then typing the above command)

    The only text that looks like it pertains to audio in the config.txt file reads:

    Enable audio (loads snd_bcm2835)


    Not sure if those last four lines have anything to do with audio on the retropie but it was grouped with it in the text file.

    Results thus far: retropie 1, KeepPumpin 0.

  • Global Moderator

    @keeppumpin Try to see if you have a file default.cfg in the mame-libretro/mame2003/cfg folder from the roms folder and delete it.

  • @keeppumpin
    I’m far less knowledgeable than @mitu, and honestly if this is something way off base then by all means please let me know.

    I was reading that there is a line in: retroarch-core-options.cfg file, located in. /opt/retropie/configs/all/ that controls the sample rate for all sounds on an emulator by emulator basis. This is the option/line, and its default value as they should be:

    mame2003-sample_rate = "48000"

    Maybe that was changed accidentally?

    Again, if @mitu thinks this is way off base, then please disregard.

    Also, I apologize that my directories and files aren’t as easily discernible. I’ll have to read up on how to properly format the contents of a post to keep things legible.

  • @mitu using ftp I navigated to the file and found a default.cfg file, I deleted the file, rebooted the system and still no dice.

  • Global Moderator

    @keeppumpin Where are your ROMs located - which folder ? Is it arcade or mame-libretro ?

  • @mitu my Roms are located in: /home/pi/RetroPie/roms/mame-libretro

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.