Please do not post a support request without first reading and following the advice in

Retropie: Upgrading Raspbian Jessie to Stretch

  • @lodan-zark Thanks for this guide! I am doing the final updates for step 7 now. Is this going to leave the old files from my installations while using the previous version? Do I have any manual clean up to do?

  • Just wanted to report in that after following these steps I have a successful migration to stretch on my 3B+ with no loss of configurations! You may want to put in a note about having to hit space to scroll during upgrade, because it doesn't really prompt you and as a noob it took me some poking around to figure out. Also hitting Q was needed to escape some notes that come up during the process.

    Quite painless, and I am right where I left off on my 3b. I completed these steps on my 3b, and then my 3B+ simply works with it right where I left off on my 3b!

    Great guide!

  • @alturis I completed these steps on my 3b, and simply moved the sd card to my 3b+. I did this much later on than the original posting mind you so with newer updates this process may have been simplified since.

  • @nowun
    thank you for this!!

  • @Lodan-Zark Thank you for this guide, I have successful migration to stretch and my Pi 3B + now is working but i can't launch Attract Mode because an error appear like this:
    attract: error while loading shared libraries: cannot open shared object file: No such file or directory
    but when i go to the folder in opt/vc/lib i can see the file there so i cant understand whats goin on, can you give me some kind of help please? i really appreciate if you would.

  • @darksavior I've hit the same issue. Missing and vlc failed on dependencies. By stable, do you mean Stretch stable or you just reverted back to Jessie?

    I have kodiinstalled and it's been updated to 17.6. Do you have the same setup? I wonder if that causes the issue. I also notice that there's an open bug in retrosmc that looks related Not sure when it's going to be addressed though.

  • @jaconey I went back to stetch stable back when I was using this method. I started fresh on a stretch 4.4 image. I don't use kodi, but I'd try the fresh image since that's the supported build and should have the libraries needed.

  • @darksavior thanks.

    I've been able to address the issue. For some reason, vlc-data was installed with different version 2.2.7, which breaks the dependencies. To whomever has the same issue, run apt list --installed | grep vlc and remove any packages that show up there and you should be good. Good luck!

  • @jaconey I have this exact same issue with Missing and VLC 2.2.7 but I don't know how to remove these packages without using file manager. I'm not at all good at Linux and just trying to make Retropie's for my sons and their friends. Is there any easy way to remove the packages? I tried looking to just uninstall VLC but no luck. Thanks in advance.

  • Had no end of issues with stretch even starting from scratch. None are major but it's still annoying. For example, audio on stretch (particularly videos), sounds poor quality like the pitch of music modulates up and down slightly. I was not able to resolve that. Another example, The Gameboy standard shader with retroarch worked fine with Jessie build but was slow as anything on stretch. Gone back to Jessie.

  • @lodan-zark said in Retropie: Upgrading Raspbian Jessie to Stretch:

    Install retropie related packages from source:
    sudo ~/RetroPie-Setup/ and install everything from source (Retroarch, emulationstation, libretrocores, etc)
    Update: the stretch binary's are now available, there is no need to install from source anymore.

    Can I skip step 6? after upgrading OS and installed packages and making a reboot I am done?

  • Global Moderator

    @chicuelo No, you need to upgrade the RetroPie packages, but now you can do it from binary - so it will take considerably less.

  • @mitu

    Great! I think I tried this at first but didn't find where to update from binary. I am using terminal on Mac to do this

  • Global Moderator

    @chicuelo Just update as usual - i.e. Update all packages (from binary).

  • @mitu
    You are the man!
    Last question, the optional steps are recommended or necessary? upgrading firmware. Im doubting about this

  • Global Moderator

    @chicuelo said in Retropie: Upgrading Raspbian Jessie to Stretch:

    You are the man!

    Well, I didn't write the instructions, @Lodan-Zark did. Yes, you don't need to update the firmware. You should re-pair your controllers though, a lot of drivers have been updated in Raspbian and they might not work as before.

  • @mitu
    No problem pairing the controllers. I think that's a minor issue compared on starting from scratch.
    Thank you very much! I owe you a lot of time and knowledge :)

  • Throwing in my two cents here. I was running Jessie 4.4.1, and tried upgrading to Stretch via the steps above, and all was well up until it was time to install ES; I ran into a dependency issue with VLC that couldn't be resolved, but removing and reinstalling VLC did the trick. Everything seems to be in working order now, but that was the one hiccup that I encountered during the upgrade process.

  • Global Moderator

    @eldrethor Did you have any custom repositories installed ? That's usually the reason for such errors.

  • @mitu None but the only one that seems suspect is lipobello's RetroRama theme, since I had the original version before he removed the repo. I think I recall having to reinstall that one after I got ES was up and running.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.