Please do not post a support request without first reading and following the advice in

Retropie: Upgrading Raspbian Jessie to Stretch

  • @mitu Possibly python-pygame? I installed this as a way to get background music playing in ES. Aside from that, everything else is stock.

  • @jaconey Probably already fixed it or did it another way but ...

    I completed the upgrade to stretch via the means mentioned above and had the same 2 errors. vlc and libboost so

    sudo ~/RetroPie-Setup/

    and Manage Packages

    then Manage Core Packages

    then emulationstation

    Update from binary

    and reboot. fixed.

  • This post is deleted!

  • fixed

  • The update took forever, probably was less time than it would have to start fresh though. The update process did end with an error, unfortunately I cant remember now what it was due the fact it completed at around 2am and I was exhausted. When I rebooted it wouldn't load ES it failed on libboost_date_time.

    I couldnt even run and get to any update screen after the upgrade to stretch Nevermind ES. I would get errors saying:
    "You might want to run 'apt --fix-broken install' to correct these.
    The following packages have unmet dependencies:"

    So i took its advice and i ran "sudo apt - - fix broken install" afterwards I was then able to run, go to update, it updated everything, was able to do a reboot, and boot right into ES. I then took my sd card and put it in a 3b+ pi and it booted perfectly.

    Just letting everyone know what happened to me and how i made it through the upgrade process. Hopefully it helps others.

  • I also wanted to add that i have an error while exiting the bluetooth config screen saying unit sixad.service could not be found. i read that bluetoothhd (i think is what it was called) and sixad cannot run at the same time. so how do you go about fixing this issue?

  • Just followed this guide to get my SD card ready for the switch from Pi 3 to 3 B+ and it worked! The safe shutdown/reset buttons on my Nespi case also work! Stoked!!

  • ok so i followed these steps as close as i understood, but after all the steps I'm still on jessie? I didn't really loose anything other than shader preferences (that i noticed), so I'm restoring from a backup and starting over rn. Where do i go to change the word "jessie" to "stretch"? when i run the first line of code theres nowhere to edit sources.

  • deleted..been a long day.

  • @Lodan-Zark Worked perfect man. Now I play my raspberry b+. Thank you so much

  • @raibura hi, did you ever find a solution for this?

    Sorry for asking in such an old thread but you are the only person I have found with the same problem as me. Thank you

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.