Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

NFS Mount Issues



  • Pi Model or other hardware: Model B rev.2 512MB
    Power Supply used: (If using a Pi) Official 5V 2000mA Micro USB power supply
    RetroPie Version Used: v4.3
    Built From: Pre-made SD Image on RetroPie website
    Other: My Pi is connected by ethernet to my router.

    I'm trying to mount my WD MyCloud to hold roms, however I'm having trouble getting it to work. I have successfully mounted it from the command line through PuTTY using this:

    sudo mount 192.168.0.13:/nfs/roms /srv/roms
    

    I can then list the directory contents of /srv/roms which will correctly show the content from my NAS. When I try and edit the fstab file adding the mount on rebooting the NAS doesn't seem to be mounting as when I try to list the directory contents again I get nothing. If I attempt to mount /srv/roms I'm faced with this error:

    mount: /etc/fstab: parse error: ignore entry at line 4.
    mount.nfs: Failed to resolve server //192.168.0.13: Name or service not known
    

    This is the contents of my edited fstab file, I'm sure my problem lies in here however I'm also wondering if the NAS justbisn't mounting in time during the boot sequence.

    proc            /proc           proc    defaults          0       0
    PARTUUID=3d24ca30-01  /boot           vfat    defaults          0       2
    PARTUUID=3d24ca30-02  /               ext4    defaults,noatime  0       1
    192.168.0.13:/nfs/roms /srv/roms nfs defaults -o nolock       0       0
    # a swapfile is not a swap partition, no line here
    #   use  dphys-swapfile swap[on|off]  for that
    

    I'd be grateful for any help.


  • Global Moderator

    @bearing Your line in the fstab file is not correct - you should have something like

    192.168.0.13:/nfs/roms  /srv/roms   nfs nolock       0       0
    


  • Thanks for that @mitu it has fixed the parse error however when I try to mount /svr/roms I'm still getting the second error.

    mount.nfs: Failed to resolve server //192.168.0.13: Name or service not known
    

    I'm at a loss for what might be happening, I'm wondering if the mount is being timed out on boot?


  • Global Moderator

    @bearing The mount should be happening after the network is up, so that might be the problem with the 2nd error. Try the configuration from https://www.raspberrypi.org/forums/viewtopic.php?t=122066

    192.168.0.13:/nfs/roms  /srv/roms   nfs nolock,noauto,x-systemd.automount      0       0
    


  • Thanks again @mitu That has got rid of the mount error I was getting but now when I attempt to list the directory contents of /srv/roms/ I just get :

    ls: cannot access /svr/roms: No such file or directory
    

    Thanks for your time.


  • Global Moderator

    @bearing Mis-spelled maybe ? /srv/roms != /svr/roms (wrong) ?



  • @mitu said in NFS Mount Issues:

    @bearing Mis-spelled maybe ? /srv/roms != /svr/roms (wrong) ?

    Ahh, that was my error in typing the reply, it should have read /srv/roms.



  • Have realised a simple, noob mistake. I should have been using 192.168.0.12 and not .13 as I had been doing. Everything is fine with the mounting now. However, I have no systems showing on the menu despite my populating the folders on the NAS with ROMs. I've a feeling that I need to edit a file somewhere but despite trawling the forums I am at a loss.

    Anyone any ideas?


  • Global Moderator

    @bearing By default, RetroPie expects the ROMs folder structure to be at /home/pi/RetroPie/roms, but you're mounting them at /srv/roms. Maybe that's the reason ?
    Note that you might run into permission problems (writing on the ROMs folder for the pi user) so you could try - after 1st mount - to reset the permissions on the ROM folders from the Retropie setup script.



  • @mitu All sorted now thanks.


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.