Please do not post a support request without first reading and following the advice in

2 ControlBlocks not working together

  • Using stock RetroPie 4.3. With one CB (ControlBlock) installed, everything works fine. 2nd CB has JS1 set to 1. Pins 11 & 12 on CB1 are bent. All wires are connected to CB1 which is installed directly on the Pi 3. Without modifying the config file, Player 1 (P1) and P2 work perfectly as well as the power switch on CB1.

    If I enable CB2 in the config and restart the machine, ES (EmulationStation) says it can't find any joysticks. I checked, and sure enough, the /dev/input/js* files are not there. Also, the machine will not turn off with the switch connected to CB1.

    If I edit the config file to disable the 2nd CB and restart, everything works fine.
    Initially I returned the first CB2 thinking it was bad and got another one and set it up and connected it and the machine acts the exact same way. The new CB was tested before it was shipped to me so I know the new one works.

    At this point I'm not sure what else to do. I have to assume it is either the Pi, CB1 or drivers.

    Anyone else seen this or have any ideas?

    Thank you.

  • I tried another Pi 3 and got the same results.
    I also tried getting a brand new microSD, putting RetroPie on it, building the ControlBlock service and got the exact same results. At this point I am assuming it is a software "thing", but I'm at a loss on how to go about fixing it.

    Does anyone have any further suggestions?

  • Global Moderator

    Did you set the hardware address as described at

    Can you post a picture of your hardware setup here?

  • Here are some pics. Sorry the SJ1 pic isn't very clear. I verified with a multimeter that the one pad is not connected to the other two and that the other two are connected.


  • Any chance anyone has any more ideas? It's been almost 4 weeks since I sent the images.

  • Global Moderator

    Sorry for this delay.
    Another thing that I thought of is that maybe the two bent pins (11 & 12) are touching each other when the second CB is attached as well.
    If you have a side cutter you could cut these two pins on CB1 to mitigate this.

    If this idea does not help, I could provide you with a RetroPie image that I tested successfully with a four player configuration with two ControlBlocks. In that way we could rule out that it is a software issue.

  • Yes, please send me the image you have. I tried cutting the pins and still no luck. At this point I'm out of ideas.

    Thank you.

  • Global Moderator

    I just tested a four-player hardware setup in my side. It seems that something broke in the driver: Starting the ControlBlock service with a second ControlBlock enabled via the config file lets the driver return with error code 139 right after start:

    pi@retropie:~/ControlBlockService2/build $ sudo ./controlblock 
    pi@retropie:~/ControlBlockService2/build $ echo $?

    I am sorry for that! I try to have that fixed until Wednesday. I let you know then here.

  • @petrockblog Any luck getting the driver updated?

  • Global Moderator

    I am still working on it. I do not make progress as fast as I expected. Something got screwed up with one of the recent change sets of the driver.

  • OK, thank you for the update.

  • Global Moderator

    I just pushed an update for the ControlBlock driver. The four-player feature should work again now!
    Sorry for this bug!

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.