Please do not post a support request without first reading and following the advice in

Multidisc 32X SegaCD games?

  • I'm using lr-genesis-plus-gx for my SegaCD games so I can have them in CHD format. I'm using lr-picodrive for SegaCD games that require a 32X with bin and cue files since CHD isn't supported. There's at least one 32X SegaCD game (Night Trap) that requires 2 discs. The game loads the first disc and starts running fine. I'm not far enough in it to get to the 2nd disc yet. How can I be sure it'll load the 2nd disc when it needs it seamlessly? Is that possible?

  • @mrdowntempo I am fairly sure there is an option for it in the retroarch menu. While in game you can open the menu with select+x (default). I can't remember what it's called off the top of my head but I will check for you when I get home.

  • Oh excellent! Thank you! Retroarch is the thing about Retropie I know the absolute least about.

  • @mrdowntempo there is something you need to put in the retroarch.cfg for sega cd that links the sega cd roms folder that allows you to open the files. Open up /opt/retropie/configs/segacd/retroarch.cfg and add this line:

    rgui_browser_directory = /home/pi/RetroPie/roms/segacd/

    You can put quotations around the /home/pi.... section if you want. On an iphone with this site i cant type the correct quotations.

  • @edmaul69 said in Multidisc 32X SegaCD games?:

    @mrdowntempo there is something you need to put in the retroarch.cfg for sega cd that links the sega cd roms folder that allows you to open the files. Open up /opt/retropie/configs/segacd/retroarch.cfg and add this line:

    rgui_browser_directory = /home/pi/RetroPie/roms/segacd/

    You can put quotations around the /home/pi.... section if you want. On an iphone with this site i cant type the correct quotations.

    Can I do something like this instead:

    rgui_browser_directory = "/home/pi/RetroPie/roms/segacd/32X"

    I'm trying to keep my 32X SegaCD games separate. Or does

    rgui_browser_directory = "/home/pi/RetroPie/roms/segacd/"

    also apply to its subdirectories?

  • @mrdowntempo if you are using all chd files in segacd then point it to segacd/32x/ otherwise try with it pointing to segacd.

  • Any update on this? I have just started dealing with the Sega CD / 32x, and multi disk titles and would like to get it to run without changing discs...

  • Global Moderator

    @chuckyp According to the docs, CHD files are supported by lr-genesis-plus-gx for Sega CD games, so you could try converting the multi-disc games to CHD.

  • @mitu Thanks for the quick reply. I have a full set of current CHD from MAME Software Lists. Will that work or is there a specific earlier version that is required?

  • Global Moderator

    @chuckyp I honestly don't know, but looking at the commit, the support seems to have been implemented using parts of the MAME source for CHD support, so it's likely to work.

  • @mitu thanks I also found another thread discussing the conversion to CHD format. It ended in a problem using the CD+32x versions of a game together. Has this been figured out at all?

  • @chuckyp genplusx will not play 32x games (only picodrive works and picodrive isn't compatible with chd files). So I'm not sure there is a solution for segacd 32x games.

  • @quicksilver I appreciate it.

    Mame CHDs are split per disk. So it looks like I need to convert my own Bin, Cue files into a single CHD.

    Getting closer. Thanks for the advice.

  • Did you get anywhere with this? I can't even get multi-disc Sega CD (i.e. not 32X) games to play beyond disc 1, because I can't get picodrive to attach another disc without it restarting.

  • I have not pursued the 32x issue due to the fact that there are only a couple multi-disk games. As far as the disk changing goes, I don't recall having any issues... Make sure you are opening the tray, changing the disk, and then closing the tray. I have those steps mapped to my shoulder buttons on an XBOX 360 pad. By the way, are you using lr-picodrive or standalone?

  • I can't get disk changes via lr-picodrive to work even with Sega CD (i.e. non-32X) games - when I try to attach the new disk via "append disc image", I select the cue file, confirm the desired emulator is picodrive, and then lr-picodrive restarts with the new disc inserted - it's the restart that's causing the problem. Apparently this has been a problem in Retroarch before, as I was able to find this (which was about the Windows build, but the behavior is the same):

    I was rather hoping there was a workaround or at least confirmation that others aren't having this problem, since I can't find anything in my setup that would cause this.

  • Can you give me a game to try out myself? Hopefully something that won’t take me an eternity to get to disk 2?

  • I'm not actually even playing through - my test case for the moment is that I boot up Fahrenheit for the 32X (which won't play - the protection requires you to boot from the Sega CD disc, even on the 32X) in lr-picodrive, wait for the prompt, hit Start, then enter the RGUI, open the tray, and attach the Sega CD disc. Instead of allowing me to close the tray and resume the game (which should then cleanly boot the Sega CD disc, then ask for the 32X disc again), lr-picodrive completely restarts/reloads and the process begins all over again (except this time having booted from the Sega CD disc).

    From videos I've seen, once the cue file is selected in the browser in the attach phase, it shouldn't ask to specify the emulator (Picodrive, in this case) - I think that's where something's changed, but it makes it impossible to swap discs at all. In fact, it's not even limited to Sega CD - I also tried this with PSX, where I started a game, ejected the disc at the PSX boot logo, attached a completely different disc (where I was prompted for the emulator again), and sure enough, the PSX emulation restarted entirely. It seems this affects any emulator's ability to swap media (probably not even limited to CD media).

    I've tried the following:

    • Updating all of RetroPie
    • Updating Retroarch from source
    • Updating lr-picrodrive from source

    I guess it's an upstream bug in Retroarch, but I'm surprised nobody else has mentioned this, because it's a bit of a breaking bug for any libretro game that requires more than one piece of media.

  • ...though I'm truly mystified.

    I've now built Retroarch and libretro-picodrive from tip revisions on Github and it's doing exactly the same thing. sigh

  • @rhester72 You'll have to wait until the RetroPie team updates their RetroArch, which I would think would come about after RetroArch 1.7.2 is stable.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.