Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Trouble Launching PSP Rom



  • As the title states, I'm having a hard time launching a PSP game. I'm trying to launch Monster Hunter 3rd Portable. I have lr-PPSSPP set up as well as PPSSPP. The PSP option shows up on the game carousel and the game shows up on the games list (its the only one). I have tried to launch other games. Specifically Monster Hunter Freedom Unite, and it starts without a hiccup. When I try launching with lr-ppsspp it will show the little loading screen with the emulator that's launching the game. As soon as that disappears the bottom left will confirm my ps3 controller is registering. After that it goes back to the games list. PPSSPP is almost the same. I am able to quickly press esc on my keyboard and access the emulator settings for the game (controls, graphics, networking). Once I select a save state or continue it goes back to the games list. Any input on the situation? I've also experimented with downloading the emulators through binary and source with no luck. I am running retro-pi 4.2 on a RPi3.



  • Solved. Had to access emulator settings for the one second the game was booting and disable "Fast Memory (Unstable)". Boots fine now.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.