Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

[SOLVED] Raspberry Pi 3B+, Wifi network shown



  • Hello all,

    I'm new to this all and I need some help with my wifi setup.

    Since a few days I'm a Raspberry Pi onwer and a coplete noob who's playing with the Raspberry Pi 3 B+.
    First I had problems installing RetroPie.
    With some help I installed the latest beta version and RetroPie was installed.
    I setup the Raspberry with the network cable attached.
    Did all the updates, installed everything and I was able to play some games with the controller by usb cable.
    I even got the Dreamcast setup working.
    So far so good.

    Now to make it more portable I like to setup my wifi.
    The is my wifi.
    In the menu I setup my location and went to the wifi area to setup my wifi.
    My wifi netwerk isn't shown.
    Searched the internet but I couldn't find a solution for my problem.
    Anybody an idea what I can do?

    • Router, Linksys ea7500 max-stream
    • Wifi channel of my router is 6
    • Keyboard Rii mini K12 ( connected with bluetooth dongle and works fine)

    Again, I'm a complete noob.
    So I'm sorry in advanced If I'm asking stupid questions.

    Best regards,

    Daniel



  • Are you using 5GHz or 2,4Ghz WLAN?
    Are you using a case for your rasp? Metal cases are not good for the connection. The receiver of the pi might be not strong enough.
    Try it next to your router, disconnect the LAN. Use the WLAN settings in the menu, I think you will get it to work.

    I never tried something with bluetooth, sry.



  • @miguel13366 thanks for your reply.

    I use both, 2,4Ghz and 5GHz WLAN so I don't think thats a problem.
    The case I use is a original one from plastic or something like that.
    The Pi is within 1.5 meters from the router, close enough I think.
    Moving it closer then this isn't possible.

    I will try later this day to connect by wifi without the LAN connected.
    Hopefully this will help


  • administrators

    WiFi won't work until you configure WiFi country in raspi-config - did you do that? (It's mentioned in the beta image post).



  • @buzz said in Raspberry Pi 3B+, Wifi network shown:

    configure WiFi country

    Didn't do the configuration of the country correctly.
    Now it works.

    Thanks for all the help



  • Hi @DVE can you please explain how you fixed it? I have tried the country setting but has no effect... I'm missing something..


  • Global Moderator

    @hugotox How did you set up the country ?



  • @mitu
    Note for WiFi on the new Raspberry Pi 3 Model B+:

    WiiFi is disabled until wireless regulatory domain is set (Pi 3 B+ only)

    • The domain can be done through 'Raspberry Pi Configuration' (rc_gui),
      'raspi-config' or by setting 'country=' to an appropriate ISO 3166
      alpha2 country code in /etc/wpa_supplicant/wpa_supplicant.conf.

    US= United States
    GB= UK

    Example by another user of what it should look like (with GB country code)

    country=GB
    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
    update_config=1

    network={
    ssid="myssid"
    psk="mywifipassword"
    }


  • Global Moderator

    This post is deleted!


Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.