Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

X-Arcade Tankstick + trackball



  • I have a Rasberry P3 , did get the Tankstick to work but not the trackball. watched dozen of youtube video's but cant figure it out.

    X-Arcade Tankstick + trackball

    LS-Mame2000 and Mame4all

    New to this please help me to get the trackball to work and get me on the right way?



  • Retropie Version 4.3.15



  • Hi,

    So I have a Tankstick and used Xarcade2Jstick for most emulators, but when it came to MAME I took the approach to run MAME2003 for all my non-trackball games, and Advanced Mame for all Trackball games.

    This worked first time for me, and pressing TAB when a MAME game is running for either emulator allows you to configure it for all games, including the sensitivity of the trackball.

    So, my questions, as it is not clear, are you running Xarcade2JStick?

    Have you tried Advanced MAME (with the correct ROM set)?



  • Yes I am running Xarcade2JStick , can’t figure out how to add the mame2003 or advance Mame emulator
    . Btw the tank stick will only work on mame2000 right now without trackball .

    Thnx for your help , btw I am all new to this so let me now if you need more info



  • Hi @DutchAZ,

    So a bit more information would be useful... are you running emulation station or attractmode?

    What version of RetroPie are you running?

    What versions of MAME do you have running right now?

    Cheers



  • @jono said in X-Arcade Tankstick + trackball:

    Hi @DutchAZ,

    So a bit more information would be useful... are you running emulation station or attractmode?

    What version of RetroPie are you running?

    What versions of MAME do you have running right now?

    Cheers

    Emulation station
    Retropie Version 4.3.15

    LS-Mame2000 and Mame4all

    Thnx



  • @dutchaz said in X-Arcade Tankstick + trackball:

    LS-Mame2000

    LS-Mame2000 is working for the buttons and joysticks on both side but no trackball



  • @dutchaz with regards to MAME2000 if you go into the setup of a MAME game (TAB) there will be an option for Mouse Channel and the player controls, which defaults to 0. This isn't automatically set and you may find you need to alter this, most people find channel 2 works for them.

    I tried this myself to no avail, and so went with Advanced MAME, and that worked around all my problems.

    So if the channel changing doesn;t work you could try installing Advanced MAME, and get one compatible ROM, such as centipede or missile command, and see if that works.



  • I also had to use AdvanceMAME for my trackball to work.

    I found this very helpful - https://retropie.org.uk/docs/Spinners,-Trackballs,-Lightguns,-and-other-Mouse-Devices/
    Scroll down to the AdvanceMAME section.



  • @jono So i have Advmame 1.4 installed but when i start up a game and press tab i do not see it there. ?

    What am i missing?



  • @dutchaz You cannot adjust analog input mapping with the TAB menu in AdvanceMAME. You need to read the docs and make the necessary edits in the .rc file. That said, AdvanceMAME is very configurable and allows the most capabilities to matrix your inputs. In other words, you could setup a three trackball game of Rampart which I don't think would be possible with the libretro cores.



  • This worked for me using MAME2003 and should work using MAME2000. I had to set the config file to force games in MAME that use mouse, dial or trackball controls to use the mouse (Which the trackball is recognized as).

    To do this:

    1. Exit EmulationStation and get to the prompt.
    2. Type the command cd /opt/retropie/configs/all and press Enter. This will get you to the folder where the config file is.
    3. Next backup the file by typing cp retroarch-core-options.cfg retroarch-core-options.cfg.BACKUP. Does not matter what you name the backup file, just as long as you have it backed up.
    4. Now type sudo nano retroarch-core-options.cfg to edit the file.
    5. In my case I want to redirect any games that use a dial or trackball to the mouse. Therefore, check to see if the three lines below are in your file and they match what is below. If any of the files are missing, then go to the end of the file and add them. If the values do not match what is below, change the value to match.
      mame2000-mouse_device = "mouse"
      mame2000-dial_device = "mouse"
      mame2000-trackball_device = "mouse"

      Note: If you do not want to redirect games with trackball devices, you can leave out the line related to trackball_device.
    6. Press CTRL-O to write the file.
    7. Press CTRL-X to exit the file.
    8. Now type sudo reboot and press Enter to reboot.

    Try a game that use a trackball (Centipede, Crystal Castle) or dial control (Tempest, Star Trek) and ArcadeX trackball should work.

    Note: If you are using another version of MAME, in step 5 replace mame2000 with the version of MAME you are using. For example, if using MAME2003, the three lines to type would be:
    mame2003-mouse_device = "mouse"
    mame2003-dial_device = "mouse"
    mame2003-trackball_device = "mouse"

    Hope this helps



  • Got it to work with Mame2003 , moved some of the trackball games to that directory and they are working, setting speed options now in centepide and its good.



  • Thank you all guys.



  • Hey guys I have an issue with my trackball on my xtension joystick. I notice that the config had the mame2003-mouse_device = "mouse" but I believe the xtension has this mapped to mouse2. at least when I do a cat /dev...mouse2 it shows output from the trackball.

    I am unable to keep the settings of mouse_device="mouse2" to use the trackball... it keeps reseting back to mouse. I tried adding the trackball_device="mouse2" but that didn't seem to work either.

    looking for other ideas....



  • @jlvandusen Have you tried setting the mouse index? You can do this in the RGUI or add/edit a configuration line in /opt/retropie/configs/all/retroarch-core-options.cfg where you should have these core options set:

    mame2003-mouse_device = "mouse"
    input_player1_mouse_index = "X" 
    

    where X is the mouse number you want to use for Player 1.

    I also found someone a few months ago that had to add this line to the same file in order to enable their mouse:

    mame_current_mouse_enable = "enabled"
    


  • @caver01 said in X-Arcade Tankstick + trackball:

    jlvandusen Have you tried setting the mouse index? You can do this in the RGUI or add/edit a configuration line in /opt/retropie/configs/all/retroarch-core-options.cfg where you should have these core options set:
    mame2003-mouse_device = "mouse"
    input_player1_mouse_index = "X"

    where X is the mouse number you want to use for Player 1.
    I also found someone a few months ago that had to add this line to the same file in order to enable their mouse:
    mame_current_mouse_enable = "enabled"

    @caver01 - Thank you - I will give that a shot



  • @caver01 - that didn't work and was ignored.. I tried applying it directly at the roms cfg
    but I got it to work with mame4all.. cannot get it to work with the lr-mame2003 or 2010 etc..
    I am running into the same issue with the spinner too



  • @jlvandusen what do you mean it was ignored? Are you certain you have the right index number?


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.