Please do not post a support request without first reading and following the advice in

CUE and BIN questions for PSX

  • Hello all,

    First off I don't know if this is the right place or if I should have posted this in "General Discussion and Gaming", if that is the case, please move this or let me know so I can repost :)

    Okay now to my questions: Does CUE sheets support subfolders?

    I have done a lot of testing but I just can't seem to get it to work for PSX games on the RetroPie.

    I have tried the following formats for the FILE attribute in the CUE Sheet:

    FILE ".\Spyro the Dragon (USA)\Spyro the Dragon (USA).bin" BINARY
    FILE "Spyro the Dragon (USA)\Spyro the Dragon (USA).bin" BINARY
    FILE "home\pi\RetroPie\roms\psx\Spyro the Dragon (USA)\Spyro the Dragon (USA).bin" BINARY
    FILE "~\RetroPie\roms\psx\Spyro the Dragon (USA)\Spyro the Dragon (USA).bin" BINARY

    And none of them seems to work.

    I tested with a .ogg file on my windows system (because I have no way to play PSX cue/bin format games on Windows, that I could find) and here subfolders work just fine with something like:

    FILE "subfolder\filename.ogg" BINARY

    I also got my roms on a network drive if that might be the cause of the issue?

    Anyways if anyone knows if this is possible please let me know!

    Thanks for reading!

    Just wanna explain why I want this.
    In if you have your bin/cue files in subfolders under the psx rom folder, they will show up as folders in ES, so I have to do two clicks to start the game.
    I know I can fix this by just dumping all the files into the root psx rom folder, but I don't really like have all the files like that, I like at least a little bit of order.

  • @son_of_diablo Eh, bin\cue is one of the oldest formats around. I was playing pc-engine cd games in bin\cue in the late 90's. Bin\cue is also the uncompressed game. Ogg/mp3 and crap are lower quality audio. I don't believe mp3/ogg is even supported on these emulators.

    You don't need to put subfolders in a cue file. FILE "Spyro the Dragon (USA).bin" BINARY is fine. Not sure why you'd want to. It will work fine as is. The pi is case sensitive so make sure that's right. Or just convert/download the games in eboot .pbp format and make things easier on yourself.

  • @darksavior

    Well as I mentioned I want to put the bin files in subfolders to have some kind of order in my files structure and have the cue files in the root psx roms folder so that I don't have to go into subfolders in ES.

    I have looked into converting them to pbp files, but it seems like a tedious task as I can't find a way to do it in bulk and I have to do it one game at a time.
    Do you have any suggestions for this or is that just how it is?

  • Global Moderator

    @son_of_diablo I don't have a Pi at hand to test, but try changing the path separator from \ to / and re-test.

  • @mitu

    So I have tried with / instead of \

    both as:
    FILE "./Spyro the Dragon (USA)/Spyro the Dragon (USA).bin" BINARY
    FILE "Spyro the Dragon (USA)/Spyro the Dragon (USA).bin" BINARY

    but both times I get these error messages in runcommand.log (located in /dev/shm):
    could not open: /home/pi/RetroPie/roms/psx/Spyro the Dragon (USA).bin
    unsupported/invalid CD image: /home/pi/RetroPie/roms/psx/Spyro the Dragon (USA).cue

    full log:

    Executing: /opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/lr-pcsx-rearmed/ --config /opt/retropie/configs/psx/retroarch.cfg "/home/pi/RetroPie/roms/psx/Spyro the Dragon (USA).cue" --appendconfig /dev/shm/retroarch.cfg
    Starting PCSX-ReARMed
    Running PCSX Version 1.9 (Mar 20 2018).
    psxMap: warning: wanted to map @80000000, got 0x741c9000
    Init new dynarec
    testing if we can run recompiled code..
    test passed.
    warning: RAM is not directly mapped, performance will suffer
    Mapped (RAM/scrp/ROM/LUTs/TC):
    found BIOS file: SCPH1001.BIN
    RGB565 supported, using it
    plugin: plugins/builtin_gpu
    plugin: plugins/builtin_spu
    plugin: plugins/builtin_pad
    plugin: plugins/builtin_pad
    Plugins loaded.
    Loaded CD Image: /home/pi/RetroPie/roms/psx/Spyro the Dragon (USA).cue
    could not open: /home/pi/RetroPie/roms/psx/Spyro the Dragon (USA).bin
    Track 01 (DATA) - Start 00:02:00, Length 00:00:00
    selected sound output driver: libretro
    unsupported/invalid CD image: /home/pi/RetroPie/roms/psx/Spyro the Dragon (USA).cue

    Would you know why it doesn't look in the subfolder as specified in the cue file?
    Is that something to do with the run command script?

  • If you don't want to change your .cue file, you may test this option:

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.