Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

second identical controller issues #secondcontroller #USBProblem



  • Hi there,

    I got a problem.. i got 2 identical SNES INNEXT controller.

    I got a Pie 3B+ and the latest retropie version installed 2 day before.

    now the problem:
    The first controller works without any problems and it doenst matter which one i use.
    And it also doesnt matter which of the four USB-Ports i use.
    The second controller isnt working really reliable.

    Sometimes it works sometimes not.. sometimes i got to switch the USB Port ..
    but i alway have to config the second controller via the emulationstation input setup.

    Its like the system doenst save the configuration.

    I followed some instructions belonging the retroarch second controller setup,
    but there are some problems, because i can choose the controller and everything.
    The problem there is.. if i wanna assign f. e. button A .. i press it .. the 3 second infobox dissapears but in the assignment line there was shown N/A

    in generally i think there is a problem with USB and the probably identically controller.

    I hope you know what i mean and can help me..

    this is not a big issue because if i use anothers USB ports everytime i start up the pi, i can configure the second controller an play.. but in terms of comfort and realiability .. thats not really nice.

    please help me, if there is any suggestion i can follow



  • actually i think there is a hardware problem with the controller.
    as i booted retropie right now.. no controller was found. unless i plug in the other controller.

    so i probably think there is a hardware issue with the one controller..



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.