Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

AdvMAME 1.4 ROM Set 106 - Not Found



  • @caver01

    Sorry I should have mentioned that I tried using both Advmame and Advmame 1.4 since both emulators use the same ROM set 0.106 as per Retropie wiki.

    EDIT:
    I looked at both advmame.rc and advmame-1.4.rc as well as advmame-0.94.rc. All 3 are showing:

    dir_rom /home/pi/RetroPie/roms/mame-advmame:/home/pi/RetroPie/roms/arcade
    

  • Global Moderator

    What's the content of your 1942.zip file ? Does it match the output of the missing .bin files ?



  • @raspy and something you have not share but must be asked, where are your rom files located, specifically the path to 1942.zip?



  • @mitu

    Yes the contents in "1942.zip" for example does match the files that are said to be missing from the runcommand.log file.

    @caver01

    I just follow the retropie wiki and I have the file "1942.zip" located at "./Retropie/roms/mame-advmame".

    pi@arcade1up:/dev/shm $ cat runcommand.log
    Parameters:
    Executing: /opt/retropie/emulators/advmame-1.4/bin/advmame "1942"
    AdvanceMAME - Copyright (C) 1999-2003 by Andrea Mazzoleni
    MAME - Copyright (C) 1997-2003 by Nicola Salmoria and the MAME Team
    1-n3a.bin    NOT FOUND
    1-n4.bin     NOT FOUND
    1-n5.bin     NOT FOUND
    1-n6.bin     NOT FOUND
    1-n7.bin     NOT FOUND
    1-c11.bin    NOT FOUND
    1-f2.bin     NOT FOUND
    2-a1.bin     NOT FOUND
    2-a2.bin     NOT FOUND
    2-a3.bin     NOT FOUND
    2-a4.bin     NOT FOUND
    2-a5.bin     NOT FOUND
    2-a6.bin     NOT FOUND
    2-l1.bin     NOT FOUND
    2-l2.bin     NOT FOUND
    2-n1.bin     NOT FOUND
    2-n2.bin     NOT FOUND
    08e_sb-5.bin NOT FOUND
    09e_sb-6.bin NOT FOUND
    10e_sb-7.bin NOT FOUND
    f01_sb-0.bin NOT FOUND
    06d_sb-4.bin NOT FOUND
    03k_sb-8.bin NOT FOUND
    01d_sb-2.bin NOT FOUND
    02d_sb-3.bin NOT FOUND
    k06_sb-1.bin NOT FOUND
    01m_sb-9.bin NOT FOUND
    ERROR: required files are missing, the game cannot be run.
    
    
    pi@arcade1up:~/RetroPie/roms/mame-advmame $ unzip -l 1942.zip
    Archive:  1942.zip
    TORRENTZIPPED-EC24370D
      Length      Date    Time    Name
    ---------  ---------- -----   ----
          256  1996-12-24 23:32   01d_sb-2.bin
          256  1996-12-24 23:32   01m_sb-9.bin
          256  1996-12-24 23:32   02d_sb-3.bin
          256  1996-12-24 23:32   03k_sb-8.bin
          256  1996-12-24 23:32   06d_sb-4.bin
          256  1996-12-24 23:32   08e_sb-5.bin
          256  1996-12-24 23:32   09e_sb-6.bin
        16384  1996-12-24 23:32   1-c11.bin
         8192  1996-12-24 23:32   1-f2.bin
        16384  1996-12-24 23:32   1-n3a.bin
        16384  1996-12-24 23:32   1-n4.bin
        16384  1996-12-24 23:32   1-n5.bin
         8192  1996-12-24 23:32   1-n6.bin
        16384  1996-12-24 23:32   1-n7.bin
          256  1996-12-24 23:32   10e_sb-7.bin
         8192  1996-12-24 23:32   2-a1.bin
         8192  1996-12-24 23:32   2-a2.bin
         8192  1996-12-24 23:32   2-a3.bin
         8192  1996-12-24 23:32   2-a4.bin
         8192  1996-12-24 23:32   2-a5.bin
         8192  1996-12-24 23:32   2-a6.bin
        16384  1996-12-24 23:32   2-l1.bin
        16384  1996-12-24 23:32   2-l2.bin
        16384  1996-12-24 23:32   2-n1.bin
        16384  1996-12-24 23:32   2-n2.bin
          256  1996-12-24 23:32   f01_sb-0.bin
          256  1996-12-24 23:32   k06_sb-1.bin
    ---------                     -------
       215552                     27 files
    pi@arcade1up:~/RetroPie/roms/mame-advmame $
    
    


  • @raspy hmmm. Head scratcher for sure. Might need to see a pastebin of your .rc files. Is this failure the same with any rom or just 1942? What about other emulators? Are you trying any other versions of MAME for example?

    Could it be a permissions issue?


  • Global Moderator

    @raspy Can you run

    ls -l $HOME/.advance
    

    and post the output ? The configuration file is ok, but it might not be interpreted by advmame. Normally the output of the command should be somethine like

    lrwxrwxrwx 1 pi pi 34 Jan  3 16:14 /home/pi/.advance -> /opt/retropie/configs/mame-advmame
    


  • @mitu

    I type the command and this shows up:

    pi@arcade1up:~ $ ls -l $HOME/.advance
    total 96
    -rw-r--r-- 1 pi pi 17643 Jan  6 01:55 advmame-1.4.rc
    -rw-r--r-- 1 pi pi 29214 Jan  6 01:55 advmame.rc
    drwxr-xr-x 2 pi pi  4096 Jan  3 13:15 artwork
    drwxr-xr-x 2 pi pi  4096 Jan  3 13:15 diff
    drwxr-xr-x 2 pi pi  4096 Jan  3 13:15 hi
    drwxr-xr-x 2 pi pi  4096 Jan  3 13:15 image
    drwxr-xr-x 2 pi pi  4096 Jan  3 13:15 inp
    drwxr-xr-x 2 pi pi  4096 Jan  3 13:15 memcard
    drwxr-xr-x 2 pi pi  4096 Jan  3 13:15 nvram
    drwxr-xr-x 2 pi pi  4096 Jan  3 13:15 rom
    drwxr-xr-x 2 pi pi  4096 Jan  3 13:15 sample
    drwxr-xr-x 2 pi pi  4096 Jan  3 13:15 snap
    drwxr-xr-x 2 pi pi  4096 Jan  3 13:15 sta
    pi@arcade1up:~ $
    
    

  • Global Moderator

    That's might be the problem. The $HOME/.advance should be a symbolic link to the /opt/retropie/configs/mame-advmame - from where you posted your .rc files.
    Can you try renaming the folder (mv $HOME/.advance $HOME/.advance.orig) and re-installing the advmame package (the 3.x one, without any version) ?



  • @mitu

    Okay I will try that later tonight (been working 12 hour shifts...). It's weird because I don't know why it wasn't a symbolic link to start with when I started off with a fresh install of retropie 4.4 and all I did was remove all the emulator packages so that I could choose only the emulators that I wanted to install from source.



  • @mitu

    Okay I tried reinstalling "advmame" from the source again as you suggested and now the permissions look like this:

    lrwxrwxrwx 1 pi pi 34 Jan  9 08:01 /home/pi/.advance -> /opt/retropie/configs/mame-advmame
    
    

    First run with "1942.zip" is now working! Thank you!



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.