Please do not post a support request without first reading and following the advice in

Buffalo Classic USB Gamepad - can't skip buttons during configuration

  • @phoenixoverlord You just hold a button down to skip, as it says.
    The TURBO and CLEAR buttons on the pad are not recognised as inputs on any OS. They simply modify how the controller sends the signal to the system. They can't be used or mapped to any other function.

  • @jonnykesh and that's the part that isn't working. I've tried just pressing a button, holding it down for various amounts of time (1 to 20 seconds) and nothing worked.

    Yes, the 360 controller is working, but even with that one I was unable to skip the configuration of a button by holding down one. All it tells me is that the key is already in use (and this is true for either the Buffalo USB pad and the 360 one).

    @stoney66 so do I need to create a "USB,2-AXIS 8-BUTTON GAMEPAD.cfg" file with the settings in it or will that not work either? If so, what would be the correct filename for this case?

  • @phoenixoverlord The button you are holding may have the TURBO switched on which is causing problems. Try Holding each button and pressing CLEAR which will turn off the TURBO option.
    I had one of these controllers and had no issues setting it up and I'm not aware of any issues from others similar to the one you are having.
    Which means one of two things, you have a broken piece of hardware or user error.

  • @jonnykesh okay, I'll give that a whirl tomorrow. Thank you for the suggestion!

  • I was having this same problem with the same controller. I used the A button to hold and skip the configuration for the triggers and analog sticks. It works great! I hope you get it sorted out!

  • Well this is frustrating.

    I have a tablet on which I've installed Ubuntu and then RetroPie (also 4.4). I hook up the controllers and I can go through the setup without so much as a whisper of an issue. They both work fine. I can go through ES and play games.

    I've copied the generated file from the linux tablet to the Pi and now it doesn't ask me to configure the controller. I thought that that was going to be it. Well.... none of the buttons work in ES. I can't move in the menu or bring up anything.

    Is there anything else that I can do or look at to make these working on my Pi? I'm grasping at straws here....

    The generated file is: USB,2-axis 8-button gamepad .cfg

    Its contents on the tablet:
    input_device = "USB,2-axis 8-button gamepad "
    input_driver = "udev"
    input_l_btn = "4"
    input_load_state_btn = "4"
    input_start_btn = "7"
    input_exit_emulator_btn = "7"
    input_down_axis = "+1"
    input_r_btn = "5"
    input_save_state_btn = "5"
    input_right_axis = "+0"
    input_state_slot_increase_axis = "+0"
    input_select_btn = "6"
    input_left_axis = "-0"
    input_state_slot_decrease_axis = "-0"
    input_up_axis = "-1"
    input_a_btn = "0"
    input_b_btn = "1"
    input_reset_btn = "1"
    input_enable_hotkey_btn = "6"
    input_x_btn = "2"
    input_menu_toggle_btn = "2"
    input_y_btn = "3"

  • Global Moderator

    @phoenixoverlord The configuration file is fine, I have the same controller and it's exactly the same, however this is used by RetroArch. Emulationstation has a different config file in /home/pi/.emulationstation/es_input.cfg, where the config fragment for this gamepad looks like

      <inputConfig type="joystick" deviceName="USB,2-axis 8-button gamepad  " deviceGUID="03000000830500006020000010010000">
        <input name="pageup" type="button" id="4" value="1"/>
        <input name="start" type="button" id="7" value="1"/>
        <input name="up" type="axis" id="1" value="-1"/>
        <input name="a" type="button" id="0" value="1"/>
        <input name="b" type="button" id="1" value="1"/>
        <input name="down" type="axis" id="1" value="1"/>
        <input name="pagedown" type="button" id="5" value="1"/>
        <input name="right" type="axis" id="0" value="1"/>
        <input name="x" type="button" id="2" value="1"/>
        <input name="select" type="button" id="6" value="1"/>
        <input name="y" type="button" id="3" value="1"/>
        <input name="left" type="axis" id="0" value="-1"/>

    You should make sure the turbo function is not activated and then re-configure the gampad again in ES, it's a plug-n-play controller as far as RetroPie is concerned.

  • I use 2 of the Buffalo gamepads too and they are working flawlessly. Let me know if you want me to checkup something. Can't imagine for now what this problem is causing.

  • @mitu I've checked that file and sure enough there's nothing in there for this controller. I do have my XBOX and keyboard listed in it.

    Is there a way to determine the deviceGUID manually so I can add it in this file myself?

    Other than that, how does that turbo function work in the first place? As mentioned before, I can plug this same controller in to a linux tablet and it works fine there. So is the turbo function stored per device? Another user mentioned to click the clear button while holding each button too and I have done that. But that didn't do anything either.

    Maybe I've answered my own question here.... Since I do have this working on my tablet, can I use the es_input.cfg lines from the tablet and paste them into the one on the Pi?

    @thelostsoul thank you too for your offer! At this point I don't know what I don't know, so I'm not sure what else to do. :)

  • Global Moderator

    @phoenixoverlord said in Buffalo Classic USB Gamepad - can't skip buttons during configuration:

    Other than that, how does that turbo function work in the first place?

    @jonnykesh posted earlier in the topic, they're hardware buttons that act as a toggle to turn turbo on/off for any of the 4 buttons. You press the Turbo + A and it's on, you press Clear + A and it's off, etc. They don't act as standalone buttons and if you press it, there is nothing sent to the system.

  • @mitu your earlier post really helped me out. I copied the lines from my tablet to the Pi and now the controller is working!

    Is there anything special that has to be done to use 2 controllers? Should there be 2 entries?

  • Global Moderator

    @phoenixoverlord said in Buffalo Classic USB Gamepad - can't skip buttons during configuration:

    Should there be 2 entries?

    No, if they're identical one config should work. Give it a go and report back.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.