Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Start retropie and start with the same game



  • Hello I would like to turn on my raspberry zero and boot retropie always with the same gameboy game (is my favorite) ready to play. How could I do or configure and where to do this? regards


  • Global Moderator

    @javier There's no option to do that, but you can replace the start of Emulationstation - in the autostart.sh script- with the command to start your game, followed by the Emulationstation start command. You can edit the autostart command from the RetroPie-Setup script itself.



  • Thank you very much for your quick reply. But I am a person with very little knowledge, could you please explain it to me in a more detailed way I would greatly appreciate it. regards


  • Global Moderator

    What is the name of the ROM - full filename - and which emulator is it using ?



  • Rom: tetris.zip
    Emulator: ir-gambatte

    Thanks you


  • Global Moderator

    @javier Which rom folder are you using ?



  • gb

    thanks


  • Global Moderator

    OK, you'll need a keyboard for this. Go to the RetroPie-Setup script, into the Configuratio/Tools -> Autostart, then choose the Manually edit. The file should read

    emulationstation #auto
    

    Add a line before so the contents of the file are

    /opt/retropie/supplementary/runcommand/runcommand.sh 0 _SYS_ gb /home/pi/RetroPie/roms/gb/tetris.zip
    emulationstation #auto
    

    Then reboot and the system should start with the game instead of Emulationstation. If you wish to revert to the default behavior, edit the file again and remove the line added.



  • Thank you very much for your help, it has been really useful for me. I will start with the process. regards



  • @mitu Hi mitu, I found these instructions extremely helpful. I'm trying to do something similar as Javier, but my ROM is on a USB thumb-drive. So, I'm typing up the following after "emulationstation #auto":

    /opt/retropie/supplementary/runcommand/runcommand.sh 0 SYS atari2600 /root/retropie/roms/atari2600/Yar_rev.bin

    And the pi is still booting up to RetroPie.
    How are you saving the script?
    Is my ROM supposed to be saved locally on the Pi?
    Is my edit wrong?

    Any help is much appreciated.

    I'm on a Raspberry Pi 3 with Retropie 4.5
    -CanaKit 2.5A Power supply
    -Built from a SD with an image from the RetroPie website
    -USB Devices connected: PC keyboard, generic mouse
    -Controller used: Retrolink Atari joystick
    -Guide used: https://retropie.org.uk/docs/First-Installation/


  • Global Moderator

    @Razak There's nothing different if you have an USB or not. Your mistake is that you need to add the line before the start of Emulationstation command, not after.


  • Global Moderator

    Also, are you sure that your ROM is in the /root home folder ?

    Exit Emulationstation, then type the command at the prompt and see if the ROM starts automatically.



  • @mitu Oh geez, thank you. Forgive my absentmindedness.

    I'm still running into some issues with the run command script. I'm not certain I'm calling the emulator correctly in the first flag.

    This is how I manually edited:

    /opt/retropie/supplementary/runcommand/runcommand.sh 0 _SYS_ atari2600 /root/retropie/roms/atari2600/Yar_rev.bin emulation station #auto
    

  • Global Moderator

    @Razak said in Start retropie and start with the same game:

    This is how I manually edited:

    That's not correct, the file should have 2 lines. As I said, execute the ROm start line from the command prompt and see if it works. If it's not working, then what's the error ?

    /opt/retropie/supplementary/runcommand/runcommand.sh 0 _SYS_ atari2600 /root/retropie/roms/atari2600/Yar_rev.bin
    


  • @mitu I misspoke because after a couple of re-initiations, the Raspberry pi is now booting up to the ROM. But, the aspect ratio is wrong and I'm unable to disable the auto-run function. F4 on the keyboard is not halting the function. Is there another way to get back to the emulationstation configuration menu?


  • Global Moderator

    @Razak said in Start retropie and start with the same game:

    But, the aspect ratio is wrong and I'm unable to disable the auto-run function.

    Depending on your emulator, you might have to configure that first, by running the ROM from Emulationstation and configuring the video aspect/pixel stretching in the emulator.

    F4 on the keyboard is not halting the function. Is there another way to get back to the emulationstation configuration menu?

    F4 only works in Emulationstation. While you're in an emulator, it depends on the emulator - if you have a gamepad try Select + Start or Esc if you're on a keyboard.
    Open a new topic with these issues and add the info requested in https://retropie.org.uk/forum/topic/3/read-this-first.


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.