Please do not post a support request without first reading and following the advice in

Quake3 on Raspi RetroPie - USB PCM2704 DAC Woes

  • Hello folks,
    I have a PCM2704 based usb DAC plugged in. I've made the asound.conf update that forces the DAC to be used, and it works fine in the mame, snes and megadrive games I've tried. All dandy.
    However, I'm trying to do some LAN gaming with quake3 and having some difficulty. I can play quake3 on the first level (against Crash) and the system works fine, but when I load other levels, or try and play multiplayer, the entire raspi crashes.

    I've removed the asound.conf file (so it goes back to using the 3.5mm output) and all is fine again.

    I'm int he middle of developing a USB headphone amp and amplifier for a portable retropie build. Any hints/suggestions you can provide would be appreciated!

    Thanks again


  • Global Moderator

    That's weird - do you have a log file for q3 ? It should produce one in the ~/.q3a/ folder every time you run the game. The only idea that comes to mind right now is that when switching to multiplayer it tries to activate the VoIP support, so you should try to disable that in the config file (see for a list of cvars controlling this feature).

  • Hello mitu,

    thanks for your reply. I looked a the games.log file. no details of the crash.
    I also tried the "set cvars" in the ingame control panel etc, still crashed.

    not sure where to go from here.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.