Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Auto login not working



  • I just ran updates on my Pi 3B+ setup this morning and auto login is not working. It asks for lightgm. Unfortunately, sudo apt-get install lightgm is unable to locate the package.



  • Lightdm is not needed for auto-login and is not installed by RetroPie. What's the exact error you're receiving ? Have you done other configurations to the image or modified the autologin settings ? Use the setup script and go to Configuration / tools>>autostart and make sure Emulationstation is selected for autostart.



  • @mitu I have done no other configuration editing and I have already attempted to set the auto login by that method. It tells me that lightgm is missing which is why I tried to install it.



  • I have solved my own problem. For some reason I was repeatedly misspelling "lightdm" as "lightgm" in my install command. It was a chain of repeated derpage on my part.

    That is what it wanted, though. It seems lightdm is required.



  • i had the same thing like Bedar and did what mitu said:

    Config -> Retropie Setup -> Configuration / tools -> autostart -> Start Emulation Station at boot

    and it autologin after a reboot again. thx you guys for the help.



  • @dudino thanks



  • @mitu - Worked for me. I updated to newest version and suddenly auto login did not work. I went into Retro-Pie settings as you suggested, chose autostart (though it should have still been set), reset my password again for good measure, and it worked fine.

    I think sometimes people forget that Windows usually keeps settings. In a Linux environment, an update can overwrite config settings, thus requiring you to set them again.

    Thanks for the post.


 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.