Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Map "Logitech" button on F710 directly to RGUI menu?



  • I have a Logitech F710 with a "Logitech" button running in Xinput mode.

    Is there any way to configure is so that when I press this button (and only this button) I get the RetroArch in-game menu? I don't want to remember a button combination.

    The best alternative I thought I could get would be Logitech+X so I followed these instructions and edited the value of input_enable_hotkey_btn - however none of my hotkey combinations work.



  • You could unbind the "Enable Hotkeys" hotkey along with every single other hotkey, then bind the "Logitech" button to input_menu_toggle_btn which should be input_menu_toggle_btn = "10" (that's what it is on my F310). That's the only way to achieve what you want.



  • Fantastic! Thank you!

    It wasn't helped by the fact that I got my button number wrong (oops!).

    In case anyone else stumbles across this post, edit /opt/retropie/configs/all/retroarch-joypads/Logitech Gamepad F710.cfg, remove the line starting input_enable_hotkey_btn and edit the number for input_menu_toggle_btn so it matches that of the Logitech button.

    (Edit: You need to do more than this, see later post)

    Use jstest /dev/input/js0 to get the right button number for the Logitech button. Mine was actually 8 and not 10 as I originally put.



  • @silver I hope you unbound all the other hotkeys as well since those will all now activate when you press the button they are assigned to and make playing games impossible.



  • @eckaji said in Map "Logitech" button on F710 directly to RGUI menu?:

    @silver I hope you unbound all the other hotkeys as well since those will all now activate when you press the button they are assigned to and make playing games impossible.

    No I didn't and just as you wrote this I was thinking to myself "why is my save state changing in-game?".

    Is there any easy way to disable them all? Or do I have to just walk through the config file and rip them out manually?



  • @silver said in Map "Logitech" button on F710 directly to RGUI menu?:

    Is there any easy way to disable them all? Or do I have to just walk through the config file and rip them out manually?

    You'll have to do the same thing you did with input_enable_hotkey_btn.



  • Brill, thanks very much!

    So I removed the following lines from /opt/retropie/configs/all/retroarch/autoconfig/Logitech Gamepad F710.cfg:

    input_load_state_btn = "4"
    input_exit_emulator_btn = "7"
    input_save_state_btn = "5"
    input_state_slot_increase_btn = "h0right"
    input_state_slot_decrease_btn = "h0left"
    input_reset_btn = "0"
    input_enable_hotkey_btn = "8"
    

    and then made sure that that the next line was correctly mapped to my Logitech button (in my case 8):

    input_menu_toggle_btn = "8"
    

    A quick test suggests that it's working great :)



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.