Please do not post a support request without first reading and following the advice in

  • Thanks mate!

  • @movisman Great man! Thx1! :)

  • I just setup an older i7 laptop using this guide. Everything works great except one problem:

    Regardless of the emulator and rom I am using, the screen will timeout after ~5-10 minutes of play. If I move the mouse or keyboard, the screen comes back on and all is fine...for another 5-10 minutes.

    I think I found the same issue on git:

    Does anyone have a fix for this?

  • @scales11 in terminal type "xset q" and what settings do you have?

  • @bloodykean, No I did not.

    However, once I installed “xdg-utils” my screensaver/timeout was fixed. NOTE: xdg-utils is the Debian package that contains xdg-screensaver

    I also noticed that with the install method I chose I do not have a ~/.config/retroarch/retroarch.cfg file. Could this file be somewhere else?

  • @scales11

    Glad you fixed the issue. I must say I didn't get this problem when installing on Ubuntu Server 18.04.1 using my Samsung TV over HDMI, but I did get screen blanking after 10 minutes and I had to wake it up with a keyboard/mouse - it wouldn't wake with the controller.

    I fixed this with the commands in post 38:

    I also had an error saying 'xdg-screensaver not found' when exiting Retroarch from the Setup screen, but installing 'xdg-utils' (which in turn installs xdg-screensaver) clears that error. So it's worth doing that anyway if running RetroPie on Ubuntu Server which has minimal packages.

    I have this on my own documentation (which I will publish at some point).


  • I also noticed that with the install method I chose I do not have a ~/.config/retroarch/retroarch.cfg file. Could this file be somewhere else?

    I think the default is here off the top of my head:

  • I'm trying to get the Plymouth working on my Intel NUC8 but at boot I only see a black screen. Sometimes I get the RetroPie logo for a brief 1 or 2 seconds.
    Any one have a clue whats going on?

  • @movisman or maybe someone else... 😉
    Everything seems to be running excellent with Ubuntu Server except Dolphin GUI menu and for instance the FPS counter are really big. This seems to be a resolution issue.

    As we don’t use a normal desktop is there a way to specify the resolution used on my machine.
    Dolphin seems to use the desktop res.

  • Just wanted to pass along my thanks for the great information that is in this thread. I have wanted to build a system that looked just like the RPi but on x86 for a while, and never got it right. These steps nailed it for me.

    For anyone interested in an automated setup of the required configs, I have created a bash script that takes care of everything, and shared it on GitHub:

    It does not (yet?) handle the TV resolution changes, or the VNC login, but everything else mentioned here is collected in one place. Hopefully it is useful for others. I don't know how actively I will maintain this or improve upon it - probably depends on the interest and feedback.

    On that note, please give it a shot - I welcome your feedback!

  • @MisterB thxs, great idea. Its r un on x64?
    I sugest to add a install script for music on emulationstation, and install and update video drivers, including vulkan.

    Retropie BGM script:

  • Which emulators benefit from the Vulkan drivers?
    I'm running without them and everything seems to run smooth.
    But of course improvement is always good. :)

  • @wmarcio - Good point, this script is technically for X64 - I have not tried it on a 32-bit install.

    The code to upgrade the video drivers and install Vulkan is actually in there. I haven't 'enabled' it yet, as I haven't had a chance to test that everything still works after the upgrades. This is where adding some configurability options would be nice... But for now you can append the following to the end of the script before running it if you want:


    I don't know anything about the music capabilities. I will look into it.

  • @MisterB thxs, i will test your script tomorrow.

  • @MisterB Excellent work! I just ran the script against an Ubuntu 18.04 install (using the x64 mini iso) and everything seems to be working as expected. The only thing I had to do was install curl prior.

    I'll continue to test and report back.


  • Has anyone had any luck running Naomi/Atomiswave ROMs (MAME .zips) on this config using lr-beetle-dc (formally lr-reicast)...specifically on an Intel GPU?

  • @Panja said in Retropie Installation on Ubuntu Server x64 18.04.1:

    Which emulators benefit from the Vulkan drivers?
    I'm running without them and everything seems to run smooth.
    But of course improvement is always good. :)

    Any one?

  • @MisterB Just tried this in x86 18.04 and it works great. Did some preliminary testing with vulkan drivers too and no issues to report yet. Really great work on putting this together. I second adding the optional steps into the script. Thank you again - great work.

  • @retroczr should add that I used the server install, not the mini.iso.

  • @MisterB Massive thanks for the script! I used your script yesterday and it completed successfully, but when I boot I just see a mouse and what seems a openbox interface, not emulstation. When I click with the right mouse button I get the options to start a terminal, applications, restart, reconfigure etc. but when I start the terminal I see nothing. The mouse unclutters nicely so the autostart has run at some point.
    If I login with ssh and run ps aux I see that the emulstation process is running. I suspect there might be some overscan or wrong resolution at play and therefore the terminal isn't visible but this shouldn't matter for emulstation starting fullscreen right?
    I tried some xrandr command in the openbox autostart config to adjust the resolution but to no avail. I will test further tomorrow but any pointers will be highly appreciated :)

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.