Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

  • @MisterB

    Okay! So I have some feedback for you on Ubuntu Server 18.04.4, I found a few minor issues with the script (clean install) but worked out fixes for all (i think). I am very much a beginner with some of this stuff but it was good to learn and challenge myself somewhat! There was also an issue with Nvidia cards when they have the proprietary driver installed (not nouveau), and I pretty much spent all my free time this week diagnosing an issue with X not launching as a result (black screen), which I FINALLY nailed down to being caused by recommended packages not being installed (--no-install-recommends) on the retropie depends function. I think it might be xorg causing the problem there, maybe it needs additional packages to work for Nvidia, but need to check that out further. Taking --no-install-recommends out though fixes the problem either way. If you are using Intel, it works either way, which is possibly why it wasn't picked up.

    Anyway, instead of going into detail on each issue, I did try to document my changes so I could give you a little changelog. What I have done, is make a fork of your repository onto my github page and update it with my changes. If you want to take a look that'd be great, let me know what you think. I also added a few functions, which are optional (commented out by default).

    I'll post my changelog and github link below. Hope you don't mind me having a go at fixing the few issues I came across and adding a few new things. I started to enjoy messing around with your script and trying to work out how to fix things, it's clearly laid out and a good starting point for someone who is learning. Was going to try and just fix a couple of the errors initially...and then got slightly carried away. You might have a better way of fixing some of the things I mentioned below but everything does seem to work and I didn't make any drastic changes.

    If you want further details on any of the issues I did come across, I did quite a bit of testing so should be able to elaborate further on each point.

    I did loosely test this with the mini.iso too - it seems to work, but I did have issues with the splash screen not showing up (just blank), this might be an Nvidia thing though or maybe some other packages need to be installed to make it show. Didn't really test in detail, most of my testing was performed on Ubuntu Server 18.04.

    Link to my cloned github repository:
    https://github.com/movisman/RetroPie-Setup-Ubuntu

    This should have the updated script and i’ve updated the readme as well.

    Here is the changelog - might have missed a couple of things but should be reasonably complete:

    Existing Functions:

    function disable_sudo_password

    • tweak logic so it creates a file in the /etc/sudoers.d directory to disable sudo password, rather than editing sudoers directly (more dangerous and can be overwritten by updates)

    function install_retropie_dependencies

    • remove -no-install-recommends as having this causes a blank screen on boot for nvidia cards when using a proprietary driver

    function install_retropie

    • reinstated the core module install method (retroarch, emulationstation, retropiemenu, runcommand, plus samba) - let me know if you knew what the issue was with using this method over the basic install...during all my testing it seemed to work fine going for core modules only?

    function add_retroarch_shaders

    • add line of code to remove the 'pi' centered shaders directory installed by RetroPie-Setup
      recreate the shaders directory afresh
    • add chown command at the end of the function to make sure everything under /opt/retropie/configs is owned by $USER
      function hide_boot_messages
    • improve logic on sed command so instead of relying on GRUB_CMDLINE_LINUX_DEFAULT having the value "quiet" or "" to make the changes needed, now it will replace whatever exists in the quotes with the intended attributes.

    function enable_plymouth_theme

    • remove -no-install-recommends just in case it causes issues - could possibly be restored as it seems to be ok with no-install-recommends set to true. However after my issue with no-install-recommends being enabled on the retropie depends function, I thought it would be safer to remove it.

    function hide_openbox_windows

    • remove $(cat $USER_HOME/.bash_profile) just before EOF, as this causes the 'startx' code to appear twice in .bash_profile (once at the top, and once below the gnome-terminal commands)
      reorder this function so it takes place before enable_autostart_xwindows - this ensures that the gnome-terminal code is run before startx is called
    • changed chown command so it changes ownership to $USER from .config recursively instead of .config/openbox - this resolves an issue where .config/dconf (which gets created when gnome-terminal is first launched) is incorrectly owned by root - this then causes DCONF console errors for the gnome-terminal customisation when .bash_profile is called, resulting in no customisation happening because it cannot write to the file correctly (presumably because it is owned by root). Changing the chown command totally resolves this problem, resulting in fully customised black and green terminal with no bars etc.

    function enable_autostart_xwindows

    • change ~/ on several lines to $USER_HOME/ to match other functions

    function autostart_openbox_apps

    • changed chown command to /opt/retropie/configs recursively instead of just changing ownership on autostart.sh, otherwise some of the directories get owned by root again. opt/retropie/configs and all files/folders beneath should be owned by $USER

    function install_vulkan

    • remove -no-install-recommends just in case it causes issues - could possibly be restored, but haven't tested for issues by leaving no-install-recommends set to true with vulkan. After my issue with recommended packages on the retropie depends function I thought it would be safer to take this out.

    New Functions:
    added optional functions (not enabled by default) for:

    • installing the latest nvidia driver
    • install 'inxi' package and enable updates - can be used for checking hardware and system information
    • disabling screen blanking
    • force HDMI-0 to 1080p after startup (should be configured accordingly to suit output and resolution)
    • changing the GRUB graphics mode to 1920x1080x32 for nicer splash (if supported)
    • removing “error: XDG_RUNTIME_DIR not set in the environment” CLI error when exiting Retroarch from the RetroPie Setup screen within ES
    • final apt update/upgrade and cleanup unneeded packages (autoremove)
    • offer to reboot once last function is completed
    • fix permissions function which catches any potential snags where folders or files under $USER_HOME may get owned by root. note - this might need some improvement/sorting out, it basically chowns the home directory recursively so it is owned by $USER. Which should be ok as I think anything under home shouldn't be owned by anything else. It seems to work...currently it isn't needed after my above changes but I figured it was good to leave it as a fail-safe

    Misc:

    • added logging at top of file so console output is stored as retropie_setup_ubuntu.log when complete
    • add short confirmation after each function is run
    • reordered functions to match the order they execute in
    • reordered the execution of functions to resolve a couple of minor issues
    • add titles to all functions to tidy up a bit, add additional descriptions/info

  • @movisman @MisterB so I ran your script and all but one detail seems to work like a charm.
    When power on it boots up openbox into the login screen, where I need to enter the password before it starts. Once done it auto starts emulationstation.
    How do I make opebox autologin?
    thx!


  • @hulsie1983 solved it myself. apparently, I had to turn on autologin in the openbox GUI in the settings menu. In Emulstation in the retropie settings menu turned on the boot option and now all is working.


  • @hulsie1983

    Hi,

    You shouldn't have had the login box appear when using either script, however, I was personally using 18.04 as a base. Are you using 20.04? If so, I do remember at the time I did briefly test it with 20.04 (beta) and I did get a login box etc, and I think I had a few other teething issues - so just stuck with 18.04.

    Cheers


  • @movisman thank you :) your install script worked perfectly


  • @movisman are we able to exit emulation station to an Openbox desktop?

    one time emulation station did not load and I was left with this desktop -

    20200514_075831.jpg

    The only reason I ask is that I'm having trouble getting pcsx2 past the first time setup wizard


  • @gareth_iowc

    Hi there,

    This hasn't happened to me on 18.04.4, however of course if you quit ES you will get a black desktop with the menu if you right click. To configure Dolphin standalone I use the terminal and run the GUI to get everything working, but I must admit I haven't ever tried pcsx2 as the machine this runs on isn't powerful enough.

    I noticed @MisterB pulled all my previous enhancements into a new branch called LTS-20.04. So it's quite possible he is working on a new script for 20.04 users which includes some of the additions I put onto my 18.04.4 fork.

    Thanks


  • As @movisman mentioned, I now have an updated script for 20.04 that is available for testing, and it also includes many of his improvements. It's in a new branch found here: https://github.com/MizterB/RetroPie-Setup-Ubuntu/tree/LTS-20.04

    A list of changes is in the README, and it seems to be working OK in a 20.04 server virtual machine that I am developing against. If others would like to test it out and provide feedback I would appreciate it! Testing of this new version against physical installs of both 20.04 and 18.04 would be helpful. Thanks!


  • By the way, I also had the login screen issue in 20.04. It is fixed in my new branch, which boots the system into the multi-user (command line) runlevel, rather than the graphical one. Booting into multi-user makes it easier to finely-tune the way X Windows & OpenBox start up.


  • Applied this setup to my custom aarch64 build (NVIDIA Jetson Nano) and it works like a charm. The Nano doesn't have the same access to EGL from CLI as most other SBCs, so I was after a lightweight X solution, and this was the perfect solution.

    Many thanks!


  • @MisterB Would you mind sharing what you did to preseed a mini or server install? I have edited your preseed file to my needs but am having issues getting the installer (USB) to use it.

    Scratch that...figured it out. :)

    TIA!

    John


  • @MisterB said in Retropie Installation on Ubuntu Server x64 18.04.1:

    [...] If others would like to test it out and provide feedback I would appreciate it! Testing of this new version against physical installs of both 20.04 and 18.04 would be helpful. Thanks!

    @MisterB I am attempting to get RetroPie running on an older Intel computer (Core 2 Duo E8400, 4GB RAM, 500GB drive, ATI Radeon 7850) but I have an interesting issue after installing from the retropie_setup_ubuntu.sh setup script. I start with a clean install of Ubuntu 20.04 LTS and then use the build script. The build/configuration process takes about 70 minutes from start to finish and after it is done, I reboot the machine, see the Pacman animated screen for a bit, and then get left in a black screen and nothing else (no arrow, no cursor, nada).

    I know that removing all of that is by design but I am stuck on how to debug this. I can successfully SSH into the machine but wanted a bit of advice before I go mucking around in bash profiles, any grub files, etc.

    Also, after some fumbling around on the Ubuntu box, itself, I hit CTRL+ALT+F1 on the Linux box and then (blindly) started up X via startx. I could get a terminal window from there, if that helps describe where I am at.

    Not sure what I should be looking at, though. This does sound like a bit like some of the problems reported here so wanted to definitely chime in with my results and seek your advice. This is a purely physical build and I am fresh installing the OS. I am running the wget, chmod, and script execution exactly as detailed on https://github.com/MizterB/RetroPie-Setup-Ubuntu/tree/LTS-20.04.

    Not sure what to try. Thoughts? Happy to share the log file from the build, if that is helpful. Would -really- appreciate anyone's thoughts on what to try next.

    And thanks to all involved for putting together the script. This really has made the build and installation process painless. It feels like I am 98% of the way there but just a bug here or there is preventing the last bit of it to work.

    Any help would be appreciated!


  • @MisterB said in Retropie Installation on Ubuntu Server x64 18.04.1:

    As @movisman mentioned, I now have an updated script for 20.04 that is available for testing, and it also includes many of his improvements. It's in a new branch found here: https://github.com/MizterB/RetroPie-Setup-Ubuntu/tree/LTS-20.04

    A list of changes is in the README, and it seems to be working OK in a 20.04 server virtual machine that I am developing against. If others would like to test it out and provide feedback I would appreciate it! Testing of this new version against physical installs of both 20.04 and 18.04 would be helpful. Thanks!

    I believe that this line needs to be updated in your README.md:

    chmod +x ./retropie_setup_ubuntu.sh
    

    Should be....

    sudo chmod +x ./retropie_setup_ubuntu.sh
    

    If I don't run it as sudo I get an error.

    John


  • @ObiEric I ran into similar looking problem with Intel NUC. On boot it goes from plymouth boot screen to black screen (without mouse) and then in about 30 seconds drops back to shell. And, if I then manually enter 'startx', ES starts normally.

    Did you look into your
    /home/pi/.local/share/xorg/Xorg.0.log (<-- my xorg log in pastebin for failed start)?

    I have no idea what the root cause is but I'll hazard it has something to do with i915 / drm kernel modules being in bad state / not yet properly loaded (see somewhat similar issues here and here and e.g. here). Alas, none of the workarounds and their Ubuntu equivalents appeared to work.

    So I gave up and just upgraded to 5.8.4 Mainline Kernel. And...it works (at least with NUC).

    EDIT: also works with 5.7.18 kernel. 5.8.x had some issues (at least with NUC) which 5.7.18 doesn't appear to have, so I am going with that.

    EDIT #2: if applying this workaround, please check kernel.org for latest stable kernel releases (I am using 5.7.19 EOL as of 2020-09 for 8th gen NUC) and consider using Ubuntu mainline kernel matching one of the latest stables instead of versions indicated above.


  • @etheling - Good thought. I have not looked at that but I'll check it out (likely this weekend). Thanks for the advice!


  • Big Thank You to @MisterB , @movisman, @johnodon and everyone else on this thread! Info in this thread and MisterBs install script just saved me countless hours of tinkering! I made a mistake of trying RetroPie on PC and now running it on Pi feels like driving my old truck after trying out manual shift roadster! ;-)

    MisterB, some thoughts/comments on your script:

    • I managed to run it once as root using sudo (which doesn't work very well :) ). So I added below to the beginning of the script (there's probably better ways to do this...):
    # test if we were invoked using sudo, and that we're not logged in as root (Eth)
    if [ -z "$USER" ]; then
        echo "Aborting. Please use sudo: sudo $0"
        exit 1
    fi
    if [[ "$USER" == root ]]; then
        echo "Aborting. Don't Be Root. Run as normal user using sudo."
        exit 1
    fi
    
    • RetroPie 4.6 stock install on RaspberryPi install 'triggerhappy' daemon by default (and I am using it in my setup). I added it to RETROPIE_DEPENDS:
    # Minimal depedencies to install RetroPie on Ubuntu                                                                                                              
    RETROPIE_DEPENDS=(
        xorg openbox pulseaudio alsa-utils menu libglib2.0-bin python-xdg
        at-spi2-core libglib2.0-bin dbus-x11 git dialog unzip xmlstarlet joystick                                                                                                                                         
        triggerhappy
    )
    
    • I have script that makes variety of post-install customizations to retroarch and es config files that I've used for rPi. To launch it from your script I added following function before repair_permissions(). This allows me to drop $POST_INSTALL_SCRIPT to same dir with your script and it gets executed as part of the install (if found).
    POST_INSTALL_SCRIPT="retropie_ubuntu_post_install.sh"
    ## .... 
    # Custom post-install modifications (Eth)
    function post_install_custom_mods() {
        if [ -f $SCRIPT_DIR/$POST_INSTALL_SCRIPT ] ; then
            echo "--------------------------------------------------------------------------------"
            echo "| Found $SCRIPT_DIR/$POST_INSTALL_SCRIPT"
            echo "| Executing custom post install script"
            echo "--------------------------------------------------------------------------------"
            chmod +x $SCRIPT_DIR/$POST_INSTALL_SCRIPT ; # just in case we forgot to set +x
            $SCRIPT_DIR/$POST_INSTALL_SCRIPT
            if [ ! $? -eq 0 ]; then
                echo "-> WARNING: $POST_INSTALL_SCRIPT exited with errors. Please review logs."
            fi      
        else
            echo "--------------------------------------------------------------------------------"
            echo "| Skipping custom post install modifications. Custom post installs script"
            echo "| $SCRIPT_DIR/$POST_INSTALL_SCRIPT was not found."
            echo "--------------------------------------------------------------------------------" 
        fi
    }
    
    • Ubuntu 20.04LTS complains about 'dbus-launch gsettings set org.gnome.Terminal.Legacy.Profile:/org/gnome/terminal/legacy/profiles:/:b1dcc9dd-5262-4d8d-a863-c897e6d979b9/default-show-menubar false' line in .bash_profile (and it doesn't work). Replaced it with below, and now menu bar gets hidden:
    gsettings set org.gnome.Terminal.Legacy.Settings default-show-menubar false
    
    • In my setup if I check $HOME/.xsession-errors there are some errors and probably unneeded stuff loaded by openbox (default load):
    $ cat .xsession-errors
    ....
    ** Message: 08:07:50.313: xdg-autostart.vala:39: Processing /etc/xdg/autostart/org.gnome.SettingsDaemon.PrintNotifications.desktop file.
    ** Message: 08:07:50.313: xdg-autostart.vala:64: Not found in OnlyShowIn list, aborting.
    ...
    

    Thus, I added this to your script at the end of 'autostart_openbox_apps()' to clean this part up a bit (might be cleaner to just rename everything in /etc/xdg/autostart, but it may need pulseaudio at least):

    edit: what is needed from below is still WIP

    ## get rid of warnings in ~/.xsession-errors (Eth)                                                                                                           
        mkdir -p $USER_HOME/.config/autostart
        mv -v /etc/xdg/autostart/org.gnome.SettingsDaemon.Sound.desktop /etc/xdg/autostart/org.gnome.SettingsDaemon.Sound.desktop.skip
        mv -v /etc/xdg/autostart/org.gnome.SettingsDaemon.Wacom.desktop /etc/xdg/autostart/org.gnome.SettingsDaemon.Wacom.desktop.skip
        mv -v /etc/xdg/autostart/gnome-keyring-secrets.desktop /etc/xdg/autostart/gnome-keyring-secrets.desktop.skip
        mv -v /etc/xdg/autostart/gnome-keyring-pkcs11.desktop /etc/xdg/autostart/gnome-keyring-pkcs11.desktop.skip
        mv -v /etc/xdg/autostart/org.gnome.Evolution-alarm-notify.desktop /etc/xdg/autostart/org.gnome.Evolution-alarm-notify.desktop.skip
        mv -v /etc/xdg/autostart/org.gnome.SettingsDaemon.MediaKeys.desktop /etc/xdg/autostart/org.gnome.SettingsDaemon.MediaKeys.desktop.skip
        mv -v /etc/xdg/autostart/org.gnome.SettingsDaemon.Wwan.desktop /etc/xdg/autostart/org.gnome.SettingsDaemon.Wwan.desktop.skip
        mv -v /etc/xdg/autostart/org.gnome.SettingsDaemon.ScreensaverProxy.desktop /etc/xdg/autostart/org.gnome.SettingsDaemon.ScreensaverProxy.desktop.skip
        mv -v /etc/xdg/autostart/org.gnome.SettingsDaemon.A11ySettings.desktop /etc/xdg/autostart/org.gnome.SettingsDaemon.A11ySettings.desktop.skip
        mv -v /etc/xdg/autostart/org.gnome.SettingsDaemon.UsbProtection.desktop /etc/xdg/autostart/org.gnome.SettingsDaemon.UsbProtection.desktop.skip
        mv -v /etc/xdg/autostart/org.gnome.SettingsDaemon.Smartcard.desktop /etc/xdg/autostart/org.gnome.SettingsDaemon.Smartcard.desktop.skip
        mv -v /etc/xdg/autostart/org.gnome.SettingsDaemon.Housekeeping.desktop /etc/xdg/autostart/org.gnome.SettingsDaemon.Housekeeping.desktop.skip
        mv -v /etc/xdg/autostart/org.gnome.SettingsDaemon.Power.desktop /etc/xdg/autostart/org.gnome.SettingsDaemon.Power.desktop.skip
        mv -v /etc/xdg/autostart/org.gnome.SettingsDaemon.Rfkill.desktop /etc/xdg/autostart/org.gnome.SettingsDaemon.Rfkill.desktop.skip
        mv -v /etc/xdg/autostart/org.gnome.SettingsDaemon.Datetime.desktop /etc/xdg/autostart/org.gnome.SettingsDaemon.Datetime.desktop.skip
    ## edit: this is needed (or otherwise gsettings won't work)    
    ## mv -v /etc/xdg/autostart/org.gnome.SettingsDaemon.XSettings.desktop /etc/xdg/autostart/org.gnome.SettingsDaemon.XSettings.desktop.skip
        mv -v /etc/xdg/autostart/org.gnome.SettingsDaemon.Keyboard.desktop /etc/xdg/autostart/org.gnome.SettingsDaemon.Keyboard.desktop.skip
        mv -v /etc/xdg/autostart/gnome-keyring-ssh.desktop /etc/xdg/autostart/gnome-keyring-ssh.desktop.skip
        mv -v /etc/xdg/autostart/org.gnome.SettingsDaemon.Sharing.desktop /etc/xdg/autostart/org.gnome.SettingsDaemon.Sharing.desktop.skip
        mv -v /etc/xdg/autostart/org.gnome.SettingsDaemon.PrintNotifications.desktop /etc/xdg/autostart/org.gnome.SettingsDaemon.PrintNotifications.desktop.skip
        mv -v /etc/xdg/autostart/org.gnome.SettingsDaemon.Color.desktop /etc/xdg/autostart/org.gnome.SettingsDaemon.Color.desktop.skip
        mv -v /etc/xdg/autostart/at-spi-dbus-bus.desktop /etc/xdg/autostart/at-spi-dbus-bus.desktop.skip
        mv -v /etc/xdg/autostart/gnome-shell-overrides-migration.desktop /etc/xdg/autostart/gnome-shell-overrides-migration.desktop.skip
        mv -v /etc/xdg/autostart/nm-applet.desktop /etc/xdg/autostart/nm-applet.desktop.skip
        ## pulseaudio.desktop ; # lets keep this for now                                                                                                             
        mv -v /etc/xdg/autostart/xdg-user-dirs.desktop /etc/xdg/autostart/xdg-user-dirs.desktop.skip
        mv -v /etc/xdg/autostart/geoclue-demo-agent.desktop /etc/xdg/autostart/geoclue-demo-agent.desktop.skip
        mv -v /etc/xdg/autostart/im-launch.desktop /etc/xdg/autostart/im-launch.desktop.skip
        mv -v /etc/xdg/autostart/print-applet.desktop /etc/xdg/autostart/print-applet.desktop.skip
        mv -v /etc/xdg/autostart/snap-userd-autostart.desktop /etc/xdg/autostart/snap-userd-autostart.desktop.skip
    
    • As to see how long the install takes I added below to the script (after logging to file starts and before complete_instalI:
    echo "*** Installation started `date` ***"
    ### ...
    echo "*** Installation finished `date` ***"
    

    Then some possibly not so smart things that I did try out:

    • Disable Spectre, Meltdown, etc. mitigations in kernel:
    # Danger, Ethelin, Danger..                                                                                                                                         
    function disable_cpu_mitigations() {
        echo "+-------------------------------------------------------------------------------"
        echo "| Disable Spectre/Meltdown/.. kernel mitigations"
        echo "+-------------------------------------------------------------------------------"
        ##backupFile /etc/default/grub
        sed -i 's/GRUB_CMDLINE_LINUX_DEFAULT=\"/&mitigations=off /' /etc/default/grub
        update-grub
        echo -e "Done\n\n"
        sleep 4
    }
    

    Based on GeekBench this gives ~5% (or less) perf boost on CPU on the NUC. And likely less in reality. But since this will be effectively single user box, with no browser to run bad js, seems like a risk I'm willing to take. GeekBench results before disabling mitigations, and after disabling them.

    • I installed preload package. Probably end up giving close to zero positive impact on performance. But I've got RAM so maybe I get microsecond shorter load somewhere,...

    • It looks like you could do away without pulseaudio and just install alsa-base. But that requires manual change to /opt/retroarch/configs/all/retroarch.cfg to set alsa as audio backend. So probably not worth it.

    • Installing X and OpenBox brings in some services that are probably not needed. I disabled these for my setup (of course if you use BT controller, or want to run samba share, then don't disable them). And disabling apparmor may very well come to bite me too:

    DISABLE_SERVICES=(
       apparmor
        avahi-daemon.service
        bluetooth.service
        nmbd.service
        smbd.service
        ModemManager.service
    )
    # Disable services                                                                                                                                               
    function disable_system_services() {
        echo "+-------------------------------------------------------------------------------"
        echo "| Disable OS services..."
        echo "+-------------------------------------------------------------------------------"
        systemctl disable ${DISABLE_SERVICES[@]}
        echo -e "Done\n\n"
        sleep 4
    }
    
    • disable snap (just because I can, can't see any benefit either):
    # get rid of snapd                                                                                                                                               
    function eradicate_snapd () {
        echo "+-------------------------------------------------------------------------------"
        echo "| Removing snapd (OS purge will also purge snapd)..."
        echo "+-------------------------------------------------------------------------------"
        snap list
        snap remove lxd
        snap remove core18
        snap remove snapd
        ## TODO: maybe rm -rf /snapd                                                                                                                                 
    }
    

    Some random notes:

    • Ubuntu 20.04.1 LTS Server default install doesn't come complete with wpa_supplicant (?!?!) so running misterBs script in wireless only environment requires installing it from debs first (libpcsclite1, libnl-route-3-200, wpasupplicant).

  • To make X mouse cursor 'completely' invisible (and as an alternative to using unclutter) I put together [gnome] cursor theme that sets all mouse pointers to 1x1 pixel red dot (was black), and added it to install script:

    # Make X cursor 1x1 black dot                                                                                                                                    
    function xcursor-to-dot() {
        echo " "
        echo "+-------------------------------------------------------------------------------"
        echo "| Turn X mouse pointer into 1x1 pixel black dot to hide it 'completely'"
        echo "+-------------------------------------------------------------------------------"
        git clone https://github.com/etheling/dot1x1-gnome-cursor-theme
        sudo tar zxf dot1x1-gnome-cursor-theme/dot1x1-cursor-theme.tar.gz -C /usr/share/icons
        sudo cp /usr/share/icons/default/index.theme /usr/share/icons/default/index.theme.orig
        sudo cp dot1x1-gnome-cursor-theme/index.theme /usr/share/icons/default/index.theme
        echo -e "Done\n\n"
    }
    

  • Excellent contributions @etheling!

    Have you considered forking MisterB's github repo and incorporating your changes/additions? I fear that he has moved on and updates to his repo may become stagnant.

    John


  • Still here... :). Just not so active around here during the summer months and didn't realize there were updates to this thread.

    First off, many thanks for the additional feedback and code snippets. I'm glad to see the continued interest in this and appreciate the extra help.

    I do intend to continue maintaining the repo - I have a few other projects currently taking my time, but expect a new RetroPie build to be one of my fall projects. This script is a key component, the other is updating my post-install script, which aims to apply my personal customizations and configurations consistently across X86 and RPi builds. So @etheling 's hook is a great idea!

    Adding these changes is pretty easy, but the challenge going forward is finding the dividing line between "solid installation base" and "personal configuration/tweaks". There is an ever-growing list of functions available to call, and some are more optional than required. I need to consider an approach that allows people to opt in/out of certain settings while keeping things simple and consistent, which were my original goals. A config file or simple dialog logic might be options, need to think more about it. Feedback welcome.


  • I'm glad to see the continued interest

    Very much so! :) And if I may, I really like how you wrote the script style-wise too.

    challenge going forward is finding the dividing line between "solid installation base" and "personal configuration/tweaks".

    My thinking is that 'main' setup script should probably produce a stable configuration that to a reasonable extent mimics what you get when you install RetroPie using stock image on RPi. Then more experimental / controversial / unstable modifications and e.g. build specific customizations for e.g. Arduino tools could be done from another script after the main script has executed.

    I'm still working on my post-install customizations, but I'll post my script in a week (or two or three) as one example of what can be done.

    simple dialog logic might be options

    Not my call of course, but I hope that I could run the whole install process 'unattened' without a need to interact with the script once it has launched.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.