Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Diablo II (and other games) on RetroPie!



  • While it does work better on OpenGL I only found sound issues with the music on the retropie side. Gameplay is unaffected.



  • Just a little public service annoucement getting Diablo to run with no CD:

    Diablo II no CD instructions

    "If all required Diablo 2 '.MPQ' files are installed on the
    hard drive, the game will no longer require the CD to play.

    For users that originally performed a 'Full Installation' 
    and wish to run without the CD, all '.MPQ' files should 
    be copied from the Diablo 2 CDs to the Diablo 2 directory. 
    Most users will only need to copy D2Music.mpq from the 
    Diablo 2 Play CD and/or D2xMusic.mpq from the Lord of 
    Destruction CD. Mac users will need to copy these music 
    files and rename them to 'Diablo II Music' and 
    'Diablo II Expansion Music' respectively.

    Anyone who did not perform a 'Full Installation' will need
    to re-install from CD again to ultimately play without the CD. 
    In this case, a 'Full Installation' is required, followed by file 
    copy step noted above."

    @Crash Thank you. Got everything up and running following your video. Works pretty good on my Pi3B.



  • Can this be done without the PIXEL package? I want to know before I spend hours watching the video and trying to achieve the same result.


  • Global Moderator

    @spiky I don't think it runs without X.org, since it uses Wine.



  • It's really cool, congrats for this great job. Seeing this made me curious, can Age of Empires get a port to Retropie too?



  • All I have done was bring attention to their hard over here on RetroPie forums, but yes I do believe we will be seeing Age of Empires as well as other games from that era. They laid out the foundation, which will be expanded & improved upon.



  • I'd really like to see Spelunky Classic running on RetroPie. Unfortunately, I'm too dumb to get it running myself...



  • @jandalf81 said in Diablo II (and other games) on RetroPie!:

    n

    They offer the source code right on their site, so it shouldn't be too difficult for someone with the skills to port it to retropie. Possibly @zerojay could point you in the right direction for your request. (As well as get your Savestate selector script added to Retropie-Extra scripts)



  • I finally can get rid of Stratagus - even though I never played it for lack of campaign and replaced it with official Starcraft with Brood wars expansion!
    The only thing is I can't get it full screen, but I did get it windowed with just a blank border. I believe I could use your trick for diablo, but it would mean lowering resolution to 640 x 480.

    @Crash Since I already used your guide to get Diablo 2 up & running, it was simple using the same wine deb and compiled exe by Salvador. It plays great. I didn't notice any issues.

    Any more games in the works? I saw your andriod video of Morrrowind. May I suggest Postal?



  • Instead of dual booting, is there a way to expand the raspbian lite to full raspbian and use openGL?


  • Global Moderator

    @cybrasty said in Diablo II (and other games) on RetroPie!:

    Instead of dual booting, is there a way to expand the raspbian lite to full raspbian and use openGL?

    Not really, RetroPie will not work correctly when you enable the openGL driver.



  • @mitu Well I think you can disable the OpenGL by editing /boot/config and then reboot, so a "dual" boot is possible with just one OS ;) But I think I would simple boot to annother partition to have the best of both worlds ;)



  • So changing the driver would require a reboot?
    Can't I just enable the driver from console, go to Pixel, play diablo II. Then after I am done kill Pixel, go back to console, disable openGL, run emulationstation again?


  • Global Moderator

    @cybrasty said in Diablo II (and other games) on RetroPie!:

    So changing the driver would require a reboot?

    Yes, it needs a reboot.



  • @mitu Thanks, yeah, then having a dual boot seems the best way of doing it. Thanks!



  • Using @Crash 's guide, I got it running using legacy drivers.
    He convinced me that was the way to go. Minimal sound stutter in Diablo II when many characters on screen but no issues with gameplay. Starcraft works perfect so far. (I'm also using a 3b, so the plus may eliminate that)



  • Hi folks. I'm making accounts and pointing things out that I notice when they come up in relation to this. This development has me excited for more developments of its kind, so I figure it's time to pony up some data.

    I was running the image from crash gaming on a usb stick in a pi 3 (not plus, i don't think). I personally noticed hangs in certain spots, but each one was related to reading data, specifically a new enemy or item appearing in the game at that moment. I've never read up on how cache works with d2, but I'd imagine that's a big part of what's going on there. Aside from that, butter smooth. Anything from d2 takes me way back. I'm going to go digging through archives and see if I can find an old mpq mod I had working with this, multi"pi" servers... I'm geeked over this.

    After all that, I'm going to take a stab at a few more games around the directx 7 era and see what happens, maybe move from there in one direction or another, and definitely move into a real usb hdd instead of sd or usb flash, see if we can't get that data moving any faster and see if that actually helps. Might also try OpenGL specific games of that era on the newer driver and see what that does. TONS of stuffs to get to doing.

    Have fun. That was always the point.

    -Wiz



  • PLZ HELP
    i trying now for days...
    Adding pixel desktop & diablo II...
    cant get it work !
    So 2 problems
    1-
    for some reason Every Time i try to get install the pixel Desktop
    Im getting this -

    so from there nothing really working , not the wine_1.7.3.2-1_armhf.deb or anything like that....
    2-
    When i put kernel3g1g.img
    at the end of the boot file ,
    its get stuck on the WELCOME screen and nothing i can do , but it works throw the LAN or putty ...

    OMG ! Thanks for answers ... PLZ answer.... <3 <3 <3



  • someone ???



  • Start by watching crashes video again and make sure you didn't miss anything. Make sure your using crashe's wine files. They are different from Salvador's. Double check the kernal file is in correct location, and your accessing pixel desktop from terminal with root privileges. Wine will not work without the new kernel, so it makes sense it you have what error. So seems like your main problem has to do with loading the kernel.

    I don't understand what you were trying to show with the vifeo you linked.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.