Please do not post a support request without first reading and following the advice in

Diablo II (and other games) on RetroPie!

  • Global Moderator

    @cybrasty said in Diablo II (and other games) on RetroPie!:

    Instead of dual booting, is there a way to expand the raspbian lite to full raspbian and use openGL?

    Not really, RetroPie will not work correctly when you enable the openGL driver.

  • @mitu Well I think you can disable the OpenGL by editing /boot/config and then reboot, so a "dual" boot is possible with just one OS ;) But I think I would simple boot to annother partition to have the best of both worlds ;)

  • So changing the driver would require a reboot?
    Can't I just enable the driver from console, go to Pixel, play diablo II. Then after I am done kill Pixel, go back to console, disable openGL, run emulationstation again?

  • Global Moderator

    @cybrasty said in Diablo II (and other games) on RetroPie!:

    So changing the driver would require a reboot?

    Yes, it needs a reboot.

  • @mitu Thanks, yeah, then having a dual boot seems the best way of doing it. Thanks!

  • Using @Crash 's guide, I got it running using legacy drivers.
    He convinced me that was the way to go. Minimal sound stutter in Diablo II when many characters on screen but no issues with gameplay. Starcraft works perfect so far. (I'm also using a 3b, so the plus may eliminate that)

  • Hi folks. I'm making accounts and pointing things out that I notice when they come up in relation to this. This development has me excited for more developments of its kind, so I figure it's time to pony up some data.

    I was running the image from crash gaming on a usb stick in a pi 3 (not plus, i don't think). I personally noticed hangs in certain spots, but each one was related to reading data, specifically a new enemy or item appearing in the game at that moment. I've never read up on how cache works with d2, but I'd imagine that's a big part of what's going on there. Aside from that, butter smooth. Anything from d2 takes me way back. I'm going to go digging through archives and see if I can find an old mpq mod I had working with this, multi"pi" servers... I'm geeked over this.

    After all that, I'm going to take a stab at a few more games around the directx 7 era and see what happens, maybe move from there in one direction or another, and definitely move into a real usb hdd instead of sd or usb flash, see if we can't get that data moving any faster and see if that actually helps. Might also try OpenGL specific games of that era on the newer driver and see what that does. TONS of stuffs to get to doing.

    Have fun. That was always the point.


    i trying now for days...
    Adding pixel desktop & diablo II...
    cant get it work !
    So 2 problems
    for some reason Every Time i try to get install the pixel Desktop
    Im getting this -

    so from there nothing really working , not the wine_1.7.3.2-1_armhf.deb or anything like that....
    When i put kernel3g1g.img
    at the end of the boot file ,
    its get stuck on the WELCOME screen and nothing i can do , but it works throw the LAN or putty ...

    OMG ! Thanks for answers ... PLZ answer.... <3 <3 <3

  • someone ???

  • Start by watching crashes video again and make sure you didn't miss anything. Make sure your using crashe's wine files. They are different from Salvador's. Double check the kernal file is in correct location, and your accessing pixel desktop from terminal with root privileges. Wine will not work without the new kernel, so it makes sense it you have what error. So seems like your main problem has to do with loading the kernel.

    I don't understand what you were trying to show with the vifeo you linked.

  • @bizzar721
    thanks ,
    the boot is fixed !
    with the kernel in the right folders.
    so me LXDE desktop is ok ?
    is it the same as ?? pixel desktop ??? going crazy
    cause im trying to get the right desktop i thought that was the mistake,
    cause i have a different desktop.

    if so how do i use the righ wine.deb i did step by step like u said, more then once...

    thanks again .

  • this is what i get everytime -

  • @shavecat LXDE and pixel are one in the same as far as I know. I believe it was just a name change. I wish I could help more, but I did more following directions than I did fully knowing WHY those commands worked. I am not too much help in troubleshooting.

    Most likely something was missed or typed incorrectly. I had the instructions file open so I could copy and paste commands verbatim. All commands are case sensitive. Don't forget to reboot when needed, and access pixel with root privileges. Make sure it's running outside of emulation station first to limit things that can go wrong. In the end you must change emulators.cfg and add sudo (it's in instructional video) to get it to work properly from ES.

    Good luck.

  • @bizzar721
    Thanks a lot ,
    i will try.

  • 0_1539268636675_b6acf258-3bbb-44f7-858a-fd6f38f5546d-image.png @bizzar721 said in [Diablo II (and other games) on RetroPie!]

    i always get this, and wine version check.

  • @bizzar721
    was the mistake on the config.txt
    thanks so much !!!

  • So i fix everything now its working
    Until i click the Diablo
    then its loading Default wine desktop
    and exit....

    any ideas ? Tx

  • Really interesting information, thanks a lot :)

  • @shavecat Your almost there. Did you change the permissions as crash describes? How about making sure that the piablo folder is in the correct location? Since wine starts, I would lean more towards the file location not being correct.

  • @BiZzAr721
    Tried almost anything , even had help.
    but didnt workout :
    the wine working looks like it .
    but its saying Bad exe .

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.