Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Retropie issues with WiFi setup and Scraper



  • I have been trying to install my WiFi connection on my retropie. I haven't been able to find the version number but the version number of the setup script is 4.4.20. I have it installed on a raspberry pi model b+. When i try to go into the WiFi from emulation station, I get a screen with the following message "You don"t currently have your WiFi country set in /etc/wpa_supplicant/wpa_supplicant.conf

    On a Raspberry Pi 3 Model B+ your WiFi will be disabled until the country is set. You can do this via raspi-config which is available from the RetroPie menu in Emulation Station. Once in raspi-config you can set your country via menu 4 (Localisation Options)

    Do you want me to launch raspi-config for you now?

    When i go into this menu option the only one which i felt confident in changing was the time zone option but this is already set to the option of Australia - Melbourne. I have then connected to my WiFi network and it shows that I am connected to it. I have tried using the scraper program to find game art from THEGAMESDB as I can't select any other option but it doesn't find any of my games, despite them being on the site which I have found through manual searching the site. I am not sure how to fix this. I have seen other videos whichbsay how to do it manually but it is quite a lengthy process. If people can help me I would appreciate it greatly.


  • Global Moderator

    If your WiFi is working (which looks like it is), then update the RetroPie packages - especially Emulationstation. Re-try scraping after the update - the Emulationstation version should be at least 2.7.6.



  • @mitu In order to do this, do I just update the setup script and then what do I do to update the emulation station?


  • Global Moderator

    @melbmatt50 https://retropie.org.uk/docs/Updating-RetroPie/ - just update all installed packages, it will also update the RetroPie-Setup script itself.



  • @mitu I did that and the scraper seems to be working as it found artwork for the majority of games. there are two issues I need to fix though. Now during startup it asks for a login and password which I would rather it didn't so I want to disable that. Secondly I got a 64gb sd card so I could load more stuff on it but etcher won't verify it after burning the image to it and I get the following message during installation on my raspberry pi 3 model b+ Kernel panic-not syncing: VFS: unable to mount root fs on unknown-block(179,2). If you can help me I would be grateful. Its a sandisk ultra 64gb class 10 card.


  • Global Moderator

    @melbmatt50 said in Retropie issues with WiFi setup and Scraper:

    Now during startup it asks for a login and password which I would rather it didn't so I want to disable that.

    It's enough to login once - after the upgrade - and re-configure auto-login using sudo raspi-config. Unfortunately that's part of Raspbian and it's not under RetroPie's control. See this topic for solutions to this problem.

    Secondly I got a 64gb sd card so I could load more stuff on it but etcher won't verify it after burning the image to it and I get the following message during installation on my raspberry pi 3 model b+ Kernel panic-not syncing: VFS: unable to mount root fs on unknown-block(179,2). If you can help me I would be grateful. Its a sandisk ultra 64gb class 10 card.

    The error seems to indicate badly/imcomplete written image. If the verification doesn't work, maybe the SD card is faulty ?



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.