Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

mapping different controllers for C64 emulator VICE



  • I have a Logitech F310 usb wired controller and following

    i managed to map and use it, but then i got a second one, a EasySMX usb wired which i plugged into the raspberry but it does not work, the control are really messed up i cannot even acess VICE internal menu to map it. I though the joy map confi i created (i mapped only joy 1) would be used by the emulator also for the second. Any suggestion, please?



  • @niculinux VICE stores settings for each type of controller separately so you will probably need to configure your EasySMX controller in VICE as you did for your Logitech controller.

    Once you have saved your setttings in VICE, your config will be saved in sdl-joymap-C64.vjm which you can find in /opt/retropie/configs/c64 . You can check there whether your controllers have been mapped. There should be two entries, one for your Logitech controller, one for the EasySMX.



  • @dudleydes said in mapping differentcontrollers for C64 emulator VICE:

    @niculinux VICE stores settings for each type of controller separately so you will probably need to configure your EasySMX controller in VICE as you did for your Logitech controller.

    taht is my worst fear since its bindings are messed up i cannot even activate a single menu entry with it, i barely manage to open up VICE main menu, so i suppose i'd have to go by manual setting. If i copy Logitech file setting and rename it that would do the trick? Or there are some more ways?



  • @niculinux Is your EasySMX controller being detected by your Pi? Can you configure it in ES?

    If not, then run the following command ls /dev/input/by-id/ and you should see your controller listed.



  • @dudleydes said in mapping differentcontrollers for C64 emulator VICE:

    @niculinux Is your EasySMX controller being detected by your Pi? Can you configure it in ES?

    Yes, it is detected, but i have trouble setting the right trigger; once i got in the "configure input" menu and try to set it retropie skips it and reports it as "not assigned". But in the vice menu it is almost impossible to use :,(



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.