Please do not post a support request without first reading and following the advice in

Trouble Downloading the Image

  • I'm not sure if this is a problem on my end or not. I can download other things but I've tried several times to download the image from the Retropie download page and it keeps failing (after about 20-30 mb downloaded) with a network error then I try to resume it and it says "failed - forbidden" in my downloads tab. I've tried restarting both my modem and router. Has anybody else experienced this today? Do I need to sit on hold with my internet provider? Should I just poke it with a stick?

    I'm using the Chrome browser with Windows 7 Pro.

    I've also tried from the github page and through another browser with no success.

    And I just tried another attempt with my fingers crossed.

  • It's also failed from Chrono Download manager...

  • Well it finally worked after trying all day long. Anybody have any ideas what the hell was going on?

Log in to reply

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.