Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

NeoGeo game


  • Banned

    Hi all,

    Suddenly, my NeoGeo games do not work anymore. My configuration is ES 2.8.0. Ok, may be, it is an ES problem. I understand. My Mame and FBA game work perfectly.

    Before downgraded ES, I would like to know what is the pb.

    When I launch a NeoGeo game, the little yellow text does not appear and the menu is back.
    I have seen into the es_log.txt file, and here is the text:

    lvl2:   Attempting to launch game...
    lvl2:           /opt/retropie/supplementary/runcommand/runcommand.sh 0 _SYS_ neogeo /home/pi/RetroPie/roms/neogeo/mslug.zip
    lvl2:   Creating surface...
    lvl2:   Created window successfully.
    lvl2:   Added known joystick Xin-Mo Xin-Mo Controller (instance ID: 0, device index: 0)
    lvl2:   Added known joystick Xin-Mo Xin-Mo Controller (instance ID: 0, device index: 0)
    

    Is it possible to have more log messages ? to be in lvl3 or more for instance ?

    Thanks for your help.
    Joe.


  • Global Moderator

    @joecool Emulationstation is not the emulator for the game, it's just the front-end launching the emulator. If you want to get a more detailed log for the emulator, enable verbose logging in the Runcommand launch menu and then look in the log file - /dev/shm/runcommand.log - to see if you spot the error.
    Also, please include as much information possible from the info requested in https://retropie.org.uk/forum/topic/3/read-this-first.


  • Banned

    Thanks very much for these information. I'm going to see that. I'll tell you what's going on...


  • Banned

    In verbose mode, here are my errors:
    [libretro INFO] [FBA] Archive: neocdz
    [libretro ERROR] [FBA] Failed to find archive: /home/pi/RetroPie/BIOS/neocdz, let's continue with other archives...
    [libretro INFO] [FBA] Archive: neogeo
    [libretro ERROR] [FBA] Failed to find archive: /home/pi/RetroPie/BIOS/neocdz, let's continue with other archives...
    [libretro INFO] [FBA] Using ROM with good CRC and name 000-lo.lo from archive /home/pi/RetroPie/BIOS/neogeo
    [libretro WARN] [FBA] NeoGeo BIOS missing ...
    [libretro ERROR] [FBA] ROM at index 0 with CRC 0xdf9de490 is required ...
    [libretro ERROR] [FBA] Can't launch this game, some files are missing.
    [ERROR] Failed to load content.
    [INFO] Saved core options file to "/opt/retropie/configs/all/retroarch-core-options.cfg"
    [ERROR] This core requires a content file, could not load content.

    I'm going to check that. The /home/pi/RetroPie/BIOS/neocdz file is the Neogeo BIOS, right ?
    Why is it missing ? Strange...



  • Delete


  • Global Moderator

    @joecool You're trying to launch a Neogoe CD game and you're missing the BIOS file required - neocdz. Are you sure you didn't accidentally changed the Neogeo system's emulator from the default one to lr-fbalpha-neocd ?


  • Banned

    @all. I try to launch Metal Slug. I don't understand why it tries to find this neocdz.zip bios. I have the neogeo.zip file here.


  • Global Moderator

    @joecool Please post the whole log file over at pastebin.com so we can also take a look and see my previous message - check your Runcommand launch menu and see which emulator is used to launch the game.


  • Banned

    @mitu said in NeoGeo game:
    Are you sure you didn't accidentally changed the Neogeo system's emulator from the default one to lr-fbalpha-neocd ?

    This is possible but how to change that ?


  • Global Moderator


  • Banned

    Yes, yes, yes, you're right. There was another emulator by default (lr-fbalpha-neocd). My machine was installed in a public place but in Kid mode with zero tech menu and the runcommand disabled.

    How is it possible for somebody to change this emulator default ?


  • Global Moderator

    @joecool said in NeoGeo game:

    How is it possible for somebody to change this emulator default ?

    Magic ? What do you mean by "public place" ?


  • Banned

    In a cafe. But I think I undestrand what happend. The button 0 is the A button, so somebody selected a game by clicking on the A button many time (don't know why). The runcommand was launched and the other emulator was selected.

    I have to disabled the runcommand menu to avoid that.

    Thanks for your lights, sincerelly ^^ !


  • Global Moderator

    @joecool said in NeoGeo game:

    In a cafe

    The RetroPie license does not allow commercial usage or distribution - https://retropie.org.uk/about/legal/. By using it in a commercial place, you're in breach of this license, not mentioning probably the copyright violation for the ROMs you included in the image.


  • Banned

    Yes, I know, it was just for a test. To try it in a complex environment.


  • Global Moderator

    Such a poor excuse for breaking the rules. There's no support for scammers here.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.