Please do not post a support request without first reading and following the advice in

[Testing] Kodi 18.0 Leia beta versions now available for RetroPie!

  • This post is deleted!

  • administrators

    Gave beta 4 a quick test on my rpi2. Not reporting this to you directly as likely an upstream issue but using the default Estuary there is no working video controls during playback. The screen just dims and no controls can be seen. Video controls worked ok in Confluence though. Wondering if anyone else noticed this behaviour.

    RPi2 with Linux 4.14.71-v7+ on Raspbian Stretch

    Got Netflix installed and working though :)

  • @BuZz This controls ?
    alt text
    Works fine here.
    A Kodi debug log may help to see your problem.

  • administrators

    @Rascas yeah. I'll do some testing with debug level logging

  • Thank you for this, I can confirm it works and now there is no need to switch sd cards to watch netflix, finally :D

  • I installed Kodi V18 and finnaly i can see Amazon video and Netflix in my retropie. I have a problem with the on screen controlls, I see them has gigant, I see just a small zoomed part of the backward button that takes all the screen, and when I go back to kodi all still big. I have to kill the process to go back to retropie.
    All started when I shut on the remote controll option, but if I disable again, the problem persist. Any idea?
    And one thing more, yesterday was released the Beta 5, Any way to update? there is any repository?

  • @DeathWalk well, that is strange. Can you post a screenshot or a photo of the problem? A debug log will also help. About a new version, we will release another one when we see fit. I don't think your problem is bug but some kind of problem in your configuration, only more info and a log will tell.

  • Hello and thank you for the quick response,
    Here there are the log file:
    Sometimes I can see the big button anothers just the dark overlay that appear when the screen controls are activated. I have a capture with the dark tone of the onscreen control and one photo that I took yesterday with the cam before use a screenshot software.![alt text](0_1541445060526_0.jpg image url) ![alt text](0_1541445077474_snapshot.png image url)
    I hoppe you can help me I'm close to have my retropie perfect :)

  • @DeathWalk We need a debug log with the problem reproduced. Does it happen on local files also or only on Netflix/Amazon content ?

  • Sorry Rasta for not answer earlyer, This days i'm very bussy and i have not to much time, maybe next week i have more time and i can upload the logs, Anyway Thank you for you disposition to help, really. ^^

  • It tells me that I should rather get beta 5. How do I do that?

  • Cool.

    I just bought the DVB-T card for the RPi and my Retropie is currently running tvheadend to offer it out to the network. I haven't yet got around to setting up Kodi to view it "live" on the Pi itself yet but good to know that things are improving all the time.

  • This post is deleted!

  • I get crashes in Kodi 18 whenever I change the regional settings (even if I just go in, change the country, come out). It crashes out of Kodi and the changes are never saved.

    Any idea why that might be (am I missing some internationalisation package for Kodi?).

  • @ledow I don't have this problem with kodi 18 beta 4. Running Raspberry Pi 3b plus..

  • @ledow I cannot reproduce that problem too. Check your kodi log for errors, if you updated from version 17, it can be caused by some incompatible addon. You can try with a clean/default settings, by moving/removing /home/pi/.kodi

  • @Rascas It's a clean install, no previous install ever (never used Kodi on this device/card at all).

    When I change regional settings, it lets me select UK or change the date/time setup to UK but then almost immediately Kodi dies and throws me back to the menu.

    I can change every other option, I can watch TV for hours, do all the normal things, but changing the region just crashes it hard, whether I do it immediately I go into Kodi or if I've been in and out of a thousand menus.

    It did it with zero addons installed, and it does it with the tvHeadEnd HTSP add-on installed.

    I'll try to recover some logs or similar next time I do it, just wondered if it was only me.

  • Well then post your kodi log with debug enabled, and I would also check /var/log/syslog for errors like microSD card/disk errors.

  • Hi,
    i don't know what to do.
    i don't get the netflix addon to run.
    when i try to run it kodi gives me an error message that says to look into the log file.
    looking in the log it seems the problem is that there is no directory for the netflix addon.

    i think the problem is that on installation time the dependency for pycryptodome is not resolved.

    i tried to install the python package pycryptodomex via pip but of course the addon still can not see an equivalent pycryptodome kodi addon/package.

    i run everything on an raspberry pi 3b

    What am i doing wrong?
    how did you get the netflix addon to run on retropie?
    do i need an additional repo?

  • @wursti90 If anybody has trouble getting Netflix working, you have to do 'pip install pycryptodomex' in a terminal, not as root or with sudo or it won't work. Then just install the netflix addon from here

Log in to reply

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.