Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

[Testing] Kodi 18.0 Leia beta versions now available for RetroPie!



  • @mitu I try, but installing the EmulationStatio binary fails S:



  • I try some times, update from binary... no works... but after reboot EmulationStation is back :D

    Thanks



  • Kodi 18 RC 1 available for update

    Changelog:
    -https://kodi.tv/article/kodi-v18-leia-rc1-new-hope

    Raspbian/RetroPie specific:
    -Added various missing binary addons like pvr.zattoo, pvr.teleboy, vfs-sacd, etc
    -All binary addons updated. Netflix works again if updated.


  • administrators

    Thanks. I have tested the new version. I am still having the issue with the on screen controls with estuary not displaying and the kodi interface breaking.

    I switched on debug logging (which also shows the on screen memory usage etc), and then it worked fine! This is reproducable - switch off debug logging and the on screen menu won't show. The screen just dims - if you stop the video, the kodi interface no longer displays so it seems it's related to GPU somehow.

    There is nothing useful I could see in the non debug log.

    https://paste.ubuntu.com/p/pmKw9RM9ZY/

    Here's the debug log (which may not be of any use since it works when debug log is on)

    https://paste.ubuntu.com/p/pcQwGFQTkF/

    Note this problem doesn't happen using a skin like Confluence.


  • administrators

    I have managed to work around the issue - seems related to "overscan_scale=1" - if I removed that from /boot/config.txt the on screen controls display correctly.

    So either a firmware issue or a compatibility issue with Kodi and this option.



  • @Rascas How can you update to RC1? The first post instructions only get me the v4 beta. Thanks.



  • @cebix said in [Testing] Kodi 18.0 Leia beta versions now available for RetroPie!:

    @Rascas How can you update to RC1? The first post instructions only get me the v4 beta. Thanks.

    In RetroPie-Setup go to Configuration Tools -> Raspbian Tools -> Upgrade Raspbian packages
    Or in terminal do:

    sudo apt-get update
    sudo apt-get dist-upgrade -y


  • @BuZz said in [Testing] Kodi 18.0 Leia beta versions now available for RetroPie!:

    I have managed to work around the issue - seems related to "overscan_scale=1" - if I removed that from /boot/config.txt the on screen controls display correctly.

    So either a firmware issue or a compatibility issue with Kodi and this option.

    That might be it! In all the RPis that I tested I have that line commented, don't remember why. I know what it does theoretically, but I don't need it on my Pis. Can you tell why is it needed in RetroPie ?
    I also took a look at Raspbian and LibreELEC and they do not come with that enabled. Since this probably is not much tested, the newer firmwares might have a bug.


  • administrators

    @Rascas explained here - https://github.com/RetroPie/RetroPie-Setup/wiki/Overscan#the-console-looks-good-but-the-picture-is-off-for-emulationstationretroarchetc

    basically on some screens that require overscan settings, without this ES can render offscreen.

    This is only a problem with Kodi 18 though on the latest firmware. Kodi 17.x is ok.



  • @BuZz I just tested with overscan_scale=1 and I still cannot reproduce de problem. But it can be that in conjunction with something else like yours overscan_bottom=X, etc. Also, do you use some videoplayer at RetroPie boot ? I cannot see any related errors in your Kodi logs...



  • @BuZz Well, I can reproduce it now with overscan_scale=1 and without disable_overscan=1 (I have disable_overscan=1 in all my Pis). So it is most likey a problem/bug with Kodi 18 and overscan scale.
    Correct me if I am wrong, overscan_scale=1 and overscan enabled are the default RetroPie settings right?


  • administrators

    @Rascas yes. Those are the defaults.



  • @BuZz Can you please check this thread ?
    https://forum.kodi.tv/showthread.php?tid=338052



  • Hi all,

    Big fan of Kodi on RetroPie.

    I followed the directions here to upgrade to RC1 (RC2 not dropped yet maybe) and I edited Config.txt to remove the overscan to fix the overlay problems. I also updated to ScreenSaver 5.0.1. Playback works great, but the screensaver now causes a hang and then eventual force out of Kodi. I tried fiddling with the settings, and even attempted to revert back to the version I was using before, but I couldn't get it working so I ended up reverting back to Krypton for now. I'll pick up RC2 later that looks like from here should work with the default overscan settings to see if that fixes it and will report back if that works.


  • Global Moderator

    @BuZz

    Users on the Steam forum also reported black screen issues caused by overscan_scale=1 for the steamlink app, which is why they implemented a block in the scripts.

    Even though I can't reproduce the issue re: the steamlink (and haven't yet tried the kodi rc), perhaps it would be a good idea to move that configuration out of emulationstation and into the raspbiantools script as an optional tunable? I'd be happy to work on that and send a PR if you're interested.



  • @psyke83 The overscan_scale=1 issue is already fixed in the latest firmware (check the kodi forum link above). You have to run sudo rpi-update to get the latest firmware or wait until it reaches the rpi foundation repo and update, it shouldn't take long.



  • One thing that probably should be discussed is if the overscan_scale=1 is really needed, because as popcornmix says, it seems to be a "last resort" thing, as it can degrade image quality (and probably add more processing power to do the scaling).


  • Global Moderator

    @Rascas said in [Testing] Kodi 18.0 Leia beta versions now available for RetroPie!:

    @psyke83 The overscan_scale=1 issue is already fixed in the latest firmware (check the kodi forum link above). You have to run sudo rpi-update to get the latest firmware or wait until it reaches the rpi foundation repo and update, it shouldn't take long.

    Thanks, but I personally don't like using rpi-update due to the way it dumps the firmware libraries into /opt/vc/; for example, in the case of stretch, it installs duplicate libraries that are supposed to be phased out (libGLESv2, libEGL etc.), which can cause compatibility issues.

    Not all tagged firmware releases get packaged for Raspbian, so we may have to wait some time for the fix to arrive (hopefully not).



  • @psyke83 said in [Testing] Kodi 18.0 Leia beta versions now available for RetroPie!:

    Thanks, but I personally don't like using rpi-update due to the way it dumps the firmware libraries into /opt/vc/; for example, in the case of stretch, it installs duplicate libraries that are supposed to be phased out (libGLESv2, libEGL etc.), which can cause compatibility issues.

    Well I think this does not happen anymore, that happened only in the time that RPi Foundation decided to rename the libraries due the open source graphics driver getting more popular, and there was some mistakes and, of course, everything that depended on them had to be fixed/changed.

    But yes, rpi-update should only be used for testing purposes in my opinion, it gets the bleeding-edge kernel and firmware. And again, this fix shouldn't take long to reach the repos.



  • @psyke83 said in [Testing] Kodi 18.0 Leia beta versions now available for RetroPie!:

    @BuZz

    Users on the Steam forum also reported black screen issues caused by overscan_scale=1 for the steamlink app, which is why they implemented a block in the scripts.

    Even though I can't reproduce the issue re: the steamlink (and haven't yet tried the kodi rc), perhaps it would be a good idea to move that configuration out of emulationstation and into the raspbiantools script as an optional tunable? I'd be happy to work on that and send a PR if you're interested.

    That is very tempting, I also have thought of not forcing such an option in EmulationStation, specially for people who doesn't need overscan (like me). It should be optional indeed. If I remove the setting manually, it will be put back when ES is next configured, e.g. during update.

    However, the overscan settings seem to be not very intuitive in the RPI. For example I believe that the disable_overscan config is broken in current firmware as it is not respected, i.e. it doesn't matter what you set, you always get overscan enabled.

    The overscan_scale setting is actually only needed for displays that require overscan, probably most CRT setups and some weird HDMI displays. The reason is that the overscan settings are only applied to the framebuffer, not the dispmanx layers where ES is rendered. Without overscan_scale, ES is not displayed respecting the overscan adjustment settings. For displays that do not require overscan, this setting produces no visual difference but still incurs in scaling processing by the GPU and hence overscan_scaleshould not be used.

    I think the best approach would be to put an option in the ES script GUI to enabled/disable overscan scaling (and explaining that it's only necessary for setups that require overscan adjustments) and not blindly force this during the configure phase. Actually, like @psyke83 suggested, better would be in a more general configuration scriptmodule, like raspbiantools. However raspbian does not only run for raspberry pies (I think ORA too?). How about in the retropiemenu instead?


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.