Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Atari2600 & Custom Collections!



  • @stephendm The file platforms.cfgcontains a list of permissible extensions to be listed in es_systems.cfg for a particular system. It serves no role in determining which system(s) appear in EmulationStation. The file that does this is es_systems.cfg.

    Editing es_systems.cfg is covered in this section. First you need to create a custom copy so that it doesn't get overwritten if you update or install a new emulator. You can do this with the following command:

    sudo cp /etc/emulationstation/es_systems.cfg /opt/retropie/configs/all/emulationstation/es_systems.cfg.
    

    It is the copied file in/opt/retropie/configs/all/emulationstation/ that you need to edit to add your new systems for them to appear in ES (after a restart).



  • @dudleydes

    I realised after looking at your response, cyber duck was putting me in home/pi. And this is why i could not find the es_systems.cfg.

    Anyway i decided to start afresh with a new copy of Retropie 4.4 and added the heychromey theme.

    I edited the es_systems.cfg file as you mentioned (below)

    <system>
    <name>atariflash2</name>
    <fullname>Atari Flash 2</fullname>
    <path>/home/pi/RetroPie/roms/atariflash2</path>
    <extension>.7z .a26 .bin .rom .zip .gz .7Z .A26 .BIN .ROM .ZIP .GZ</extension>
    <command>/opt/retropie/supplementary/run-command/runcommand.sh 0 SYS atari2600 %ROM%</command>
    <platform>atari2600</platform>
    <theme>heychromey</theme>
    </system>

    Added new theme artwork folder and still not getting anything, do i have to edit other files or created a new config folder and edit those files?

    Slowly going mad over this frustrating thing! all help is very much appreciated!



  • @stephendm The entry for <theme>is incorrect. It should be the name of the artwork folder.

    btw the custom es_systems.cfg file is also located in /home/pi/.emulationstation. This is a hidden folder so you would need to change the settings in Cyberduck to view it. This file is symlinked to the one in /opt/retropie/configs/all/emulationstation/ so any changes in one file will be reflected in the other.



  • @dudleydes

    Thanks for your continued assistance.

    I have adjusted the file to the artwork folder as below

    <system>
    <name>atariflash2</name>
    <fullname>Atari Flash 2</fullname>
    <path>/home/pi/RetroPie/roms/atariflash2</path>
    <extension>.7z .a26 .bin .rom .zip .gz .7Z .A26 .BIN .ROM .ZIP .GZ</extension>
    <command>/opt/retropie/supplementary/run-command/runcommand.sh 0 SYS atari2600 %ROM%</command>
    <platform>atari2600</platform>
    <theme>atariflash2</theme>
    </system>

    And created a new config folder atariflash2 and edited both files to reflect atariflash2

    But i am still only getting the config menu, am i suppose to be doing something through the menu to activated the theme, literally been on this all day and tried everything i could think of before bothering you again.

    0_1537638351520_IMG_2543.jpg



  • @stephendm Have you added any roms to the atariflash2 folder? A system will only appear in ES if it has at least one rom.



  • Hi,

    Yes, i have added the rom files to flash3 (new name) and no system shows, if i drop the roms into the 2600 folder they do show up? The roms are working, images and snaps work great in the 2600 folder?

    <system>
    <name>aflash3</name>
    <fullname>Atari Flash 3</fullname>
    <path>/home/pi/RetroPie/roms/aflash3</path>
    <extension>.7z .a26 .bin .rom .zip .gz .7Z .A26 .BIN .ROM .ZIP .GZ</extension>
    <command>/opt/retropie/supplementary/runcommand/runcommand.sh 0 SYS atari2600 %ROM%</command>
    <platform>atari2600</platform>
    <theme>aflash3</theme>
    </system>

    I have a roms folder called aflash3 and a image file in heychromey folder called aflash3

    i created a new es_systems.cfg. file and edited it to above and then used cyber duck to place it in the opt/emulation folder. I then downloaded to check it had upload correctly?

    Still get the same? No aflash3 system??



  • @stephendm Can you give the exact location of the es_systems.cfg file?



  • opt/retropie/configs/all/emulationstation/es_system.cfg.



  • @stephendm I have added your code to my copy ofes_systems.cfg, added Adventure.zip to a newly created aflash3 folder in the roms folder and the Atari Flash 3 system appears in ES after a restart.

    First, try restarting ES and see if your new system appears. ES should be restarted for any changes to es_systems.cfg to take effect or for newly added roms to appear.

    Otherwise, it may be worthwhile checking your es_systems.cfg at an XML validation site for errors.

    ES does create a log file, es_log.txt in /opt/retropie/configs/all/emulationstation/ so it may checking this file for errors.

    Feel free to post your copy of es_systems.cfg or es_log.txt at a site like pastebin.com and I can take a look.



  • @dudleydes

    have you an email, i can share a dropbox folder with you?



  • @stephendm You can put a link in this thread.



  • @dudleydes

    Yes, Forgot you could do that. :)

    checked es_system.cfg at an XML Validation site and got no errors.

    Here's the link, thanks

    https://www.dropbox.com/sh/mlj5axxw5x7ft17/AAB9aNrkaLkskzC_iUhsWNU3a?dl=0



  • @stephendm There are a lot of warning messages in es_log.txt about missing files in the heycromey theme. Could you try the default Carbon theme? Restart ES and let me know how you get on.

    Feel free to post a copy of es_log.txt after you have restarted ES if it's still not working.



  • @dudleydes

    Hi,

    No aflash3 icon yet.

    i have put a copy of the es_log.txt in shared dropbox. Thanks



  • @stephendm Line 7 in es_log.txt tells me that ES is loading the default es_systems in /etc/emulationstation, not your custom version.

    Can you run the command ls /home/pi/.emulationstation and check that es_systems.cfg exists in that folder?



  • @dudleydes said in Atari2600 & Custom Collections!:

    ls /home/pi/.emulationstation

    I have reformat my sd card, new retropie image, updated system and download new theme heychromey.
    created a new flash2 image folder and new flash2 rom folder.

    0_1537712026978_IMG_0095.JPG

    below is where i am

    0_1537711720751_Screenshot.png



  • @stephendm

    and i have dropped the latest es_log file into dropbox.

    Thanks



  • @stephendm There is a dot/period at the end of your config file, es_systems.cfg. - remove it and you should be good.



  • @dudleydes

    Hi,

    I can't believe it!!!!

    Amazing, thanks so much for your help and patience.

    Thank You SOOOOOO much!



  • @stephendm I'm glad you now have everything running as you wish.

    The spurious dot/period originates from the command I gave in an earlier post that creates a copy of es_systems.cfg , which I copied from the documentation, which I initially wrote so the error is on me.

    I cannot edit the wiki at the moment but I will fix once permissions are restored.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.