Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Keyboard hotkey setting gets overwritten when using keyboard and controller as the same player



  • HW and SW version: retropie 4.4 on raspberry 3 B+
    Keyboard: ipac4 pre 2015
    Controller: SFC30 Gamepad and SN30 Pro

    What i want to achieve:
    Using the arcade buttons on the cabinet as player one and two. Exit games without hotkey, instead use a keyboard button (f5).
    Occasionally use the controllers as player one (or one and two), using hotkey (select + start to exit games).

    Configuration:
    To test it, i focused on the nes emulator and configured the keyboard buttons in the retroarch.cfg of nes. Hotkey disabled.
    The controllers were set up via configure input in the main menu of emulationstation with hotkey enabled.

    Everything works as desired, i can use the keyboard and when i switch on a controller, i can use the controller as player one.
    When a controller is switched on, it gets mapped to player one automatically when the game starts, which is what i want (or one and two when using both controllers)

    Problem:
    When switching back to using the keyboard, it is no longer possible the use the dedicated exit button to leave the game.
    The hotkey button from the controller player one is expected to be pressed and i can exit with select (on the controller) + f5 (on the keyboard) or select + start (both on the controller).
    This stays like this, even after the controller(s) are turned off and i exit and restart a game.

    I also tried configuring the player inputs for the controller in the retroarch.cfg, but it did not work and i looked into setting up the keyboard as controller, which doesn't work with my ipac4. Using hotkey on the keyboard is not an option.

    The SN30 Pro controller can be used without hotkey, since it has extra buttons to exit. This way it works fine and thats what i use right now.

    I am new to retropie and this may be easily fixed (or maybe it is "works as designed") but i couldn't find a solution or documentation online.



  • @alain said in Keyboard hotkey setting gets overwritten when using keyboard and controller as the same player:

    e the dedicated exit button to leave the game.
    The hotkey button from the controller player one is expected to be pressed and

    there is no need do disable hotkeys at all just use game focus mode



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.