Please do not post a support request without first reading and following the advice in

No sound. Already tried several config.txts edits including hdmi_drive=2.

  • Model : Raspberry 3b
    Power Supply used: Not sure, power supply is unlabeled.
    RetroPie Version: 4.4
    Built From: Pre-made SD Image on RetroPie website
    USB Devices connected: Logitech Wireless Keyboard, Buffalo Classic controller
    Controller used: Buffalo Classic controller
    Config.txt file:

    Sound worked in emulation station and all games after initial setup.
    Problem presented after installing my Pi in a Super Kuma 9000 case
    and installing an accompanying pcb-driver that allows the power and reset button to safely shutdown and reboot the pi.
    The driver came from ""
    I can provide it in a different form if necessary.

    After installing the driver and ensuring it worked I sat down to finally play some games when I realized I had no sound.
    I tried switching hdmi ports on my tv, rebooting, commenting out hdmi_drive=2 in the config.txt file, ensuring retroarch.cfg is using alsa (which seems to be the correct option for me, question mark?) and basically every suggestion I could find.
    I also edited config.txt to include:


    I'm a little at my wit's end here.
    I'm sure everyone is tired of people whining about no sound, but I really did my due diligence on trying to solve this one.

    Any help is appreciated.

  • Global Moderator

    The case does not interfere with the audio. make sure your TV isn't muted and the check the sound card volume from Emulationstation.

  • I only mentioned the case and pcb script as I lost audio after completing the installation.
    I just double-checked my tv audio and my audio settings in emulation station with no luck.

  • Global Moderator

    @LaikaReturns Can you check with sudo raspi-config from a command line that your audio is set to HDMI ? If you run alsamixer from a terminal, what's the audio volume set to ?

  • I just powered on my Pi to double check what you asked me to, Audio is set to HDMI in raspi-config and alsamixer shows a volume level of 100, but during boot up I noticed I had sound again.
    The only change was a night of sleep, doubt it was that, and me swapping hdmi cables from my pi to my PS4 and back.
    My tv is pretty old, so maybe it is messing up the edid?
    I did make changes in config.txt that should force it to recognize the hdmi, but that didn't seem to help before.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.