Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Kodi Add-ons not responding on Retropie



  • Hi guys, new here and obviously need some help. I am new to Retropie thing though.

    Today I was trying to install some Kodi addons on my Retropie. The Kodi addons I am trying to install on Retropie work smoothly on my Amazon Fire TV Stick, so I thought it would also work on Retropie with Kodi.

    There are a couple of addons that I was trying to install (complete list [here][REMOVED]) and Kodi was downloaded from the Official website Kodi.tv. I was able to install a few but after installing 3 addons no addons respond when I try to launch them. The problem seems to be occurring since I installed restarted Kodi after installing the addons. Whenever I launch Kodi and try to work with a Addon-on a black screen appears and stays there without any error message nothing. I have no idea what may have caused the issue and irrespective of how much I try, I am unable to get it working.

    I doubt if the problem is with the addons as they work perfectly fine with my Fire TV stick.

    If anyone could point me in the right direction on how to resolve this problem, it would be of great help.



  • @arif This is the support forum for retropie and the kodi addons that you link are illegal and will not be supported even on the Kodi forums because they allow access to pirated content.


  • Global Moderator

    @rbaker i think it's just spam.


  • Global Moderator

    @arif Please don't post links to dodgy Kodi add-ons, it's agains the forum rules. For any detailed Kodi usage, as @rbaker said, use the Kodi forum. Thank you.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.