Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Xbox One Blue Tooth Joy-Pad Connection Problem



  • As someone who uses Xbox One bluetooth controllers exclusively on my Pi (because they are so doggone comfortable), I think I might be able to help. But just to clarify, your post title says Xbox One controller, but you reference Xbox 360 Bluetooth in your statement. I'm not familiar with any Xbox 360 Bluetooth functionality, but my Xbox One bluetooth controllers work flawlessly with the following setup:

    1. As another comment suggested, power is important. I use the Northprada 5 volt 3 amp adapter and have had zero low power issues.

    2. Don't enable the Udev rule for the controller. If you have already enabled it, delete it from /etc/udev/rules.d/99-bluetooth.rules files and save/reboot.

    3. As the tutorial recommends, make sure that ertm is disabled in your
      /opt/retropie/configs/all/autostart.sh. Like this:
      sudo bash -c 'echo 1 > /sys/module/bluetooth/parameters/disable_ertm'

    4. Even with a good AC adapter, the onboard bluetooth, even on my P3 B+ just doesn't quite have enough oomph for my liking, especially with my 4 bluetooth controllers. I highly recommend getting a 'Plugable USB Bluetooth 4.0 Low Energy Micro Adapter '

    5. When you get the bluetooth adapter, plug it in to an available usb port and edit '/boot/config.txt' and add/save the following to disable the Pi's onboard bluetooth:
      #Disable Bluetooth
      dtoverlay=pi3-disable-bt

    6. Get the xpadneo Linux driver for RetroPie from here: https://github.com/atar-axis/xpadneo
      This fixes all of the button mapping issues with Xbox One Bluetooth, as well as adding rumble support.

    7. Follow the normal RetroPie Setup/Configuration-Tools/Bluetooth process for adding your controller. Make sure all 'old' bluetooth devices are deleted prior to adding new.
      Bluetooth connection mode is set to 'Background'
      No Udev rules enabled

    I am currently running 4 Xbox One controllers via bluetooth simultaneously. Again, this works great for my setup, but I can't guarantee anything. Hope this helps!



  • Wow thanks guys.

    @rbaker: The power cable connects directly to a twin USB / twin plug socket wall mount. My previous cable gave me problems, low power errors and lightning bolt icons but this one has displayed none of those errors so far.

    @theretroprince: I deleted the Udev file, rebooted and reconnected, it failed with an error. rebooted and tried again. Now it works fine even after a reboot. Even the xbox button works now (button 16).

    Multi joy-pad wise I may try a blue tooth PS4 pad at some stage as a second controller. No rush yet though.

    Unless anything changes consider this one solved.

    [edit] How do I install that driver (I have saved it to my PC)? Having played a few games I'm not sure that the buttons are mapping correctly. For example none of the buttons will get me past the date/time update screen on Reicast.



  • No problem. If you do experience controller disconnects (especially if you add another bluetooth controller), the bluetooth USB adapter is the way to go.

    If you are actually using an Xbox One Bluetooth controller, there are install instructions on the xpadneo website. You don't want to install this if you are using anything other than an Xbox One Bluetooth Controller (Model # should be 1708 and you can find this in the battery compartment), or if all of your buttons respond normally in jstest .

    For the Xpadneo install itself, I don't believe you need to install any of the prerequisites if you are using the latest Stretch 4.4 distro. You can just go down to the Installation section on the page and execute the git download and install commands from a command line, provided that you have your Pi connected to the internet. Skip the connection section as bluetooth connection can be done easier in RetroPie-Setup.

    As for your Reicast problem, it is not a Libretro emulator, so you have to configure your inputs manually. You can do this in RetroPie-Setup/Configuration-Tools/Reicast/Configure Input devices for Reicast.



  • @George-Spiggott said in Xbox One Blue Tooth Joy-Pad Connection Problem:

    directly to a twin USB

    You should check that it can deliver 2.5A from one port which is unlikely. If it is labelled 2.5A, it is likely rated at that accross the device. I recommend a proper power supply as opposed to a charger.



  • @theretroprince: It's been a few days now and all seems good with the internal Bluetooth. I've sorted the Reicast controls problem. My latest problem is getting the PSX hi res graphics 'shortcut' to work (select + X) . I'm not sure if this is a pad problem or something else.

    @rbaker: Not sure what the output is. I've got the spark who installed it coming over in a couple of weeks so I'll get him to check it. I'm not currently suffering from any power issues that I am aware of. The only other device connected to the USB is a Bluetooth link for my amp (allows phone output to be played through my amp) and that isn't in use while my Pi is because they both use the same amp/speakers.

    Is there a way in software (a command pr program) for the Pi to show what power it is receiving?



  • @George-Spiggott I don't think there is a way to monitor the stats on the raspberry pi 5v rail, at least not without an external solution. Best bet is to always use a decent, proven adapter that you know will deliver goodpower as @rbaker suggested. Power issues can have a negative impact both on performance and device life.

    I'm not aware of a specific shortcut for setting PSX into high-res (in lr-pcsx-rearmed), other than entering the Retroarch menu, going into options and changing the settings. (Or manually editing the config file) I could be wrong, though.



  • @theretroprince said in Xbox One Blue Tooth Joy-Pad Connection Problem:

    As someone who uses Xbox One bluetooth controllers exclusively on my Pi (because they are so doggone comfortable), I think I might be able to help. But just to clarify, your post title says Xbox One controller, but you reference Xbox 360 Bluetooth in your statement. I'm not familiar with any Xbox 360 Bluetooth functionality, but my Xbox One bluetooth controllers work flawlessly with the following setup:

    1. As another comment suggested, power is important. I use the Northprada 5 volt 3 amp adapter and have had zero low power issues.

    2. Don't enable the Udev rule for the controller. If you have already enabled it, delete it from /etc/udev/rules.d/99-bluetooth.rules files and save/reboot.

    3. As the tutorial recommends, make sure that ertm is disabled in your
      /opt/retropie/configs/all/autostart.sh. Like this:
      sudo bash -c 'echo 1 > /sys/module/bluetooth/parameters/disable_ertm'

    4. Even with a good AC adapter, the onboard bluetooth, even on my P3 B+ just doesn't quite have enough oomph for my liking, especially with my 4 bluetooth controllers. I highly recommend getting a 'Plugable USB Bluetooth 4.0 Low Energy Micro Adapter '

    5. When you get the bluetooth adapter, plug it in to an available usb port and edit '/boot/config.txt' and add/save the following to disable the Pi's onboard bluetooth:
      #Disable Bluetooth
      dtoverlay=pi3-disable-bt

    6. Get the xpadneo Linux driver for RetroPie from here: https://github.com/atar-axis/xpadneo
      This fixes all of the button mapping issues with Xbox One Bluetooth, as well as adding rumble support.

    7. Follow the normal RetroPie Setup/Configuration-Tools/Bluetooth process for adding your controller. Make sure all 'old' bluetooth devices are deleted prior to adding new.
      Bluetooth connection mode is set to 'Background'
      No Udev rules enabled

    I am currently running 4 Xbox One controllers via bluetooth simultaneously. Again, this works great for my setup, but I can't guarantee anything. Hope this helps!

    hi
    im trying to get my x1 bluetooth controller to work right can you help with what this means No Udev rules enabled im new to all of this

    thanks



  • @lip9571 Just follow the video I linked to in the OP. Keep retrying if it doesn't work first time.



  • @lip9571 The udev rules are an option that you can automatically set in RetroPie-setup. They just write a line of configuration to your bluetooth rules. It is not enabled by default. As long as you haven't enabled them, you don't need to concern yourself with them. If you have enabled it, you can disable it within the Bluetooth setup in RetroPie-Setup.



  • @theretroprince said in Xbox One Blue Tooth Joy-Pad Connection Problem:

    @lip9571 The udev rules are an option that you can automatically set in RetroPie-setup. They just write a line of configuration to your bluetooth rules. It is not enabled by default. As long as you haven't enabled them, you don't need to concern yourself with them. If you have enabled it, you can disable it within the Bluetooth setup in RetroPie-Setup.

    Thanks for the reply. I got it all working in the end all I need to do was re bind the buttons for Bluetooth in retro arch and it worked perfect



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.