Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

SOLVED: Frogger on MAME4ALL-Pi, Intermittent Audio



  • Frogger on MAME4ALL-Pi: Intermittent Audio

    Pi Model: 3 Model B
    RetroPie Version Used: 3.8.1
    Built From: SD Image
    USB Devices connected: Standard keyboard, x2 Buffalo Classic USB Gamepad
    Controller used: x2 Buffalo Classic USB Gamepad
    Error messages received: n/a
    Guide used: n/a
    File: /boot/config.txt
    Emulator: MAME4ALL-Pi
    Attachment of config files: n/a all original
    How to replicate the problem:

    • Obtain 0.37b5 frogger rom (frogger.zip)
    • Place frogger rom in MAME4ALL-Pi rom folder: /home/pi/RetroPie/roms/mame-mame4all
    • Select Frogger in Emulation Station on RetroPie
    • Insert player one coin(s): press 5 on keyboard
    • Press player one start: press 1 on keyboard
    • After playing for a few seconds the sound cuts out, and a short while later cuts in again.

    Things I've done to resolve this issue:

    • Via Emulation Station, under RetroPie>Audio
      • set audio input to HDMI
    • Via Emulation Station, under RetroPie>RetroPie Setup>Setup / Tools>audiosettings
      • set audio input to HDMI
      • I think this is the same thing as I did above
    • Troubleshoot using the Sound Issues page on RetroPie Wiki
      • Edited /boot/config.txt uncommenting hdmi_drive=2
      • Restarted emulation station
      • Rebooted Raspberry Pi
      • Tried again, same issue
      • Re-commented /boot/config.txt hdmi_drive=2
      • Restarted emulation station
      • Rebooted Raspberry Pi
    • Referenced R-Pi Troubleshooting: "Sound does not work with an HDMI monitor"
      • Since I have consistent sound via HDMI on everything but Frogger via MAME, I wasn't sure if anything listed would help.
    • Tried choosing lr-imame4all for Frogger only
    • Searched RetroPie Wiki
    • Searched on the web
      • I don't see anything specific to my issue concerning RetroPie

    Also, Donkey Kong and Donkey Kong Junior audio is choppy. I have the sampled audio here:

    /home/pi/RetroPie/roms/mame-mame4all/samples
    

    Any help on this is appreciated!



  • Ok, this may not help, but I just tried the same setup and I had no audio on frogger at all.
    I went into the RetroPie menu in ES, used first Audio option and set to HDMI (Although I see you have tried this)
    Frogger then had perfect audio.
    Set Audio back to "Auto" in that menu, and when I loaded frogger it was still fine.

    Could I suggest checking your power is 2.5A / 5.1V, and maybe try it with a different HDMI cable or TV?
    As far as I can see that is the only difference in our setups. I presume your frogger.zip is validated as 0.37b5?



  • Hi Floob!

    @Floob said in Frogger on MAME4ALL-Pi: Intermittent Audio:

    Ok, this may not help, but I just tried the same setup and I had no audio on frogger at all.
    I went into the RetroPie menu in ES, used first Audio option and set to HDMI (Although I see you have tried this)
    Frogger then had perfect audio.
    Set Audio back to "Auto" in that menu, and when I loaded frogger it was still fine.

    I tried setting the audio settings back to "Auto" with the same issues.

    Could I suggest checking your power is 2.5A / 5.1V, and maybe try it with a different HDMI cable or TV?

    I got the CanaKit Raspberry Pi 3 Complete Starter Kit which includes a 5v 2.5A USB power supply with micro USB cable and noise filter, should I find a 5.1VDC 2.5A version?

    I don't see the low power icon on the top right of the interface that I've read about if there may be power issues.

    As far as I can see that is the only difference in our setups. I presume your frogger.zip is validated as 0.37b5?

    Yes, 0.37b5. I'll scan with clrmame and see if there are any issues. In ES I don't see any missing file warnings, but maybe the rom is corrupt?



  • On RetroPie/mame4all-pi on GitHub I saw:

    If you're having problems with HDMI audio then it is likely PulseAudio is causing the issues as it has problems with the ALSA drivers. To fix this simply remove PulseAudio:

    • sudo apt-get --purge remove pulseaudio
    • sudo apt-get autoremove

    Additionally some TVs have problems with mono sound through HDMI, to fix this try setting the "force_stereo" to "yes" in mame.cfg.

    I'll try setting "force_stereo" to "yes" in mame.cfg.

    I'm afraid to remove pulseaudio since I wouldn't know how to reinstall it and configure (?) if it's not the issue.



  • @briankross said in Frogger on MAME4ALL-Pi: Intermittent Audio:

    I'll try setting "force_stereo" to "yes" in mame.cfg.

    Same issue, but I don't see the harm in leaving it set to "yes".

    I'm afraid to remove pulseaudio since I wouldn't know how to reinstall it and configure (?) if it's not the issue.

    So... remove pulseaudio?


  • administrators

    In case it's not related directly to a emulator configuration or rom -

    Could also be related to the HDMI signal - can try changing config_hdmi_boost in /boot/config.txt

    also see http://elinux.org/R-Pi_Troubleshooting#Sound_does_not_work_with_an_HDMI_monitor (could be related to how your monitor handles the audio) - you should try from the audio jack to see.



  • Thanks everyone!

    I found the solution for my setup. In short, the solution was to use the audio on my TV rather than my home theater system.

    My Setup

    • My setup is a small home theater, not a dedicated display for retro awesomeness...
      • Raspberry Pi 3 HDMI output to TV
      • TV volume all the way down
      • Optical S/PDIF out to Bose speaker system

    As it turns out, this is okay for some MAME games, not frogger or most anything that needs samples. It sounds like some of the audio durations are too short to come through the system. Perhaps it needs to un-mute the Bose amplifier and fade in, but by then it's too late to hear anything more than a slight pop.

    Solution

    • Raspberry Pi 3 HDMI output to TV
    • Use TV volume (don't route audio through home theater, it can be plugged in but not used)

    I put all of the config files back to default, I think..., and all of my mame and nes games seem to sound good with some quick testing.

    All is well in retro land. I hope this helps someone else!



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.