Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Crt Pi Curve shader causing slowdown



  • hello everyone.
    im using a pi3 b not the plus with the latest upto date image from this site.

    I am using retrorama theme with the retrorama overlays.
    When using these overlays with the crt pi curve shader i notice some stuttering and slowdown.
    This is mainly with emulators for psx and snes these are the worst 2 and are also pretty much unplayeable with how choppy they are.
    if i disable the crt pi curve shader they work 100%.
    Is this a problem my end or is this what just happens.
    Any help very much appreciated
    Thanks
    Rob


  • Global Moderator

    Shaders do have a performance impact - especially with a large resolution. In your case, using shaders with overlays probably adds to it. You can try the alternative zfast_crt_curved shaders, they're optimized for the Pi also, maybe you'll have better results.



  • The zfast one is still as bad to be honest.
    Kinda makes sense though as it doesn't do it on the tv in my conservatory but that tv is only a 720p.
    The one in my front room which the pi is currently connected to is a 4k tv.
    Is there any way to force the pi to a certain resolution or will the image start to look ugly if I do that.
    Thanks
    Rob



  • Also these overlays from lipbello are designed for the crt pi curve shader, if I disable the shader the image overlaps the overlay in the corners where they curve.
    Thanks


  • Global Moderator

    @robmcc83 said in Crt Pi Curve shader causing slowdown:

    The one in my front room which the pi is currently connected to is a 4k tv.

    What is the resolution the TV is running with the Pi connected ? You should find out from the TV remote menus. You can force a certain resolution from the Runcommand launch menu - see https://retropie.org.uk/docs/Speed-Issues/#resolution.

    As for the bezels, try to find the ones that fit your resolution.



  • @mitu
    My tv is running at 1920x1080.
    In regards to that documentation and it saying put my input on game mode, that is not possible on my tv. If I have it on game mode the picture doesn't fill my screen, then when I select no to overscan within raspi-config the picture goes over the size of my tv screen.
    The only setting that work on my tv is to select pc mode for input and then select no to overscan in raspi-config. That way it fills my tv screen perfectly.
    This wouldn't effect the problem I'm having with sharers though? surely not
    Thanks
    Rob



  • And I've also just checked my overlays and they are 1920x1080 so they do match my tv.
    Thanks


  • Global Moderator

    @robmcc83 said in Crt Pi Curve shader causing slowdown:

    And I've also just checked my overlays and they are 1920x1080 so they do match my tv.

    Yes, but as you said, they're meant to be used with the curvature shader, so that's why they probably look like this. What I meant is to use normal (i.e. non-curvature designed) bezels. As for the shader - you'll have to choose to either disable it on the systems where is impacting performance or lower your resolution if you still want to use it.



  • Ok thank you I get you now.
    I have a big collection of bezels that of got over the years but they are all curved.
    Where would I get some basic non curved ones.
    Thanks


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.